aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-03-02 14:49:10 +0800
committerrafan <rafan@FreeBSD.org>2008-03-02 14:49:10 +0800
commite7287b04530503db6a38238e443fca5085931ef8 (patch)
tree4d7f5f68fab3209b463da27196a537f124085c3e
parent5d61c139033a950d3b498c76b2b275c7dc4313ce (diff)
downloadfreebsd-ports-gnome-e7287b04530503db6a38238e443fca5085931ef8.tar.gz
freebsd-ports-gnome-e7287b04530503db6a38238e443fca5085931ef8.tar.zst
freebsd-ports-gnome-e7287b04530503db6a38238e443fca5085931ef8.zip
- Restore previous patch that disables buggy assembly. This fixes build
on 5.x and 6.x. Noticed by: marcus@ Approved by: maintainer (implicit)
-rw-r--r--devel/pwlib/Makefile4
-rw-r--r--devel/pwlib/files/patch-src_ptlib_common_jidctflt.cxx12
2 files changed, 12 insertions, 4 deletions
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index 2e9f5bd51105..cfa31bd4cce6 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -31,10 +31,6 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-BROKEN= does not compile
-.endif
-
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -O1 -I${WRKSRC}/include -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
diff --git a/devel/pwlib/files/patch-src_ptlib_common_jidctflt.cxx b/devel/pwlib/files/patch-src_ptlib_common_jidctflt.cxx
new file mode 100644
index 000000000000..b47f7ae97b6c
--- /dev/null
+++ b/devel/pwlib/files/patch-src_ptlib_common_jidctflt.cxx
@@ -0,0 +1,12 @@
+--- src/ptlib/common/jidctflt.cxx.orig Wed Apr 5 07:08:00 2006
++++ src/ptlib/common/jidctflt.cxx Wed Apr 5 07:08:08 2006
+@@ -97,7 +97,8 @@
+ #define DEQUANTIZE(coef,quantval) (((FAST_FLOAT) (coef)) * (quantval))
+
+
+-#if defined(__GNUC__) && (__GNUC__ >= 3) && (defined(__i686__) || defined(__x86_64__)) && (!defined(P_64BIT)) && (!defined(__MACOSX__))
++/* asm doesn't compile properly... avoid using */
++#if 0
+
+ static inline unsigned char descale_and_clamp(int x, int shift)
+ {