aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2010-01-09 04:02:31 +0800
committerdhn <dhn@FreeBSD.org>2010-01-09 04:02:31 +0800
commite83ae7215b614b817ea7f832f0423ceb856e8d7a (patch)
treee9499560beac884858e8d3d916d04c02950b89ae
parent6ee4d400ffbc793db5006831cc9cf0017895960d (diff)
downloadfreebsd-ports-gnome-e83ae7215b614b817ea7f832f0423ceb856e8d7a.tar.gz
freebsd-ports-gnome-e83ae7215b614b817ea7f832f0423ceb856e8d7a.tar.zst
freebsd-ports-gnome-e83ae7215b614b817ea7f832f0423ceb856e8d7a.zip
- Add patch that's fix core dump, when an FTP server rejects a
file retrieval operation with permission denied. - bump PORTREVISION PR: ports/142454 Submitted by: Aragon Gouveia <aragon@phat.za.net>
-rw-r--r--sysutils/fusefs-curlftpfs/Makefile2
-rw-r--r--sysutils/fusefs-curlftpfs/files/patch-ftpfs.c19
2 files changed, 20 insertions, 1 deletions
diff --git a/sysutils/fusefs-curlftpfs/Makefile b/sysutils/fusefs-curlftpfs/Makefile
index d1e651117409..43c2a9d14922 100644
--- a/sysutils/fusefs-curlftpfs/Makefile
+++ b/sysutils/fusefs-curlftpfs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= curlftpfs
PORTVERSION= 0.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= SF
PKGNAMEPREFIX= fusefs-
diff --git a/sysutils/fusefs-curlftpfs/files/patch-ftpfs.c b/sysutils/fusefs-curlftpfs/files/patch-ftpfs.c
new file mode 100644
index 000000000000..42f6e1c4ee12
--- /dev/null
+++ b/sysutils/fusefs-curlftpfs/files/patch-ftpfs.c
@@ -0,0 +1,19 @@
+--- ./ftpfs.c.orig 2008-04-30 01:05:47.000000000 +0200
++++ ./ftpfs.c 2010-01-08 19:14:39.000000000 +0100
+@@ -611,10 +611,12 @@
+ curl_easy_cleanup(fh->write_conn);
+ g_free(fh->full_path);
+ g_free(fh->open_path);
+- sem_destroy(&fh->data_avail);
+- sem_destroy(&fh->data_need);
+- sem_destroy(&fh->data_written);
+- sem_destroy(&fh->ready);
++ if (fh->data_avail) {
++ sem_destroy(&fh->data_avail);
++ sem_destroy(&fh->data_need);
++ sem_destroy(&fh->data_written);
++ sem_destroy(&fh->ready);
++ }
+ free(fh);
+ }
+