aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-17 21:00:50 +0800
committermiwi <miwi@FreeBSD.org>2009-05-17 21:00:50 +0800
commite8a6ead676231bb4f13cbed674107ab4dc925c81 (patch)
tree36e9d532bfc55053129b75b8671e9c674008ecdb
parentc3279820d0db40965ad7c5a534da8d979ee35ca6 (diff)
downloadfreebsd-ports-gnome-e8a6ead676231bb4f13cbed674107ab4dc925c81.tar.gz
freebsd-ports-gnome-e8a6ead676231bb4f13cbed674107ab4dc925c81.tar.zst
freebsd-ports-gnome-e8a6ead676231bb4f13cbed674107ab4dc925c81.zip
Chemistry-MacroMol is a toolkit includes basic objects and methods to
describe macromolecules, a macromolecule is just a molecule that consists of several "domains". For example, a protein consists of aminoacid residues, or a nucleic acid consists of bases. Therefore Chemistry::MacroMol is derived from Chemistry::Mol, with additional methods to handle the domains. WWW: http://search.cpan.org/dist/Chemistry-MacroMol/ PR: ports/134609 Submitted by: Wen Heping <wenheping at gmail.com>
-rw-r--r--science/Makefile1
-rw-r--r--science/p5-Chemistry-MacroMol/Makefile24
-rw-r--r--science/p5-Chemistry-MacroMol/distinfo3
-rw-r--r--science/p5-Chemistry-MacroMol/pkg-descr8
-rw-r--r--science/p5-Chemistry-MacroMol/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 4ada82482c15..553e03bb8695 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -98,6 +98,7 @@
SUBDIR += p5-Algorithm-SVMLight
SUBDIR += p5-Chemistry-Elements
SUBDIR += p5-Chemistry-File-PDB
+ SUBDIR += p5-Chemistry-MacroMol
SUBDIR += p5-Chemistry-Mol
SUBDIR += p5-Geo-ReadGRIB
SUBDIR += paje
diff --git a/science/p5-Chemistry-MacroMol/Makefile b/science/p5-Chemistry-MacroMol/Makefile
new file mode 100644
index 000000000000..865a1d9dd475
--- /dev/null
+++ b/science/p5-Chemistry-MacroMol/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Chemistry-MacroMol
+# Date created: 17 May, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chemistry-MacroMol
+PORTVERSION= 0.06
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Perl toolkit to describe macromolecules
+
+BUILD_DEPENDS= p5-Chemistry-Mol>=0.37:${PORTSDIR}/science/p5-Chemistry-Mol
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Chemistry::MacroMol.3 Chemistry::Domain.3
+
+.include <bsd.port.mk>
diff --git a/science/p5-Chemistry-MacroMol/distinfo b/science/p5-Chemistry-MacroMol/distinfo
new file mode 100644
index 000000000000..52c021dac4cb
--- /dev/null
+++ b/science/p5-Chemistry-MacroMol/distinfo
@@ -0,0 +1,3 @@
+MD5 (Chemistry-MacroMol-0.06.tar.gz) = 2aa357a957f36e247535ec396744fd93
+SHA256 (Chemistry-MacroMol-0.06.tar.gz) = 37c33b1a72a80905983ff1f9b373e40b7f1ea5441c2108e9f7d16d772f9e3079
+SIZE (Chemistry-MacroMol-0.06.tar.gz) = 2953
diff --git a/science/p5-Chemistry-MacroMol/pkg-descr b/science/p5-Chemistry-MacroMol/pkg-descr
new file mode 100644
index 000000000000..604de0e37b52
--- /dev/null
+++ b/science/p5-Chemistry-MacroMol/pkg-descr
@@ -0,0 +1,8 @@
+Chemistry-MacroMol is a toolkit includes basic objects and methods to
+describe macromolecules, a macromolecule is just a molecule that
+consists of several "domains". For example, a protein consists
+of aminoacid residues, or a nucleic acid consists of bases. Therefore
+Chemistry::MacroMol is derived from Chemistry::Mol, with additional
+methods to handle the domains.
+
+WWW: http://search.cpan.org/dist/Chemistry-MacroMol/
diff --git a/science/p5-Chemistry-MacroMol/pkg-plist b/science/p5-Chemistry-MacroMol/pkg-plist
new file mode 100644
index 000000000000..0520114ae46a
--- /dev/null
+++ b/science/p5-Chemistry-MacroMol/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Chemistry/Domain.pm
+%%SITE_PERL%%/Chemistry/MacroMol.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Chemistry/MacroMol/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chemistry/MacroMol
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chemistry
+@dirrmtry %%SITE_PERL%%/Chemistry