aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-05-24 01:56:55 +0800
committermiwi <miwi@FreeBSD.org>2013-05-24 01:56:55 +0800
commiteaf674775eae700fabb43cd73706b5600c4ec0c2 (patch)
tree91b6b5b6ba186e38ffe5feb20acc4953710288b9
parent29596d87163a625c425f09540ebd3111b05cedc3 (diff)
downloadfreebsd-ports-gnome-eaf674775eae700fabb43cd73706b5600c4ec0c2.tar.gz
freebsd-ports-gnome-eaf674775eae700fabb43cd73706b5600c4ec0c2.tar.zst
freebsd-ports-gnome-eaf674775eae700fabb43cd73706b5600c4ec0c2.zip
- Update to 1.2
PR: 177765 Submitted by: Ports Fury
-rw-r--r--math/py-ffc/Makefile19
-rw-r--r--math/py-ffc/distinfo4
-rw-r--r--math/py-ffc/pkg-plist16
3 files changed, 28 insertions, 11 deletions
diff --git a/math/py-ffc/Makefile b/math/py-ffc/Makefile
index a24a50c9cd0a..686c2142e068 100644
--- a/math/py-ffc/Makefile
+++ b/math/py-ffc/Makefile
@@ -1,29 +1,30 @@
-# New ports collection makefile for: py-ffc
-# Date created: 12 April 2012
-# Whom: Jason Bacon <jwbacon@tds.net>
-#
+# Created by: Jason Bacon <jwbacon@tds.net>
# $FreeBSD$
-#
PORTNAME= ffc
-PORTVERSION= 1.0.0
+PORTVERSION= ${MMVERSION}.0
CATEGORIES= math python
-MASTER_SITES= https://launchpad.net/${PORTNAME}/1.0.x/${PORTVERSION}/+download/
+MASTER_SITES= https://launchpad.net/${PORTNAME}/${MMVERSION}.x/${PORTVERSION}/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jwbacon@tds.net
COMMENT= C++ code generator for multilinear forms
+LICENSE= LGPL3
+
USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= FFC
-FETCH_ARGS= -Fpr
+FETCH_ARGS= -F
MAN1= ffc.1
MANCOMPRESSED= yes
+MMVERSION= 1.2
+
post-patch:
- @${REINPLACE_CMD} -e 's|"usr")|"usr", "local")|g' ${WRKSRC}/test/regression/test.py
+ ${REINPLACE_CMD} -i '' -e 's|os.path.join(os.path.sep, "usr")|os.path.normpath("${PREFIX}")|' \
+ ${WRKSRC}/test/regression/test.py
.include <bsd.port.mk>
diff --git a/math/py-ffc/distinfo b/math/py-ffc/distinfo
index cce5ab40992c..3f92c7818c2a 100644
--- a/math/py-ffc/distinfo
+++ b/math/py-ffc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ffc-1.0.0.tar.gz) = 04582684b3b8640029ccf287dcf6dfd38cc90a7c2b851ce9b941ba46fe03c512
-SIZE (ffc-1.0.0.tar.gz) = 3938612
+SHA256 (ffc-1.2.0.tar.gz) = ac7cca537dac4610821c9ecb0338700970d713d03a9bc176567f1979c89ed869
+SIZE (ffc-1.2.0.tar.gz) = 4457544
diff --git a/math/py-ffc/pkg-plist b/math/py-ffc/pkg-plist
index e733412d974b..d288322361f7 100644
--- a/math/py-ffc/pkg-plist
+++ b/math/py-ffc/pkg-plist
@@ -131,6 +131,9 @@ bin/ffc
%%PYTHON_SITELIBDIR%%/ffc/representation.py
%%PYTHON_SITELIBDIR%%/ffc/representation.pyc
%%PYTHON_SITELIBDIR%%/ffc/representation.pyo
+%%PYTHON_SITELIBDIR%%/ffc/representationutils.py
+%%PYTHON_SITELIBDIR%%/ffc/representationutils.pyc
+%%PYTHON_SITELIBDIR%%/ffc/representationutils.pyo
%%PYTHON_SITELIBDIR%%/ffc/restrictedelement.py
%%PYTHON_SITELIBDIR%%/ffc/restrictedelement.pyc
%%PYTHON_SITELIBDIR%%/ffc/restrictedelement.pyo
@@ -170,12 +173,25 @@ bin/ffc
%%PYTHON_SITELIBDIR%%/ffc/tensor/tensorrepresentation.py
%%PYTHON_SITELIBDIR%%/ffc/tensor/tensorrepresentation.pyc
%%PYTHON_SITELIBDIR%%/ffc/tensor/tensorrepresentation.pyo
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/__init__.py
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/__init__.pyc
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/__init__.pyo
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/uflacsgenerator.py
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/uflacsgenerator.pyc
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/uflacsgenerator.pyo
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/uflacsoptimization.py
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/uflacsoptimization.pyc
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/uflacsoptimization.pyo
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/uflacsrepresentation.py
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/uflacsrepresentation.pyc
+%%PYTHON_SITELIBDIR%%/ffc/uflacsrepr/uflacsrepresentation.pyo
%%PYTHON_SITELIBDIR%%/ffc/utils.py
%%PYTHON_SITELIBDIR%%/ffc/utils.pyc
%%PYTHON_SITELIBDIR%%/ffc/utils.pyo
%%PYTHON_SITELIBDIR%%/ffc/wrappers.py
%%PYTHON_SITELIBDIR%%/ffc/wrappers.pyc
%%PYTHON_SITELIBDIR%%/ffc/wrappers.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/ffc/uflacsrepr
@dirrm %%PYTHON_SITELIBDIR%%/ffc/tensor
@dirrm %%PYTHON_SITELIBDIR%%/ffc/quadrature
@dirrm %%PYTHON_SITELIBDIR%%/ffc/errorcontrol