aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-05 14:59:44 +0800
committerbapt <bapt@FreeBSD.org>2013-06-05 14:59:44 +0800
commiteb3b55991b7b83e752e8607da2a08cdd4280fda3 (patch)
treeb82a15c1c2abb7b630a28553f94dd9b28132b670
parent569c8f66c77c094dd7d78b267e89eb132bb86016 (diff)
downloadfreebsd-ports-gnome-eb3b55991b7b83e752e8607da2a08cdd4280fda3.tar.gz
freebsd-ports-gnome-eb3b55991b7b83e752e8607da2a08cdd4280fda3.tar.zst
freebsd-ports-gnome-eb3b55991b7b83e752e8607da2a08cdd4280fda3.zip
Convert to new options framework
-rw-r--r--www/gatling/Makefile32
-rw-r--r--www/horde3-meta/Makefile85
-rw-r--r--www/links-hacked/Makefile33
3 files changed, 70 insertions, 80 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index f2eca1af6e88..b99190fdf601 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -1,9 +1,5 @@
-# Ports collection Makefile for: gatling
-# Date created: Feb 21, 2004
-# Whom: Thomas-Martin Seck <tmseck@netcologne.de>
-#
+# Created by: Thomas-Martin Seck <tmseck@netcologne.de>
# $FreeBSD$
-#
PORTNAME= gatling
PORTVERSION= 0.13
@@ -35,15 +31,15 @@ PORTDOCS= CHANGES README README.antidos README.cgi README.ftp \
PORTEXAMPLES= run-gatling cgi acc getlinks hcat hitprofile matchiprange \
referrer
-OPTIONS= GATLING_BENCHMARKS "Install some benchmark programs" on \
- GATLING_SMB "Add (read only) SMB support" on \
- GATLING_TLS "Build and install tlsgatling" on \
- GATLING_ZLIB "Compress outgoing data" on \
- GATLING_OPTIMIZED_CFLAGS "Add additional optimizations" on
+OPTIONS_DEFINE= BENCHMARKS SMB TLS ZLIB OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= BENCHMARKS SMB TLS ZLIB OPTIMIZED_CFLAGS
+BENCHMARKS_DESC= Install some benchmark programs
+TLS_DESC= Build and install tlsgatling
+ZLIB_DESC= Compress outgoing data
.include <bsd.port.pre.mk>
-.if defined(WITH_GATLING_BENCHMARKS) || defined(WITH_BENCHMARKS)
+.if ${PORT_OPTIONS:MBENCHMARKS}
PORTDOCS+= README.bindbench README.forkbench README.httpbench \
README.manymapbench README.mmapbench
bin+= bindbench forkbench forksbench httpbench ioerr manymapbench \
@@ -53,11 +49,11 @@ MAN1+= bench.1
MAKE_ENV+= BENCHMARKS=1
.endif
-.if defined(WITH_GATLING_OPTIMIZED_CFLAGS) && !defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS} && !defined(WITH_DEBUG)
CFLAGS+= -O2 -fomit-frame-pointer
.endif
-.if defined(WITH_GATLING_SMB)
+.if ${PORT_OPTIONS:MSMB}
USES+= iconv
CFLAGS+= -I${LOCALBASE}/include
MAKE_ENV+= ICONV=1
@@ -65,17 +61,17 @@ MAKE_ENV+= ICONV=1
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-disable_smb
.endif
-.if defined(WITH_GATLING_TLS)
+.if ${PORT_OPTIONS:MTLS}
MAKE_ENV+= TLSGATLING=1
sbin+= tlsgatling
PORTDOCS+= README.tls
.endif
-.if defined(WITH_GATLING_ZLIB)
+.if ${PORT_OPTIONS:MZLIB}
MAKE_ENV+= ZLIB=1
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
MAKE_ENV+= DEBUG=1
STRIP=
.endif
@@ -93,7 +89,7 @@ do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} ${bin} ${PREFIX}/bin
cd ${WRKSRC} && ${INSTALL_PROGRAM} ${sbin} ${PREFIX}/sbin
${INSTALL_SCRIPT} ${FILESDIR}/gatling_wrapper ${PREFIX}/sbin
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_SCRIPT} ${PORTEXAMPLES} ${EXAMPLESDIR}
.endif
@@ -101,7 +97,7 @@ do-install:
cd ${WRKSRC} && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1
.endif
cd ${WRKSRC} && ${INSTALL_MAN} ${MAN8} ${MAN8PREFIX}/man/man8
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/www/horde3-meta/Makefile b/www/horde3-meta/Makefile
index 3c177262aaf2..4b37993110ba 100644
--- a/www/horde3-meta/Makefile
+++ b/www/horde3-meta/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: horde
-# Date created: 24 February 2007
-# Whom: Beech Rintoul <beech@FreeBSD.org>
-#
+# Created by: Beech Rintoul <beech@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= meta
PORTVERSION= 1.0
@@ -18,103 +14,106 @@ COMMENT= Meta port for the horde framework
NO_BUILD= yes
LHORDEDIR?= www/horde
-OPTIONS= ANSEL "Photo Gallery" off \
- CHORA "CVS Web Viewer" off \
- DIMP "Dynamic Imp" off \
- GOLLEM "Web-Based File Manager" off \
- HERMES "Time Tracking Application" off \
- HPASSWD "Password Changing Module" off \
- IMP "IMAP Webmail System" on \
- INGO "Email-Filter Management" on \
- JETA "Java SSH Applets" off \
- KRONOLITH "Calendar Application" off \
- MIMP "Mobile Webmail System" off \
- MNEMO "Notes and Memo Application" off \
- NAG "Task List Manager" on \
- NIC "Network Monitor" off \
- TREAN "Bookmark Manager" off \
- TURBA "Contact Management" on \
- VACATION "Vacation & Auto Respond" off \
- WHUPS "Bug Tracking/Ticket System" off \
- KLUTZ "Comic Strip Viewer" off
+OPTIONS_DEFINE= ANSEL CHORA DIMP GOLLEM HPASSWD IMP INGO JETA \
+ KRONOLITH MIMP MNEMO NAG NIC TREAN TURBA VACATION \
+ WHUPS KLUTZ
+ANSEL_DESC= Photo Gallery
+CHORA_DESC= CVS Web Viewer
+DIMP_DESC= Dynamic Imp
+GOLLEM_DESC= Web-Based File Manager
+HERMES_DESC= Time Tracking Application
+HPASSWD_DESC= Password Changing Module
+IMP_DESC= IMAP Webmail System
+INGO_DESC= Email-Filter Management
+JETA_DESC= Java SSH Applets
+KRONOLITH_DESC= Calendar Application
+MIMP_DESC= Mobile Webmail System
+MNEMO_DESC= Notes and Memo Application
+NAG_DESC= Task List Manager
+NIC_DESC= Network Monitor
+TREAN_DESC= Bookmark Manager
+TURBA_DESC= Contact Management
+VACATION_DESC= Vacation & Auto Respond
+WHUPS_DESC= Bug Tracking/Ticket System
+KLUTZ_DESC= Comic Strip Viewer
.include <bsd.port.pre.mk>
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde3-base
-.if !defined(WITHOUT_IMP)
+.if ${PORT_OPTIONS:MIMP}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/imp/index.php:${PORTSDIR}/mail/horde3-imp
.endif
-.if defined(WITH_MIMP)
+.if ${PORT_OPTIONS:MMIMP}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/mimp/index.php:${PORTSDIR}/mail/horde3-mimp
.endif
-.if defined(WITH_DIMP)
+.if ${PORT_OPTIONS:MDIMP}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/dimp/compose.php:${PORTSDIR}/mail/horde3-dimp
.endif
-.if !defined(WITHOUT_INGO)
+.if ${PORT_OPTIONS:MINGO}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/ingo/filters.php:${PORTSDIR}/mail/horde3-ingo
.endif
-.if !defined(WITHOUT_TURBA)
+.if ${PORT_OPTIONS:MTURBA}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/turba/minisearch.php:${PORTSDIR}/mail/horde3-turba
.endif
-.if defined(WITH_KRONOLITH)
+.if ${PORT_OPTIONS:MKRONOLITH}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/kronolith/index.php:${PORTSDIR}/deskutils/horde3-kronolith
.endif
-.if defined(WITH_MNEMO)
+.if ${PORT_OPTIONS:MMNEMO}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/mnemo/index.php:${PORTSDIR}/deskutils/horde3-mnemo
.endif
-.if !defined(WITHOUT_NAG)
+.if ${PORT_OPTIONS:MNAG}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/nag/data.php:${PORTSDIR}/deskutils/horde3-nag
.endif
-.if defined(WITH_CHORA)
+.if ${PORT_OPTIONS:MCHORA}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/chora/index.php:${PORTSDIR}/devel/horde3-chora
.endif
-.if defined(WITH_GOLLEM)
+.if ${PORT_OPTIONS:MGOLLEM}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/gollem/index.php:${PORTSDIR}/ftp/horde3-gollem
.endif
-.if defined(WITH_JETA)
+.if ${PORT_OPTIONS:MJETA}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/jeta/index.php:${PORTSDIR}/security/horde3-jeta
.endif
-.if defined(WITH_HPASSWD)
+.if ${PORT_OPTIONS:MHPASSWD}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/passwd/index.php:${PORTSDIR}/www/horde3-passwd
.endif
-.if defined(WITH_VACATION)
+.if ${PORT_OPTIONS:MVACATION}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/vacation/main.php:${PORTSDIR}/mail/horde3-vacation
.endif
-.if defined(WITH_TREAN)
+.if ${PORT_OPTIONS:MTREAN}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/trean/data.php:${PORTSDIR}/www/horde3-trean
.endif
-.if defined(WITH_NIC)
+.if ${PORT_OPTIONS:MNIC}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/nic/status.php:${PORTSDIR}/net-mgmt/horde3-nic
.endif
-.if defined(WITH_ANSEL)
+.if ${PORT_OPTIONS:MANSEL}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/ansel/gallery.php:${PORTSDIR}/www/horde3-ansel
.endif
-.if defined(WITH_WHUPS)
+.if ${PORT_OPTIONS:MWHUPS}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/whups/index.php:${PORTSDIR}/devel/horde3-whups
.endif
-.if defined(WITH_HERMES)
+.if ${PORT_OPTIONS:MHERMES}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/hermes/index.php:${PORTSDIR}/deskutils/horde3-hermes
.endif
-.if defined(WITH_KLUTZ)
+.if ${PORT_OPTIONS:MKLUTZ}
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/klutz/index.php:${PORTSDIR}/deskutils/horde3-klutz
.endif
diff --git a/www/links-hacked/Makefile b/www/links-hacked/Makefile
index c0d26419c815..79b61076ca8e 100644
--- a/www/links-hacked/Makefile
+++ b/www/links-hacked/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: links-hacked
-# Date created: 24 September 2011
-# Whom: Peter Vereshagin <peter@vereshagin.org>
-#
+# Created by: Peter Vereshagin <peter@vereshagin.org>
# $FreeBSD$
-#
PORTNAME= links-hacked
DISTVERSION= 101110
@@ -30,16 +26,15 @@ LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
USE_OPENSSL= yes
-OPTIONS= SVGALIB "non-X11 graphics support" off \
- DIRECTFB "directfb driver support" off \
- X11 "X11 graphics support" on \
- FORMSAVE "Enable forms saving" on \
- JS "Enable Javascript (very basic)" on \
- FREETYPE "Enable Freetype renderer" on
+OPTIONS_DEFINE= SVGALIB DIRECTFB X11 FORMSAVE JS FREETYPE
+OPTIONS_DEFAULT= X11 FORMSAVE JS FREETYPE
+DIRECTFB_DESC= directfb driver support
+FORMSAVE_DESC= Enable forms saving
+JS_DESC= Enable Javascript (very basic)
.include <bsd.port.options.mk>
-.ifdef(WITH_SVGALIB) || defined(WITH_X11) || defined(WITH_DIRECTFB)
+.if ${PORT_OPTIONS:MSVGALIB} || ${PORT_OPTIONS:MX11} || ${PORT_OPTIONS:MDIRECTFB}
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
@@ -48,21 +43,21 @@ CONFIGURE_ARGS+= --enable-graphics
CONFIGURE_ARGS+= --disable-graphics --without-libjpeg --without-libtiff
.endif
-.ifdef(WITH_SVGALIB)
+.if ${PORT_OPTIONS:MSVGALIB}
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
CONFIGURE_ARGS+= --with-svgalib
.else
CONFIGURE_ARGS+= --without-svgalib
.endif
-.ifdef(WITH_DIRECTFB)
+.if ${PORT_OPTIONS:MDIRECTFB}
LIB_DEPENDS+= directfb-1.4.5:${PORTSDIR}/devel/directfb
CONFIGURE_ARGS+= --with-directfb
.else
CONFIGURE_ARGS+= --without-directfb
.endif
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
USE_XORG= x11 xproto
CONFIGURE_ARGS+= --with-x
DESKTOP_ENTRIES="Links" \
@@ -76,20 +71,20 @@ PLIST_FILES+= share/pixmaps/links.xpm
CONFIGURE_ARGS+= --without-x
.endif
-.ifdef(WITH_FREETYPE)
+.if ${PORT_OPTIONS:MFREETYPE}
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
CONFIGURE_ARGS+= --with-freetype
.else
CONFIGURE_ARGS+= --without-freetype
.endif
-.ifdef(WITH_FORMSAVE)
+.if ${PORT_OPTIONS:MFORMSAVE}
CONFIGURE_ARGS+= --enable-form-saving
.else
CONFIGURE_ARGS+= --disable-form-saving
.endif
-.ifdef(WITH_JS)
+.if ${PORT_OPTIONS:MJS}
CONFIGURE_ARGS+= --enable-javascript
.else
CONFIGURE_ARGS+= --disable-javascript
@@ -98,7 +93,7 @@ CONFIGURE_ARGS+= --disable-javascript
MAN1= links.1
PLIST_FILES+= bin/links
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
post-install:
@${INSTALL_DATA} ${WRKSRC}/graphics/links.xpm ${PREFIX}/share/pixmaps/links.xpm
.endif