aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2006-03-31 11:26:51 +0800
committerijliao <ijliao@FreeBSD.org>2006-03-31 11:26:51 +0800
commitec806acb5e7e827c37fb645afe16aa5c4dacc4c0 (patch)
treec0321e754fb0b35157d009f362814c58028b48ab
parent0e6bfd2e364a7cc44a7bd2f579687165ea3be796 (diff)
downloadfreebsd-ports-gnome-ec806acb5e7e827c37fb645afe16aa5c4dacc4c0.tar.gz
freebsd-ports-gnome-ec806acb5e7e827c37fb645afe16aa5c4dacc4c0.tar.zst
freebsd-ports-gnome-ec806acb5e7e827c37fb645afe16aa5c4dacc4c0.zip
upgrade to 0.6.9
PR: 95115 Submitted by: Ports Fury
-rw-r--r--misc/pinfo/Makefile28
-rw-r--r--misc/pinfo/distinfo6
-rw-r--r--misc/pinfo/files/patch-src__filehandling_functions.c34
-rw-r--r--misc/pinfo/files/patch-src__manual.c20
-rw-r--r--misc/pinfo/files/patch-src__utils.c76
-rw-r--r--misc/pinfo/files/patch-src__video.c58
-rw-r--r--misc/pinfo/pkg-descr2
-rw-r--r--misc/pinfo/pkg-plist5
8 files changed, 211 insertions, 18 deletions
diff --git a/misc/pinfo/Makefile b/misc/pinfo/Makefile
index 9e2644ba2054..ca0d0e9c5ead 100644
--- a/misc/pinfo/Makefile
+++ b/misc/pinfo/Makefile
@@ -6,30 +6,22 @@
#
PORTNAME= pinfo
-PORTVERSION= 0.6.8
-PORTREVISION= 1
+PORTVERSION= 0.6.9
CATEGORIES= misc
-MASTER_SITES= http://dione.ids.pl/~pborys/software/pinfo/
+MASTER_SITES= http://alioth.debian.org/download.php/1502/
MAINTAINER= ports@FreeBSD.org
COMMENT= Ncurses based, lynx style info documentation browser
+USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-readline \
--with-localedir=${PREFIX}/share/locale
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-MAN1= pinfo.1
-INFO= pinfo
+MAN1= pinfo.1
+INFO= pinfo
.include <bsd.port.pre.mk>
@@ -38,4 +30,12 @@ LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
CONFIGURE_ARGS+= --with-ncurses=${LOCALBASE}
.endif
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
.include <bsd.port.post.mk>
diff --git a/misc/pinfo/distinfo b/misc/pinfo/distinfo
index dee0a69e0fc9..82fa5123549c 100644
--- a/misc/pinfo/distinfo
+++ b/misc/pinfo/distinfo
@@ -1,3 +1,3 @@
-MD5 (pinfo-0.6.8.tar.gz) = 55feb4ebaa709b52bd00a15ed0fb52fb
-SHA256 (pinfo-0.6.8.tar.gz) = f5a177986dea663102f6a6c31895cd07c3e2fdb81d936ef5c176f709a2a40a4e
-SIZE (pinfo-0.6.8.tar.gz) = 319857
+MD5 (pinfo-0.6.9.tar.gz) = c3298d36537601753558b3e9240b00b7
+SHA256 (pinfo-0.6.9.tar.gz) = c25f08e115a5e796f40838a28d0e9816c755f4cb9e7bcc77f6d4c9ddaf0a1651
+SIZE (pinfo-0.6.9.tar.gz) = 554213
diff --git a/misc/pinfo/files/patch-src__filehandling_functions.c b/misc/pinfo/files/patch-src__filehandling_functions.c
new file mode 100644
index 000000000000..d23b27b10a7c
--- /dev/null
+++ b/misc/pinfo/files/patch-src__filehandling_functions.c
@@ -0,0 +1,34 @@
+--- src/filehandling_functions.c.orig Fri Mar 17 00:15:02 2006
++++ src/filehandling_functions.c Fri Mar 17 15:57:06 2006
+@@ -139,14 +139,13 @@
+ char name[256];
+ char file[256];
+ int i;
++ char *nameend, *filestart, *fileend, *dot;
+
+ id = opendirfile(0);
+ if (!id)
+ return 0;
+
+ read_item(id, type, message, lines);
+-
+- char *nameend, *filestart, *fileend, *dot;
+
+ /* search for node-links in every line */
+ for (i = 1; i < Lines; i++)
+@@ -163,6 +162,7 @@
+
+ /* skip this hit if it is not a perfect match and
+ * we have already found a previous partial match */
++ char *tmp = name;
+ if ( ! ( (nameend - Message[i]) - 2 == filenamelen )
+ && goodHit )
+ {
+@@ -170,7 +170,6 @@
+ }
+
+ /* find the name of the node link */
+- char *tmp = name;
+ strncpy(file, filestart + 1, fileend - filestart - 1);
+ file[fileend - filestart - 1] = 0;
+ strncpy(name, fileend + 1, dot - fileend - 1);
diff --git a/misc/pinfo/files/patch-src__manual.c b/misc/pinfo/files/patch-src__manual.c
new file mode 100644
index 000000000000..a8a02c996eb0
--- /dev/null
+++ b/misc/pinfo/files/patch-src__manual.c
@@ -0,0 +1,20 @@
+--- src/manual.c.orig Thu Mar 16 23:14:30 2006
++++ src/manual.c Fri Mar 17 16:00:02 2006
+@@ -797,7 +797,7 @@
+ if ((!strchr(p_t1, '(')) &&(!is_in_manlinks(manlinks, p_t1)))
+ {
+ char tempchar;
+- int breakpos;
++ int breakpos, cols_before_link;
+ i = mylink - tmp - 1;
+ if (i < 0)
+ i++;
+@@ -830,7 +830,7 @@
+ */
+
+ /* calculate the number of columns in front of the link */
+- int cols_before_link = width_of_string(tmp, i-1);
++ cols_before_link = width_of_string(tmp, i-1);
+
+ /* a small check */
+ if (!((use_apropos) &&(manualhistorylength == 0)))
diff --git a/misc/pinfo/files/patch-src__utils.c b/misc/pinfo/files/patch-src__utils.c
new file mode 100644
index 000000000000..1d274afd9806
--- /dev/null
+++ b/misc/pinfo/files/patch-src__utils.c
@@ -0,0 +1,76 @@
+--- src/utils.c.orig Thu Mar 16 23:14:30 2006
++++ src/utils.c Fri Mar 17 16:04:57 2006
+@@ -553,6 +553,10 @@
+ int
+ check_node_name( const char * const node_name, const char * const node_header)
+ {
++ size_t header_len;
++ char *header, *str_start, *c;
++ int res;
++
+ /* if either one of node_name or node_header is NULL or a zero
+ * sized string, we have nothing to check, so return success */
+ if ( (node_name==NULL) || (node_header==NULL)
+@@ -561,15 +565,15 @@
+ return 1;
+ }
+
+- size_t header_len = strlen(node_header);
++ header_len = strlen(node_header);
+
+ /* copy node_header to a local string which can be mutilated */
+ /* don't use strdup here, as xmalloc handles all errors */
+- char *header = xmalloc( header_len + 1 );
++ header = xmalloc( header_len + 1 );
+ strcpy(header, node_header);
+
+ /* search for "Node: foobar," in node_header */
+- char *str_start = strstr(header, "Node: ");
++ str_start = strstr(header, "Node: ");
+ if (str_start==NULL) /* no match */
+ {
+ return 0;
+@@ -577,14 +581,14 @@
+ /* advance str_start to the start of the node name */
+ str_start += strlen("Node: ");
+ /* and search for the next comma, tab, or newline */
+- char *c = str_start;
++ *c = str_start;
+ while ( (*c!=',') && (*c!='\t') && (*c!='\n') && (*c!='\0') ) c++;
+ *c = '\0';
+
+ /* so, now str_start point to a \0-terminated string containing the
+ * node name from the header.
+ * Let's compare it with the node_name we're looking for */
+- int res = strcmp(str_start, node_name);
++ res = strcmp(str_start, node_name);
+
+ /* we're done, so free alloc'ed vars */
+ xfree(header);
+@@ -637,20 +641,22 @@
+ int
+ width_of_string( const char * const mbs, const int len)
+ {
++ int width;
++ char *str;
++ wchar_t *wstr;
++
+ if (len<0) return -1;
+ if (len==0) return 0;
+
+- int width;
+-
+ /* copy the string to a local buffer, because we only want to
+ * compare the first len bytes */
+- char *str = xmalloc(len+1);
++ str = xmalloc(len+1);
+ memcpy(str, mbs, len);
+
+ #ifdef USE_WCHAR
+
+ /* allocate a widestring */
+- wchar_t *wstr = xmalloc( (len+1)*sizeof(wchar_t) );
++ wstr = xmalloc( (len+1)*sizeof(wchar_t) );
+
+ mbstowcs(wstr, str, len);
+ width = wcswidth(wstr, len);
diff --git a/misc/pinfo/files/patch-src__video.c b/misc/pinfo/files/patch-src__video.c
new file mode 100644
index 000000000000..0bd260048aec
--- /dev/null
+++ b/misc/pinfo/files/patch-src__video.c
@@ -0,0 +1,58 @@
+--- src/video.c.orig Thu Mar 16 06:54:56 2006
++++ src/video.c Fri Mar 17 16:08:37 2006
+@@ -88,9 +88,11 @@
+ attrset(normal);
+ for (i = pos;(i < lines) &&(i < pos + maxy - 2); i++)
+ {
++ int tmp;
++
+ if (!message[i]) continue;
+
+- int tmp = strlen(message[i]) - 1;
++ tmp = strlen(message[i]) - 1;
+ message[i][tmp] = 0;
+ if (tmp>column)
+ mvaddstr(i + 1 - pos, 0, message[i]+column);
+@@ -263,12 +265,14 @@
+ {
+ regmatch_t pmatch[1];
+ long maxpos = pos +(maxy - 2);
++ int maxregexp;
++
+ if (maxpos > lines)
+ {
+ maxpos = lines;
+ }
+
+- int maxregexp = aftersearch ? h_regexp_num + 1 : h_regexp_num;
++ maxregexp = aftersearch ? h_regexp_num + 1 : h_regexp_num;
+ /*
+ * if it is after search, then we have user defined regexps+
+ * a searched regexp to highlight
+@@ -285,19 +289,22 @@
+ /* check if this regexp is present on this line */
+ while (!regexec(&h_regexp[j], str, 1, pmatch, 0))
+ {
++ int n, x, y;
++ char tmp;
++
+ /* yes, found something, so highlight it */
+- int n = pmatch[0].rm_eo - pmatch[0].rm_so;
++ n = pmatch[0].rm_eo - pmatch[0].rm_so;
+
+ /* point str at start of match */
+ str += pmatch[0].rm_so;
+
+ /* calculate position on screen */
+- int x = calculate_len(message[i], str);
+- int y = i - pos + 1;
++ x = calculate_len(message[i], str);
++ y = i - pos + 1;
+
+ /* save the char after the end of the match,
+ * and replace it by \0 */
+- char tmp = str[n];
++ tmp = str[n];
+ str[n] = 0;
+
+ /* write out the highlighted match to screen */
diff --git a/misc/pinfo/pkg-descr b/misc/pinfo/pkg-descr
index 4417a896c108..7a1ea394ae6a 100644
--- a/misc/pinfo/pkg-descr
+++ b/misc/pinfo/pkg-descr
@@ -1,3 +1,3 @@
pinfo is a (n)curses based, lynx style info browser.
-WWW: http://dione.ids.pl/~pborys/software/linux/
+WWW: http://pinfo.alioth.debian.org/
diff --git a/misc/pinfo/pkg-plist b/misc/pinfo/pkg-plist
index d57bd5c6a179..289deb9e7eeb 100644
--- a/misc/pinfo/pkg-plist
+++ b/misc/pinfo/pkg-plist
@@ -2,7 +2,12 @@ bin/pinfo
etc/pinforc
%%NLS%%share/locale/cs/LC_MESSAGES/pinfo.mo
%%NLS%%share/locale/de/LC_MESSAGES/pinfo.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/pinfo.mo
%%NLS%%share/locale/ja/LC_MESSAGES/pinfo.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/pinfo.mo
%%NLS%%share/locale/pl/LC_MESSAGES/pinfo.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pinfo.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/pinfo.mo
%%NLS%%share/locale/ru/LC_MESSAGES/pinfo.mo
%%NLS%%share/locale/sv/LC_MESSAGES/pinfo.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/pinfo.mo