aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-09-25 08:26:34 +0800
committergahr <gahr@FreeBSD.org>2008-09-25 08:26:34 +0800
commitec9157f146af88e733cbcada591c81a7a30dbde1 (patch)
tree3bf58213404029fbcd96c46cc88c566559b7d789
parent52d7df3e769fec3baf9d2d51f5d357a8aa061000 (diff)
downloadfreebsd-ports-gnome-ec9157f146af88e733cbcada591c81a7a30dbde1.tar.gz
freebsd-ports-gnome-ec9157f146af88e733cbcada591c81a7a30dbde1.tar.zst
freebsd-ports-gnome-ec9157f146af88e733cbcada591c81a7a30dbde1.zip
- New port: mbox2imap
mbox2imap is a python script to upload local mbox files to remote INBOX folders
-rw-r--r--mail/Makefile1
-rw-r--r--mail/mbox2imap/Makefile31
-rw-r--r--mail/mbox2imap/distinfo3
-rw-r--r--mail/mbox2imap/pkg-descr4
4 files changed, 39 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index cfe6a016d036..8ff47de2574c 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -249,6 +249,7 @@
SUBDIR += masqmail
SUBDIR += mavbiff
SUBDIR += mb2md
+ SUBDIR += mbox2imap
SUBDIR += mbox2mdir
SUBDIR += mboxcheck-applet
SUBDIR += mboxgrep
diff --git a/mail/mbox2imap/Makefile b/mail/mbox2imap/Makefile
new file mode 100644
index 000000000000..7a2a21ebb037
--- /dev/null
+++ b/mail/mbox2imap/Makefile
@@ -0,0 +1,31 @@
+# New ports collection Makefile for: mbox2imap
+# Date created: 25 September 2008
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= mbox2imap
+PORTVERSION= 1.0
+CATEGORIES= mail
+MASTER_SITES= http://people.cs.uchicago.edu/~brendan/scripts/ \
+ http://people.freebsd.org/~gahr/distfiles/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Upload email stored in mbox file format to an IMAP server
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-extract:
+ ${CP} ${DISTDIR}/${PORTNAME} ${WRKDIR}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/mail/mbox2imap/distinfo b/mail/mbox2imap/distinfo
new file mode 100644
index 000000000000..e7ad7264a9d4
--- /dev/null
+++ b/mail/mbox2imap/distinfo
@@ -0,0 +1,3 @@
+MD5 (mbox2imap) = 031b86c32dd8bbfeeba6478f607b82f1
+SHA256 (mbox2imap) = edca95bd28d8af8e64071cbb7218ec8acaf3be384a138b3b458f8f7e194797fa
+SIZE (mbox2imap) = 14605
diff --git a/mail/mbox2imap/pkg-descr b/mail/mbox2imap/pkg-descr
new file mode 100644
index 000000000000..84ab1bf48dd7
--- /dev/null
+++ b/mail/mbox2imap/pkg-descr
@@ -0,0 +1,4 @@
+mbox2imap is a python script to upload email stored in mbox file format to
+an IMAP server.
+
+WWW: http://people.cs.uchicago.edu/~brendan/scripts/