aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-06-15 00:52:58 +0800
committerbsam <bsam@FreeBSD.org>2013-06-15 00:52:58 +0800
commitecbd84bee48bef1a002fa2080f3233d3b75064dd (patch)
treebca6e013da92e828ae78ea62a3d0c75ffb885ef7
parent87470c755620fe823c0451b857f296fb15c343f8 (diff)
downloadfreebsd-ports-gnome-ecbd84bee48bef1a002fa2080f3233d3b75064dd.tar.gz
freebsd-ports-gnome-ecbd84bee48bef1a002fa2080f3233d3b75064dd.tar.zst
freebsd-ports-gnome-ecbd84bee48bef1a002fa2080f3233d3b75064dd.zip
. remove LICENSE_FILE for GPLv2;
. NOPORTDOCS -> PORT_OPTIONS:MDOCS; . use one-line install instead of a .for loop; . trim Makefile headers.
-rw-r--r--sysutils/stowES/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/sysutils/stowES/Makefile b/sysutils/stowES/Makefile
index 3887710c0c49..1433b3fa5944 100644
--- a/sysutils/stowES/Makefile
+++ b/sysutils/stowES/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: stowES
-# Date created: Mar 17, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= stowES
PORTVERSION= 0.5.6
@@ -15,7 +10,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Stow enhancement script
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= stow:${PORTSDIR}/sysutils/stow
@@ -28,17 +22,19 @@ PORTDOCS= AUTHORS ChangeLog NEWS README TODO \
${PORTNAME}.html ${PORTNAME}.pod ${PORTNAME}.txt
PLIST_FILES= bin/${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e "s|'md5sum',|'md5',|" ${WRKSRC}/${PORTNAME}.in
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ ${INSTALL_SCRIPT} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
.include <bsd.port.mk>