aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-08 15:49:55 +0800
committermarcus <marcus@FreeBSD.org>2003-11-08 15:49:55 +0800
commiteccb26002eb0638dac72a3ab294f13973ce04889 (patch)
tree6c01298d9eb9343f3d7c03ff2f3a618baec047a5
parent580e6a6c4660cde61f27c91ef930c98791a2d67b (diff)
downloadfreebsd-ports-gnome-eccb26002eb0638dac72a3ab294f13973ce04889.tar.gz
freebsd-ports-gnome-eccb26002eb0638dac72a3ab294f13973ce04889.tar.zst
freebsd-ports-gnome-eccb26002eb0638dac72a3ab294f13973ce04889.zip
Fix the plug-in build on -STABLE.
Submitted by: bland Approved by: maintainer (implicit)
-rw-r--r--multimedia/gstreamer-player/Makefile3
-rw-r--r--multimedia/gstreamer-player/files/patch-mozilla::plugin.c13
2 files changed, 11 insertions, 5 deletions
diff --git a/multimedia/gstreamer-player/Makefile b/multimedia/gstreamer-player/Makefile
index 63152744c46d..d4b3e8e00583 100644
--- a/multimedia/gstreamer-player/Makefile
+++ b/multimedia/gstreamer-player/Makefile
@@ -49,7 +49,8 @@ pre-install:
@${MKDIR} ${PREFIX}/etc/gconf/
.if defined(WITH_MOZILLA_PLUGIN)
-BUILD_DEPENDS+= ${X11BASE}/include/mozilla${HEADERS_SUFX}/plugin/npapi.h:${PORTSDIR}/www/mozilla-headers${HEADERS_SUFX}
+BUILD_DEPENDS+= ${X11BASE}/include/mozilla${HEADERS_SUFX}/plugin/npapi.h:${PORTSDIR}/www/mozilla-headers${HEADERS_SUFX} \
+ ${X11BASE}/lib/${MOZILLA}/mozilla-config:${PORTSDIR}/www/${MOZILLA}
.if !defined(WITH_MOZILLA)
MOZILLA= mozilla-gtk2
diff --git a/multimedia/gstreamer-player/files/patch-mozilla::plugin.c b/multimedia/gstreamer-player/files/patch-mozilla::plugin.c
index d64bf2dc85f4..7e73fa8a4152 100644
--- a/multimedia/gstreamer-player/files/patch-mozilla::plugin.c
+++ b/multimedia/gstreamer-player/files/patch-mozilla::plugin.c
@@ -1,14 +1,19 @@
--- mozilla/plugin.c.orig Sat Jul 12 05:27:40 2003
-+++ mozilla/plugin.c Thu Nov 6 19:43:19 2003
-@@ -19,6 +19,7 @@
++++ mozilla/plugin.c Sat Nov 8 14:10:11 2003
+@@ -18,7 +18,12 @@
+ */
#include <stdio.h>
++#ifdef HAVE_STDINT_H
#include <stdint.h>
++#else
++#include <inttypes.h>
++#endif
+#include <signal.h>
#include <unistd.h>
#include <fcntl.h>
#include <sys/wait.h>
-@@ -76,7 +77,7 @@
+@@ -76,7 +81,7 @@
dup2(fds[2],0);
//dup2(fds[1],1);
@@ -17,7 +22,7 @@
argv[argc++] = "--xid";
argv[argc++] = xid_str;
if(plugin->width){
-@@ -92,8 +93,8 @@
+@@ -92,8 +97,8 @@
argv[argc++] = "fd://0";
argv[argc] = NULL;