aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2002-08-21 17:47:42 +0800
committerkevlo <kevlo@FreeBSD.org>2002-08-21 17:47:42 +0800
commited9cc17dd91fc498f28cb78467eec2eef839b165 (patch)
treed973b9217af832e5d5c3f5c4627f01856297dc9c
parent4509f39552dbd8d8dd454fb9af71d79ae26cd3e0 (diff)
downloadfreebsd-ports-gnome-ed9cc17dd91fc498f28cb78467eec2eef839b165.tar.gz
freebsd-ports-gnome-ed9cc17dd91fc498f28cb78467eec2eef839b165.tar.zst
freebsd-ports-gnome-ed9cc17dd91fc498f28cb78467eec2eef839b165.zip
Applied this patch to ensure build smoothly on
some environment/compiler. PR: 41535 Submitted by: MAINTAINER
-rw-r--r--chinese/xcin25/Makefile4
-rw-r--r--chinese/xcin25/files/patch-chewing::sort_word.c10
2 files changed, 13 insertions, 1 deletions
diff --git a/chinese/xcin25/Makefile b/chinese/xcin25/Makefile
index 1fc442b4549a..7bfe2334364b 100644
--- a/chinese/xcin25/Makefile
+++ b/chinese/xcin25/Makefile
@@ -58,8 +58,10 @@ pre-fetch:
@${ECHO} --
.endif
+post-extract:
+ ${MV} ${WRKDIR}/chewing ${WRKSRC}/src/Cinput
+
post-patch:
- @mv ${WRKDIR}/chewing ${WRKSRC}/src/Cinput
@cd ${WRKSRC}/src/Cinput/chewing; ${SH} ./patch_chewing
post-install:
diff --git a/chinese/xcin25/files/patch-chewing::sort_word.c b/chinese/xcin25/files/patch-chewing::sort_word.c
new file mode 100644
index 000000000000..933d29f960c6
--- /dev/null
+++ b/chinese/xcin25/files/patch-chewing::sort_word.c
@@ -0,0 +1,10 @@
+--- src/Cinput/chewing/sort_word.c.orig Sun Aug 11 12:32:03 2002
++++ src/Cinput/chewing/sort_word.c Sun Aug 11 12:32:20 2002
+@@ -40,6 +40,7 @@
+ Key2Pho(phoneBuf, keyBuf, KB_DEFAULT, 1) ;
+ word_data[nWord].num = PhoneBg2Uint(phoneBuf) ;
+ nWord++ ;
++ return 0;
+ }
+
+ void Output()