aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-07-15 06:56:44 +0800
committermiwi <miwi@FreeBSD.org>2007-07-15 06:56:44 +0800
commitede03adbcb00cc046b52d0d0a71cba28bf71e37a (patch)
tree5484f74ec12cd32e05e04f53b6bbf3aad3c6d9fb
parent5b9e476a03361de4a4e25286d820797e246d4468 (diff)
downloadfreebsd-ports-gnome-ede03adbcb00cc046b52d0d0a71cba28bf71e37a.tar.gz
freebsd-ports-gnome-ede03adbcb00cc046b52d0d0a71cba28bf71e37a.tar.zst
freebsd-ports-gnome-ede03adbcb00cc046b52d0d0a71cba28bf71e37a.zip
Haml is a markup language that's used to cleanly and simply describe the XHTML
of any web document without the use of inline code. Haml functions as a replacement for inline page templating systems such as PHP, ASP, and ERB, the templating language used in most Ruby on Rails applications. However, Haml avoids the need for explicitly coding XHTML into the template, because it itself is a description of the XHTML, with some code to generate dynamic content. WWW: http://haml.hamptoncatlin.com/ PR: ports/114568 Submitted by: Robert Gogolok <gogo at cs.uni-sb.de>
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-haml/Makefile18
-rw-r--r--www/rubygem-haml/distinfo3
-rw-r--r--www/rubygem-haml/pkg-descr9
-rw-r--r--www/rubygem-haml/pkg-plist173
5 files changed, 204 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 33618482e930..f551670c1756 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1090,6 +1090,7 @@
SUBDIR += rubygem-actionpack
SUBDIR += rubygem-actionwebservice
SUBDIR += rubygem-bluecloth
+ SUBDIR += rubygem-haml
SUBDIR += rubygem-hpricot
SUBDIR += rubygem-layout-yullio
SUBDIR += rubygem-maruku
diff --git a/www/rubygem-haml/Makefile b/www/rubygem-haml/Makefile
new file mode 100644
index 000000000000..33c6ede8c56e
--- /dev/null
+++ b/www/rubygem-haml/Makefile
@@ -0,0 +1,18 @@
+# Ports collection makefile for: rubygem-haml
+# Date created: 13 July 2007
+# Whom: Robert Gogolok <gogo@cs.uni-sb.de>
+#
+# $FreeBSD$
+
+PORTNAME= haml
+PORTVERSION= 1.5.2
+CATEGORIES= www rubygems
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gogo@cs.uni-sb.de
+COMMENT= Markup language to describe XHTML
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/rubygem-haml/distinfo b/www/rubygem-haml/distinfo
new file mode 100644
index 000000000000..cbb472f7292f
--- /dev/null
+++ b/www/rubygem-haml/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/haml-1.5.2.gem) = 831263208ae2c0989bb054253e6253d6
+SHA256 (rubygem/haml-1.5.2.gem) = 32b49a105c43d30d18dc4273a67b72ad1cc97b08f11414cff398868d7c85217c
+SIZE (rubygem/haml-1.5.2.gem) = 57856
diff --git a/www/rubygem-haml/pkg-descr b/www/rubygem-haml/pkg-descr
new file mode 100644
index 000000000000..9c95505b2a55
--- /dev/null
+++ b/www/rubygem-haml/pkg-descr
@@ -0,0 +1,9 @@
+Haml is a markup language that's used to cleanly and simply describe the XHTML
+of any web document without the use of inline code. Haml functions as a
+replacement for inline page templating systems such as PHP, ASP, and ERB, the
+templating language used in most Ruby on Rails applications.
+However, Haml avoids the need for explicitly coding XHTML into the template,
+because it itself is a description of the XHTML, with some code to generate
+dynamic content.
+
+WWW: http://haml.hamptoncatlin.com/
diff --git a/www/rubygem-haml/pkg-plist b/www/rubygem-haml/pkg-plist
new file mode 100644
index 000000000000..28b0a71e331a
--- /dev/null
+++ b/www/rubygem-haml/pkg-plist
@@ -0,0 +1,173 @@
+bin/haml
+bin/html2haml
+bin/sass
+%%GEM_CACHE%%
+%%GEM_DOC_DIR%%/rdoc/classes/ActionController.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActionView.html
+%%GEM_DOC_DIR%%/rdoc/classes/ActionView/Helpers.html
+%%GEM_DOC_DIR%%/rdoc/classes/Haml.html
+%%GEM_DOC_DIR%%/rdoc/classes/Haml/Engine.html
+%%GEM_DOC_DIR%%/rdoc/classes/Haml/Error.html
+%%GEM_DOC_DIR%%/rdoc/classes/Haml/HamlError.html
+%%GEM_DOC_DIR%%/rdoc/classes/Haml/Helpers.html
+%%GEM_DOC_DIR%%/rdoc/classes/Haml/SyntaxError.html
+%%GEM_DOC_DIR%%/rdoc/classes/Haml/Template.html
+%%GEM_DOC_DIR%%/rdoc/classes/Sass.html
+%%GEM_DOC_DIR%%/rdoc/classes/Sass/Engine.html
+%%GEM_DOC_DIR%%/rdoc/classes/Sass/Plugin.html
+%%GEM_DOC_DIR%%/rdoc/classes/Sass/SyntaxError.html
+%%GEM_DOC_DIR%%/rdoc/classes/Sass/Tree.html
+%%GEM_DOC_DIR%%/rdoc/classes/Sass/Tree/AttrNode.html
+%%GEM_DOC_DIR%%/rdoc/classes/Sass/Tree/Node.html
+%%GEM_DOC_DIR%%/rdoc/classes/Sass/Tree/RuleNode.html
+%%GEM_DOC_DIR%%/rdoc/classes/Sass/Tree/ValueNode.html
+%%GEM_DOC_DIR%%/rdoc/created.rid
+%%GEM_DOC_DIR%%/rdoc/files/MIT-LICENSE.html
+%%GEM_DOC_DIR%%/rdoc/files/README.html
+%%GEM_DOC_DIR%%/rdoc/files/VERSION.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/haml/engine_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/haml/error_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/haml/exec_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/haml/filters_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/haml/helpers/action_view_mods_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/haml/helpers_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/haml/template_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/haml_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/constant/color_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/constant/literal_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/constant/number_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/constant/operation_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/constant/string_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/constant_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/engine_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/error_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/plugin_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/tree/attr_node_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/tree/node_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/tree/rule_node_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass/tree/value_node_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/sass_rb.html
+%%GEM_DOC_DIR%%/rdoc/fr_class_index.html
+%%GEM_DOC_DIR%%/rdoc/fr_file_index.html
+%%GEM_DOC_DIR%%/rdoc/fr_method_index.html
+%%GEM_DOC_DIR%%/rdoc/index.html
+%%GEM_DOC_DIR%%/rdoc/rdoc-style.css
+%%GEM_LIB_DIR%%/MIT-LICENSE
+%%GEM_LIB_DIR%%/README
+%%GEM_LIB_DIR%%/Rakefile
+%%GEM_LIB_DIR%%/VERSION
+%%GEM_LIB_DIR%%/bin/haml
+%%GEM_LIB_DIR%%/bin/html2haml
+%%GEM_LIB_DIR%%/bin/sass
+%%GEM_LIB_DIR%%/init.rb
+%%GEM_LIB_DIR%%/lib/haml.rb
+%%GEM_LIB_DIR%%/lib/haml/buffer.rb
+%%GEM_LIB_DIR%%/lib/haml/engine.rb
+%%GEM_LIB_DIR%%/lib/haml/error.rb
+%%GEM_LIB_DIR%%/lib/haml/exec.rb
+%%GEM_LIB_DIR%%/lib/haml/filters.rb
+%%GEM_LIB_DIR%%/lib/haml/helpers.rb
+%%GEM_LIB_DIR%%/lib/haml/helpers/action_view_mods.rb
+%%GEM_LIB_DIR%%/lib/haml/template.rb
+%%GEM_LIB_DIR%%/lib/sass.rb
+%%GEM_LIB_DIR%%/lib/sass/constant.rb
+%%GEM_LIB_DIR%%/lib/sass/constant/color.rb
+%%GEM_LIB_DIR%%/lib/sass/constant/literal.rb
+%%GEM_LIB_DIR%%/lib/sass/constant/number.rb
+%%GEM_LIB_DIR%%/lib/sass/constant/operation.rb
+%%GEM_LIB_DIR%%/lib/sass/constant/string.rb
+%%GEM_LIB_DIR%%/lib/sass/engine.rb
+%%GEM_LIB_DIR%%/lib/sass/error.rb
+%%GEM_LIB_DIR%%/lib/sass/plugin.rb
+%%GEM_LIB_DIR%%/lib/sass/tree/attr_node.rb
+%%GEM_LIB_DIR%%/lib/sass/tree/node.rb
+%%GEM_LIB_DIR%%/lib/sass/tree/rule_node.rb
+%%GEM_LIB_DIR%%/lib/sass/tree/value_node.rb
+%%GEM_LIB_DIR%%/test/benchmark.rb
+%%GEM_LIB_DIR%%/test/haml/engine_test.rb
+%%GEM_LIB_DIR%%/test/haml/helper_test.rb
+%%GEM_LIB_DIR%%/test/haml/mocks/article.rb
+%%GEM_LIB_DIR%%/test/haml/results/content_for_layout.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/eval_suppressed.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/filters.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/helpers.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/helpful.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/just_stuff.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/list.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/original_engine.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/partials.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/semantic.cache
+%%GEM_LIB_DIR%%/test/haml/results/silent_script.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/standard.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/tag_parsing.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/very_basic.xhtml
+%%GEM_LIB_DIR%%/test/haml/results/whitespace_handling.xhtml
+%%GEM_LIB_DIR%%/test/haml/rhtml/standard.rhtml
+%%GEM_LIB_DIR%%/test/haml/runner.rb
+%%GEM_LIB_DIR%%/test/haml/template_test.rb
+%%GEM_LIB_DIR%%/test/haml/templates/_partial.haml
+%%GEM_LIB_DIR%%/test/haml/templates/_text_area.haml
+%%GEM_LIB_DIR%%/test/haml/templates/breakage.haml
+%%GEM_LIB_DIR%%/test/haml/templates/content_for_layout.haml
+%%GEM_LIB_DIR%%/test/haml/templates/eval_suppressed.haml
+%%GEM_LIB_DIR%%/test/haml/templates/filters.haml
+%%GEM_LIB_DIR%%/test/haml/templates/helpers.haml
+%%GEM_LIB_DIR%%/test/haml/templates/helpful.haml
+%%GEM_LIB_DIR%%/test/haml/templates/just_stuff.haml
+%%GEM_LIB_DIR%%/test/haml/templates/list.haml
+%%GEM_LIB_DIR%%/test/haml/templates/original_engine.haml
+%%GEM_LIB_DIR%%/test/haml/templates/partialize.haml
+%%GEM_LIB_DIR%%/test/haml/templates/partials.haml
+%%GEM_LIB_DIR%%/test/haml/templates/silent_script.haml
+%%GEM_LIB_DIR%%/test/haml/templates/standard.haml
+%%GEM_LIB_DIR%%/test/haml/templates/tag_parsing.haml
+%%GEM_LIB_DIR%%/test/haml/templates/very_basic.haml
+%%GEM_LIB_DIR%%/test/haml/templates/whitespace_handling.haml
+%%GEM_LIB_DIR%%/test/profile.rb
+%%GEM_LIB_DIR%%/test/sass/engine_test.rb
+%%GEM_LIB_DIR%%/test/sass/plugin_test.rb
+%%GEM_LIB_DIR%%/test/sass/results/basic.css
+%%GEM_LIB_DIR%%/test/sass/results/compact.css
+%%GEM_LIB_DIR%%/test/sass/results/complex.css
+%%GEM_LIB_DIR%%/test/sass/results/constants.css
+%%GEM_LIB_DIR%%/test/sass/results/expanded.css
+%%GEM_LIB_DIR%%/test/sass/results/nested.css
+%%GEM_LIB_DIR%%/test/sass/templates/basic.sass
+%%GEM_LIB_DIR%%/test/sass/templates/bork.sass
+%%GEM_LIB_DIR%%/test/sass/templates/compact.sass
+%%GEM_LIB_DIR%%/test/sass/templates/complex.sass
+%%GEM_LIB_DIR%%/test/sass/templates/constants.sass
+%%GEM_LIB_DIR%%/test/sass/templates/expanded.sass
+%%GEM_LIB_DIR%%/test/sass/templates/nested.sass
+%%GEM_SPEC%%
+@dirrm %%GEM_LIB_DIR%%/test/sass/templates
+@dirrm %%GEM_LIB_DIR%%/test/sass/results
+@dirrm %%GEM_LIB_DIR%%/test/sass
+@dirrm %%GEM_LIB_DIR%%/test/haml/templates
+@dirrm %%GEM_LIB_DIR%%/test/haml/rhtml
+@dirrm %%GEM_LIB_DIR%%/test/haml/results
+@dirrm %%GEM_LIB_DIR%%/test/haml/mocks
+@dirrm %%GEM_LIB_DIR%%/test/haml
+@dirrm %%GEM_LIB_DIR%%/test
+@dirrm %%GEM_LIB_DIR%%/lib/sass/tree
+@dirrm %%GEM_LIB_DIR%%/lib/sass/constant
+@dirrm %%GEM_LIB_DIR%%/lib/sass
+@dirrm %%GEM_LIB_DIR%%/lib/haml/helpers
+@dirrm %%GEM_LIB_DIR%%/lib/haml
+@dirrm %%GEM_LIB_DIR%%/lib
+@dirrm %%GEM_LIB_DIR%%/bin
+@dirrm %%GEM_LIB_DIR%%
+@dirrm %%GEM_DOC_DIR%%/rdoc/files/lib/sass/tree
+@dirrm %%GEM_DOC_DIR%%/rdoc/files/lib/sass/constant
+@dirrm %%GEM_DOC_DIR%%/rdoc/files/lib/sass
+@dirrm %%GEM_DOC_DIR%%/rdoc/files/lib/haml/helpers
+@dirrm %%GEM_DOC_DIR%%/rdoc/files/lib/haml
+@dirrm %%GEM_DOC_DIR%%/rdoc/files/lib
+@dirrm %%GEM_DOC_DIR%%/rdoc/files
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Sass/Tree
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Sass
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Haml
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/ActionView
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes
+@dirrm %%GEM_DOC_DIR%%/rdoc
+@dirrm %%GEM_DOC_DIR%%