aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-07 16:20:31 +0800
committerknu <knu@FreeBSD.org>2000-08-07 16:20:31 +0800
commitee45ff4ebd7e88c7dbf710e68dbd0b9777ad5ef3 (patch)
tree8e17deddf9e2ca2da637468b1df28723eccb7fe9
parentc0a9453662405e1651994f8fe45c26db896bf09e (diff)
downloadfreebsd-ports-gnome-ee45ff4ebd7e88c7dbf710e68dbd0b9777ad5ef3.tar.gz
freebsd-ports-gnome-ee45ff4ebd7e88c7dbf710e68dbd0b9777ad5ef3.tar.zst
freebsd-ports-gnome-ee45ff4ebd7e88c7dbf710e68dbd0b9777ad5ef3.zip
Add more Ruby ports.
devel/ruby-racc: An LALR(1) parser generator for Ruby textproc/ruby-html-parser: HTML-parser package for Ruby
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-racc/Makefile53
-rw-r--r--devel/ruby-racc/distinfo1
-rw-r--r--devel/ruby-racc/pkg-comment1
-rw-r--r--devel/ruby-racc/pkg-descr5
-rw-r--r--devel/ruby-racc/pkg-plist54
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ruby-html-parser/Makefile35
-rw-r--r--textproc/ruby-html-parser/distinfo1
-rw-r--r--textproc/ruby-html-parser/pkg-comment1
-rw-r--r--textproc/ruby-html-parser/pkg-descr5
-rw-r--r--textproc/ruby-html-parser/pkg-plist5
12 files changed, 163 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 257bc79374cd..ec69e4dc09b2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -263,6 +263,7 @@
SUBDIR += robodoc
SUBDIR += rpc2
SUBDIR += ruby-property
+ SUBDIR += ruby-racc
SUBDIR += rvm
SUBDIR += sdcc
SUBDIR += sdl
diff --git a/devel/ruby-racc/Makefile b/devel/ruby-racc/Makefile
new file mode 100644
index 000000000000..de7dd1e18e88
--- /dev/null
+++ b/devel/ruby-racc/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: Ruby-Racc
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= racc
+PORTVERSION= 1.2.1
+CATEGORIES= devel # ruby
+MASTER_SITES= http://www1.u-netsurf.ne.jp/~brew/mine/soft/
+PKGNAMEPREFIX= ruby-
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+DOCS_EN= changes.html command.html debug.html grammer.html \
+ index.html usage.html
+DOCS_JA= changes.html command.html debug.html grammer.html \
+ index.html parser.html usage.html
+EXAMPLES= calc.y calc2-ja.y compile.rb
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} setup.rb config
+
+do-build:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${RUBY} setup.rb setup
+
+do-install:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${RUBY} setup.rb install
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/racc/examples
+ ${MKDIR} ${PREFIX}/share/doc/ruby/racc/ja
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${PREFIX}/share/doc/ruby/racc/examples/
+.endfor
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/doc.en/${f} ${PREFIX}/share/doc/ruby/racc/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/doc.ja/${f} ${PREFIX}/share/doc/ruby/racc/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-racc/distinfo b/devel/ruby-racc/distinfo
new file mode 100644
index 000000000000..634f6a8c81e2
--- /dev/null
+++ b/devel/ruby-racc/distinfo
@@ -0,0 +1 @@
+MD5 (racc-1.2.1.tar.gz) = 6a48cfdbdb480ae726a8cc5a06650e55
diff --git a/devel/ruby-racc/pkg-comment b/devel/ruby-racc/pkg-comment
new file mode 100644
index 000000000000..9ed1bd89205e
--- /dev/null
+++ b/devel/ruby-racc/pkg-comment
@@ -0,0 +1 @@
+An LALR(1) parser generator for Ruby
diff --git a/devel/ruby-racc/pkg-descr b/devel/ruby-racc/pkg-descr
new file mode 100644
index 000000000000..92ed74dbef18
--- /dev/null
+++ b/devel/ruby-racc/pkg-descr
@@ -0,0 +1,5 @@
+Racc is an LALR(1) parser generator for Ruby. It is written in Ruby
+and generates Ruby code. Almost all functions of yacc(1) is
+implemented.
+
+WWW: http://www1.u-netsurf.ne.jp/~brew/mine/en/index.html
diff --git a/devel/ruby-racc/pkg-plist b/devel/ruby-racc/pkg-plist
new file mode 100644
index 000000000000..7d39c7e26a37
--- /dev/null
+++ b/devel/ruby-racc/pkg-plist
@@ -0,0 +1,54 @@
+bin/racc
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/bench.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/bug.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/collfrom.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/dispatch.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/errutil.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/extmod.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/fileutils.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/futils.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/gconst.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/getdep.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/info.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/must.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/pipeline.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/rbparams.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/recycle.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/rubyemu.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/strquote.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/symbol.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/timer.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/to_s.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/version.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/racc/libracc.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/racc/facade.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/racc/raccs.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/racc/register.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/racc/state.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/racc/format.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/racc/info.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/racc/raccp.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/racc/parser.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/racc/cparse.so
+@dirrm lib/ruby/site_ruby/%%RUBY_VER%%/amstd
+@dirrm lib/ruby/site_ruby/%%RUBY_VER%%/racc
+@dirrm lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/racc
+share/doc/ruby/racc/examples/calc.y
+share/doc/ruby/racc/examples/calc2-ja.y
+share/doc/ruby/racc/examples/compile.rb
+share/doc/ruby/racc/ja/changes.html
+share/doc/ruby/racc/ja/command.html
+share/doc/ruby/racc/ja/debug.html
+share/doc/ruby/racc/ja/grammer.html
+share/doc/ruby/racc/ja/index.html
+share/doc/ruby/racc/ja/parser.html
+share/doc/ruby/racc/ja/usage.html
+share/doc/ruby/racc/changes.html
+share/doc/ruby/racc/command.html
+share/doc/ruby/racc/debug.html
+share/doc/ruby/racc/grammer.html
+share/doc/ruby/racc/index.html
+share/doc/ruby/racc/usage.html
+@dirrm share/doc/ruby/racc/examples
+@dirrm share/doc/ruby/racc/ja
+@dirrm share/doc/ruby/racc
diff --git a/textproc/Makefile b/textproc/Makefile
index e29427714d71..12fab3104c3a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -76,6 +76,7 @@
SUBDIR += py-xml
SUBDIR += rand
SUBDIR += rman
+ SUBDIR += ruby-racc
SUBDIR += sarep
SUBDIR += se-ispell
SUBDIR += sgmlformat
diff --git a/textproc/ruby-html-parser/Makefile b/textproc/ruby-html-parser/Makefile
new file mode 100644
index 000000000000..9b2a89e24c3b
--- /dev/null
+++ b/textproc/ruby-html-parser/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Ruby-html-parser
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= html-parser
+PORTVERSION= 19990912.p1
+CATEGORIES= textproc # ruby
+MASTER_SITES= http://www.jin.gr.jp/~nahi/Ruby/html-parser/
+PKGNAMEPREFIX= ruby-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//}
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_BUILD= yes
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+do-install:
+ @cd ${WRKSRC}; ${RUBY} install.rb
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/html-parser
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${PREFIX}/share/doc/ruby/html-parser/
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-html-parser/distinfo b/textproc/ruby-html-parser/distinfo
new file mode 100644
index 000000000000..785f05ea6bdd
--- /dev/null
+++ b/textproc/ruby-html-parser/distinfo
@@ -0,0 +1 @@
+MD5 (html-parser-19990912p1.tar.gz) = f8aaa127c54416ac435c81119adb9fff
diff --git a/textproc/ruby-html-parser/pkg-comment b/textproc/ruby-html-parser/pkg-comment
new file mode 100644
index 000000000000..b6b6be841831
--- /dev/null
+++ b/textproc/ruby-html-parser/pkg-comment
@@ -0,0 +1 @@
+HTML-parser package for Ruby
diff --git a/textproc/ruby-html-parser/pkg-descr b/textproc/ruby-html-parser/pkg-descr
new file mode 100644
index 000000000000..86f3fe102857
--- /dev/null
+++ b/textproc/ruby-html-parser/pkg-descr
@@ -0,0 +1,5 @@
+The html-parser package is a Ruby implementation of the Python's SGML
+parser (sgmllib.py), HTML parser (htmllib.py) and Formatter
+(formatter.py).
+
+WWW: http://www.jin.gr.jp/~nahi/Ruby/html-parser/README.html
diff --git a/textproc/ruby-html-parser/pkg-plist b/textproc/ruby-html-parser/pkg-plist
new file mode 100644
index 000000000000..79190f3860f0
--- /dev/null
+++ b/textproc/ruby-html-parser/pkg-plist
@@ -0,0 +1,5 @@
+lib/ruby/site_ruby/formatter.rb
+lib/ruby/site_ruby/html-parser.rb
+lib/ruby/site_ruby/sgml-parser.rb
+share/doc/ruby/html-parser/README.html
+@dirrm share/doc/ruby/html-parser