aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-23 22:43:06 +0800
committeradamw <adamw@FreeBSD.org>2014-08-23 22:43:06 +0800
commitef14cc1657bd2f4f8e2673446f457d047ff8bf8f (patch)
tree5852df44a40c4331bb77fe336ff41a850483058a
parentf935ae4bcbeba886dc6346e868bdc9e7365f5a18 (diff)
downloadfreebsd-ports-gnome-ef14cc1657bd2f4f8e2673446f457d047ff8bf8f.tar.gz
freebsd-ports-gnome-ef14cc1657bd2f4f8e2673446f457d047ff8bf8f.tar.zst
freebsd-ports-gnome-ef14cc1657bd2f4f8e2673446f457d047ff8bf8f.zip
Add devel/liballium and security/obfsclient.
liballium attempts to reduce the amount of boilerplate code required to implement pluggable transports for Tor in C or C++. WWW: https://github.com/yawning/liballium obfsclient is a C++11 Tor-managed pluggable transport client implementation of the following protocols: obfs2 - The Twobfuscator obfs3 - The Threebfuscator ScrambleSuit - Experimental WWW: https://github.com/yawning/obfsclient PR: 187926, 187927 Submitted by: fk@fabiankeil.de
-rw-r--r--devel/Makefile1
-rw-r--r--devel/liballium/Makefile39
-rw-r--r--devel/liballium/distinfo2
-rw-r--r--devel/liballium/pkg-descr4
-rw-r--r--devel/liballium/pkg-plist11
-rw-r--r--security/Makefile1
-rw-r--r--security/obfsclient/Makefile40
-rw-r--r--security/obfsclient/distinfo2
-rw-r--r--security/obfsclient/pkg-descr8
9 files changed, 108 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9fbcec12d9df..7de33c7551cc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -953,6 +953,7 @@
SUBDIR += libIDL
SUBDIR += libPropList
SUBDIR += libafterbase
+ SUBDIR += liballium
SUBDIR += libantlr3c
SUBDIR += libarena
SUBDIR += libassa
diff --git a/devel/liballium/Makefile b/devel/liballium/Makefile
new file mode 100644
index 000000000000..d20aeb50c53a
--- /dev/null
+++ b/devel/liballium/Makefile
@@ -0,0 +1,39 @@
+# Created by: Fabian Keil <fk@fabiankeil.de>
+# $FreeBSD$
+
+PORTNAME= liballium
+PORTVERSION= 0.0.1
+CATEGORIES= devel security
+MASTER_SITES= GH
+DISTNAME= g-${GH_ACCOUNT}-${GH_PROJECT}-${PORTVERSION}-${GH_COMMIT}
+
+MAINTAINER= fk@fabiankeil.de
+COMMENT= Tor pluggable transports utility library
+
+USE_GITHUB= yes
+GH_ACCOUNT= Yawning
+GH_COMMIT= 0c9b50f
+GH_TAGNAME= ${GH_COMMIT}
+
+GNU_CONFIGURE= yes
+USES= libtool:build pkgconfig tar:bzip2 pathfix
+USE_AUTOTOOLS= autoconf aclocal automake
+USE_LDCONFIG= yes
+
+PLIST_SUB+= PKGNAME=${PKGNAME}
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -E -e "s@^(pkgconfigdir =) .*@\1 ${LOCALBASE}/libdata/pkgconfig@" \
+ ${WRKSRC}/Makefile.am
+
+pre-configure:
+ @(cd ${WRKSRC}; ./autogen.sh)
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/liballium/distinfo b/devel/liballium/distinfo
new file mode 100644
index 000000000000..322bc16c1895
--- /dev/null
+++ b/devel/liballium/distinfo
@@ -0,0 +1,2 @@
+SHA256 (g-Yawning-liballium-0.0.1-0c9b50f.tar.bz2) = cf621145ae328d3694fda1231a645cf91ccc5fcd7edfaf263a21e20d9e48853d
+SIZE (g-Yawning-liballium-0.0.1-0c9b50f.tar.bz2) = 39938
diff --git a/devel/liballium/pkg-descr b/devel/liballium/pkg-descr
new file mode 100644
index 000000000000..8d7d4a4e1e6c
--- /dev/null
+++ b/devel/liballium/pkg-descr
@@ -0,0 +1,4 @@
+liballium attempts to reduce the amount of boilerplate code required to
+implement pluggable transports for Tor in C or C++.
+
+WWW: https://github.com/yawning/liballium
diff --git a/devel/liballium/pkg-plist b/devel/liballium/pkg-plist
new file mode 100644
index 000000000000..b32e3e8c7c29
--- /dev/null
+++ b/devel/liballium/pkg-plist
@@ -0,0 +1,11 @@
+include/allium/allium.h
+include/allium/allium_ptcfg.h
+include/allium/bstrlib.h
+lib/liballium-1.0.a
+lib/liballium-1.0.so
+lib/liballium-1.0.so.0
+lib/liballium-1.0.so.0.0.1
+libdata/pkgconfig/liballium-1.0.pc
+@dirrmtry include/allium
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/security/Makefile b/security/Makefile
index 57b74a236fd7..1e94c552b9cb 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -343,6 +343,7 @@
SUBDIR += nmapsi4
SUBDIR += nss
SUBDIR += oath-toolkit
+ SUBDIR += obfsclient
SUBDIR += obfsproxy
SUBDIR += ocaml-cryptgps
SUBDIR += ocaml-cryptokit
diff --git a/security/obfsclient/Makefile b/security/obfsclient/Makefile
new file mode 100644
index 000000000000..9b162cb7df49
--- /dev/null
+++ b/security/obfsclient/Makefile
@@ -0,0 +1,40 @@
+# Created by: Fabian Keil <fk@fabiankeil.de>
+# $FreeBSD$
+
+PORTNAME= obfsclient
+PORTVERSION= 0.0.2
+CATEGORIES= security
+DISTNAME= g-${GH_ACCOUNT}-${GH_PROJECT}-${PORTVERSION}-${GH_COMMIT}
+
+MAINTAINER= fk@fabiankeil.de
+COMMENT= Tor-managed pluggable transport client
+
+LIB_DEPENDS= liballium-1.0.so:${PORTSDIR}/devel/liballium \
+ libevent.so:${PORTSDIR}/devel/libevent2
+
+USE_GITHUB= yes
+GH_ACCOUNT= Yawning
+GH_COMMIT= 3c551c5
+GH_TAGNAME= ${GH_COMMIT}
+
+GNU_CONFIGURE= yes
+USES= compiler:c++11-lib libtool:build pkgconfig tar:bzip2
+USE_AUTOTOOLS= autoconf aclocal automake
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= COPYING
+
+pre-configure:
+ @(cd ${WRKSRC} && ./autogen.sh)
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
+
+regression-test: build
+ (cd ${WRKSRC} && make check)
+
+.include <bsd.port.mk>
diff --git a/security/obfsclient/distinfo b/security/obfsclient/distinfo
new file mode 100644
index 000000000000..a2057a449807
--- /dev/null
+++ b/security/obfsclient/distinfo
@@ -0,0 +1,2 @@
+SHA256 (g-Yawning-obfsclient-0.0.2-3c551c5.tar.bz2) = 02bf73b5845ee5e514d26f8dd2fba0d2fc0e44a8b76ad7b444361f40391f684d
+SIZE (g-Yawning-obfsclient-0.0.2-3c551c5.tar.bz2) = 374687
diff --git a/security/obfsclient/pkg-descr b/security/obfsclient/pkg-descr
new file mode 100644
index 000000000000..f2db7fc9f08e
--- /dev/null
+++ b/security/obfsclient/pkg-descr
@@ -0,0 +1,8 @@
+obfsclient is a C++11 Tor-managed pluggable transport client
+implementation of the following protocols:
+
+obfs2 - The Twobfuscator
+obfs3 - The Threebfuscator
+ScrambleSuit - Experimental
+
+WWW: https://github.com/yawning/obfsclient