aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2010-01-13 18:15:07 +0800
committerehaupt <ehaupt@FreeBSD.org>2010-01-13 18:15:07 +0800
commitef8ec82cec652efbdd3f91a300bea36f5d8e920a (patch)
tree7678fc10295adab61485a7c0948d5cb8962d018e
parentd6879da7401b57d4a301ffd4ba56f1615e56868d (diff)
downloadfreebsd-ports-gnome-ef8ec82cec652efbdd3f91a300bea36f5d8e920a.tar.gz
freebsd-ports-gnome-ef8ec82cec652efbdd3f91a300bea36f5d8e920a.tar.zst
freebsd-ports-gnome-ef8ec82cec652efbdd3f91a300bea36f5d8e920a.zip
Update to 0.62
-rw-r--r--audio/audacious-dumb/Makefile3
-rw-r--r--audio/audacious-dumb/distinfo6
-rw-r--r--audio/audacious-dumb/files/patch-Makefile35
-rw-r--r--audio/audacious-dumb/files/patch-audacious-dumb.c11
4 files changed, 4 insertions, 51 deletions
diff --git a/audio/audacious-dumb/Makefile b/audio/audacious-dumb/Makefile
index 91eae5df4668..214858db61dd 100644
--- a/audio/audacious-dumb/Makefile
+++ b/audio/audacious-dumb/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= audacious-dumb
-PORTVERSION= 0.57
-PORTREVISION= 5
+PORTVERSION= 0.62
CATEGORIES= audio
MASTER_SITES= http://www.netswarm.net/misc/ \
CRITICAL
diff --git a/audio/audacious-dumb/distinfo b/audio/audacious-dumb/distinfo
index 8f5cd56f7795..241528fbb509 100644
--- a/audio/audacious-dumb/distinfo
+++ b/audio/audacious-dumb/distinfo
@@ -1,3 +1,3 @@
-MD5 (audacious-dumb-0.57.tar.gz) = cff708d05158418f50b34acee0981959
-SHA256 (audacious-dumb-0.57.tar.gz) = b75c8e2cfaea8204c2315409c8b03a37999f68e6031def866449740bb289fbce
-SIZE (audacious-dumb-0.57.tar.gz) = 22674
+MD5 (audacious-dumb-0.62.tar.gz) = e11ee09f243a4641446b41e42511909a
+SHA256 (audacious-dumb-0.62.tar.gz) = ac5dc9a8fa6325036f358d6c0528234d050520c255c94716ba74abb1e66a37d9
+SIZE (audacious-dumb-0.62.tar.gz) = 22970
diff --git a/audio/audacious-dumb/files/patch-Makefile b/audio/audacious-dumb/files/patch-Makefile
deleted file mode 100644
index 7536885198a4..000000000000
--- a/audio/audacious-dumb/files/patch-Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
---- ./Makefile.orig 2008-01-27 20:32:05.000000000 +0100
-+++ ./Makefile 2009-12-02 00:14:08.000000000 +0100
-@@ -7,7 +7,7 @@
- CC ?= gcc
- CFLAGS ?= -O2 -pipe
-
--CFLAGS += -Wall -fPIC -DPIC -I/usr/local/include
-+CFLAGS += -Wall -fPIC -DPIC -I$(LOCALBASE)/include
- AUDACIOUSCFLAGS = $(shell pkg-config 'audacious >= 1.4' --cflags || echo "old")
-
- ifeq ($(AUDACIOUSCFLAGS),old)
-@@ -17,6 +17,8 @@
- CFLAGS += $(AUDACIOUSCFLAGS)
- endif
-
-+LDFLAGS+= -fPIC -DPIC
-+
- DUMBLIBS := -ldumb -L/usr/local/lib
- AUDACIOUSLIBS := $(shell pkg-config audacious --libs)
-
-@@ -25,13 +27,9 @@
- OBJECTS := $(SOURCES:%.c=$(OBJDIR)/%.o)
-
- all: $(PLUGIN_FILE)
-- @echo
-- @echo "The plug-in has been compiled. Run one of the following:"
-- @echo "make install - for global (root) installation to $(INSTALL_DIR)"
-- @echo "make install-home - for installation to home directory $(INSTALL_DIR_HOME)"
-
- $(PLUGIN_FILE): $(OBJECTS)
-- $(CC) -shared -o $@ $^ $(DUMBLIBS) $(AUDACIOUSLIBS)
-+ $(CC) $(LDFLAGS) -shared -o $@ $^ $(DUMBLIBS) $(AUDACIOUSLIBS)
-
- $(OBJDIR)/%.o: %.c
- $(CC) -o $@ $(CFLAGS) -c $<
diff --git a/audio/audacious-dumb/files/patch-audacious-dumb.c b/audio/audacious-dumb/files/patch-audacious-dumb.c
deleted file mode 100644
index 4774feb6b91e..000000000000
--- a/audio/audacious-dumb/files/patch-audacious-dumb.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./audacious-dumb.c.orig 2009-12-02 00:14:15.000000000 +0100
-+++ ./audacious-dumb.c 2009-12-02 00:14:26.000000000 +0100
-@@ -49,7 +49,7 @@
- .stop = stop,
- .pause = duh_pause,
- .seek = seek,
-- .get_song_info = get_song_info,
-+ NULL,
- .file_info_box = file_info_box,
- .get_song_tuple = get_tuple_info,
- .is_our_file_from_vfs = is_our_file_from_vfs,