aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-16 02:53:46 +0800
committerbapt <bapt@FreeBSD.org>2014-05-16 02:53:46 +0800
commitefbfb13f411592dec5c0e76e2ae1edaa782a37b7 (patch)
tree735e3f4d4eada2e3c451641fa7612e9dd703c87e
parent7504ecbc65fe5252de0c4b497b3c1082ec668215 (diff)
downloadfreebsd-ports-gnome-efbfb13f411592dec5c0e76e2ae1edaa782a37b7.tar.gz
freebsd-ports-gnome-efbfb13f411592dec5c0e76e2ae1edaa782a37b7.tar.zst
freebsd-ports-gnome-efbfb13f411592dec5c0e76e2ae1edaa782a37b7.zip
Prevent x264 to link to ffmpeg if ffmpeg is already installed on the system which will lead to a circular dependencies which is revealed by pkg autodeps functionnality
Reported by: kwm
-rw-r--r--multimedia/x264/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index f383445bfa95..5bce27c1d575 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -3,7 +3,7 @@
PORTNAME= x264
PORTVERSION= 0.${X264_BUILD}.${X264_REV}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.videolan.org/pub/videolan/x264/snapshots/ \
http://samples.mplayerhq.hu/yuv4mpeg2/:pgo
@@ -26,8 +26,7 @@ X264_COMMIT= 3361d59a0a83dcb8b321cc0eb8e6ba68ca49c7d4
X264_GITVER= ${X264_COMMIT:C/^(.......).*$/\1/g}
X264_SNAPSHOT= 20130827
-USES= gmake
-USE_BZIP2= yes
+USES= gmake tar:bzip2
WRKSRC= ${WRKDIR}/${DISTNAME}
USE_LDCONFIG= yes
HAS_CONFIGURE= yes
@@ -43,7 +42,8 @@ X11_OUTPUT_DESC= Enable X11 Output
CONFIGURE_ARGS+= --extra-cflags="-I${LOCALBASE}/include" \
--extra-ldflags="-L${LOCALBASE}/lib" \
--enable-static --enable-shared \
- --disable-opencl
+ --disable-opencl \
+ --disable-swscale
PLIST_SUB+= X264_BUILD=${X264_BUILD}