aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-06-01 05:09:20 +0800
committerantoine <antoine@FreeBSD.org>2013-06-01 05:09:20 +0800
commitf0bfcdacc92c0d07087bd65318c78885c0d22ff7 (patch)
treed251fa67c2570fe8cae94d04146a7e5aa2b663b7
parent7f15e8a98b5323973ce8943f0d5baeb69b8806d5 (diff)
downloadfreebsd-ports-gnome-f0bfcdacc92c0d07087bd65318c78885c0d22ff7.tar.gz
freebsd-ports-gnome-f0bfcdacc92c0d07087bd65318c78885c0d22ff7.tar.zst
freebsd-ports-gnome-f0bfcdacc92c0d07087bd65318c78885c0d22ff7.zip
New port: rubygem-pcaprub
libpcap bindings for ruby WWW: https://github.com/shadowbq/pcaprub Approved by: miwi, eadler (mentors, implicit)
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-pcaprub/Makefile17
-rw-r--r--net/rubygem-pcaprub/distinfo2
-rw-r--r--net/rubygem-pcaprub/pkg-descr6
4 files changed, 26 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6c222669cac0..73b4fcbd5ab6 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1035,6 +1035,7 @@
SUBDIR += rubygem-oauth2
SUBDIR += rubygem-open-uri-cached
SUBDIR += rubygem-openid
+ SUBDIR += rubygem-pcaprub
SUBDIR += rubygem-rightaws
SUBDIR += rubygem-rightflexiscale
SUBDIR += rubygem-rightgogrid
diff --git a/net/rubygem-pcaprub/Makefile b/net/rubygem-pcaprub/Makefile
new file mode 100644
index 000000000000..b2df4d62431f
--- /dev/null
+++ b/net/rubygem-pcaprub/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= pcaprub
+PORTVERSION= 0.11.3
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Libpcap bindings for ruby
+
+LICENSE= LGPL21
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST=yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-pcaprub/distinfo b/net/rubygem-pcaprub/distinfo
new file mode 100644
index 000000000000..29df782650de
--- /dev/null
+++ b/net/rubygem-pcaprub/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/pcaprub-0.11.3.gem) = a6f724ce8fe1036a399cefe1c77d3b989cb335e31f078028160c8f875e576eef
+SIZE (rubygem/pcaprub-0.11.3.gem) = 32768
diff --git a/net/rubygem-pcaprub/pkg-descr b/net/rubygem-pcaprub/pkg-descr
new file mode 100644
index 000000000000..d8814b96a0d4
--- /dev/null
+++ b/net/rubygem-pcaprub/pkg-descr
@@ -0,0 +1,6 @@
+This goal of this project is to provide a consistent interface to LBL's libpcap
+packet capture library. This does not provide packet processing functionality,
+it simply provides the interface for capturing packets, and passing yielding
+those packets.
+
+WWW: https://github.com/shadowbq/pcaprub