aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2001-08-09 04:02:49 +0800
committerache <ache@FreeBSD.org>2001-08-09 04:02:49 +0800
commitf142679b0d146f798cee72e8cefebaa9c753ee48 (patch)
tree764a41b8e2d188d1e9812da88dba96c548175d65
parentf8c2ab2068d70caa15878932161ea4ac945f88de (diff)
downloadfreebsd-ports-gnome-f142679b0d146f798cee72e8cefebaa9c753ee48.tar.gz
freebsd-ports-gnome-f142679b0d146f798cee72e8cefebaa9c753ee48.tar.zst
freebsd-ports-gnome-f142679b0d146f798cee72e8cefebaa9c753ee48.zip
Enable 16bit pixels by default since they are enabled by default in newer
ImageMagick versions. Add WITHOUT_ option to disable them. Enable modules by default, much smaller executable up to 10Mb runtime. Add WITHOUT_ option to disable them. Use IMAGEMAGICK portion for two WITHOUT_ option names mentioned above - it allows to put them to /etc/make.conf without conflicts. Add few comments about options
-rw-r--r--graphics/ImageMagick/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 9c0a23e62973..f1a9b4ba597a 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -62,17 +62,18 @@ CONFIGURE_ARGS+= --with-threads
CONFIGURE_ARGS+= --without-threads
.endif
-.if defined(WITH_16BIT_PIXEL)
-CONFIGURE_ARGS+= --enable-16bit-pixel
-.else
+# Faster, but poor quality
+.if defined(WITHOUT_IMAGEMAGICK_16BIT_PIXEL)
CONFIGURE_ARGS+= --disable-16bit-pixel
.endif
+# Produce standard (small) GIFs
.if defined(HAVE_UNISYS_LICENSE)
CONFIGURE_ARGS+= --enable-lzw
.endif
-.if defined(WITH_MODULES)
+# Loadable coders, smaller executable
+.if !defined(WITHOUT_IMAGEMAGICK_MODULES)
LIB_DEPENDS+= ltdl.1:${PORTSDIR}/devel/libtool
LIBTOOLFLAGS= # none
CONFIGURE_ARGS+= --with-modules