aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2012-09-25 01:41:38 +0800
committerolivierd <olivierd@FreeBSD.org>2012-09-25 01:41:38 +0800
commitf513b87516ce3c7424d798e4b5c832fefae9d8a9 (patch)
treed1bfdbc54be988f0f656068a6a0447b3929f34e7
parentd25eb6b1d14550055a498071dcfeaf2da621bb7b (diff)
downloadfreebsd-ports-gnome-f513b87516ce3c7424d798e4b5c832fefae9d8a9.tar.gz
freebsd-ports-gnome-f513b87516ce3c7424d798e4b5c832fefae9d8a9.tar.zst
freebsd-ports-gnome-f513b87516ce3c7424d798e4b5c832fefae9d8a9.zip
- Force to install GLib schema
While here: - Move LICENSE to proper location - Clean headers - Remove ABI version - Change maintainer address - Convert to USE_PKGCONFIG Approved by: rene, miwi (mentors)
-rw-r--r--deskutils/steadyflow/Makefile26
-rw-r--r--deskutils/steadyflow/files/patch-data__net.launchpad.steadyflow.gschema.xml11
2 files changed, 22 insertions, 15 deletions
diff --git a/deskutils/steadyflow/Makefile b/deskutils/steadyflow/Makefile
index 808a37b4f428..df629c291b0c 100644
--- a/deskutils/steadyflow/Makefile
+++ b/deskutils/steadyflow/Makefile
@@ -1,35 +1,31 @@
-# New ports collection makefile for: steadyflow
-# Date created: 2011-01-28
-# Whom: Olivier Duchateau <duchateau.olivier@gmail.com>
-#
# $FreeBSD$
#
PORTNAME= steadyflow
PORTVERSION= 0.1.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
MASTER_SITES= http://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/ \
https://launchpadlibrarian.net/72208624/
-MAINTAINER= duchateau.olivier@gmail.com
+MAINTAINER= olivierd@FreeBSD.org
COMMENT= Simple download manager
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- gee.2:${PORTSDIR}/devel/libgee \
- notify.4:${PORTSDIR}/devel/libnotify \
- unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
-BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
-
LICENSE= GPLv3
+LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ gee:${PORTSDIR}/devel/libgee \
+ notify:${PORTSDIR}/devel/libnotify \
+ unique-1:${PORTSDIR}/x11-toolkits/unique
+BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
+
USE_CMAKE= yes
GLIB_SCHEMAS= net.launchpad.steadyflow.gschema.xml
-USE_GNOME= desktopfileutils glib20 gtk20 pkgconfig
+USE_GNOME= desktopfileutils glib20 gtk20
USE_GETTEXT= yes
INSTALLS_ICONS= yes
-
-CMAKE_ARGS= -DCOMPILE_GSETTINGS_ON_INSTALL:BOOL=OFF \
+USE_PKGCONFIG= build
+CMAKE_ARGS= -DCOMPILE_GSETTINGS_ON_INSTALL:BOOL=ON \
-DWANT_AYATANA:BOOL=OFF
MAN1= steadyflow.1
diff --git a/deskutils/steadyflow/files/patch-data__net.launchpad.steadyflow.gschema.xml b/deskutils/steadyflow/files/patch-data__net.launchpad.steadyflow.gschema.xml
new file mode 100644
index 000000000000..b473e34ea345
--- /dev/null
+++ b/deskutils/steadyflow/files/patch-data__net.launchpad.steadyflow.gschema.xml
@@ -0,0 +1,11 @@
+--- ./data/net.launchpad.steadyflow.gschema.xml.orig 2011-05-22 09:29:17.000000000 +0000
++++ ./data/net.launchpad.steadyflow.gschema.xml 2012-09-01 11:09:47.000000000 +0000
+@@ -35,7 +35,7 @@
+ <description>Show notification popups.</description>
+ </key>
+ <key name="start-minimized" type="b">
+- <default>true</default>
++ <default>false</default>
+ <description>Hide the main window when the application starts.</description>
+ </key>
+ <key name="default-post-download-action" enum="finish-action">