aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2010-04-17 00:09:15 +0800
committergerald <gerald@FreeBSD.org>2010-04-17 00:09:15 +0800
commitf605f75ce4018b924f7dc33dede338bc8eeed198 (patch)
tree42c1b8ccfcbd193170180544b5bc23a2aabe4d0d
parentc810b2505d5757146cb420713ab88a488dadf0a3 (diff)
downloadfreebsd-ports-gnome-f605f75ce4018b924f7dc33dede338bc8eeed198.tar.gz
freebsd-ports-gnome-f605f75ce4018b924f7dc33dede338bc8eeed198.tar.zst
freebsd-ports-gnome-f605f75ce4018b924f7dc33dede338bc8eeed198.zip
Force the use of system as and ld. This makes building and using this
port consistent across installations and avoids confusing error modes for users who may have others flavors of these tools earlier in PATH. On the way, sort CONFIGURE_ARGS. Triggered by: glarkin
-rw-r--r--lang/gcc42/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index 9d183f2dcf20..19b8c90409aa 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -53,14 +53,16 @@ WRKSRC= ${WRKDIR}/build
TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --disable-nls \
- --with-system-zlib \
- --with-libiconv-prefix=${LOCALBASE} \
- --with-gmp=${LOCALBASE} \
- --program-suffix=${SUFFIX} \
+CONFIGURE_ARGS+=--disable-nls \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
- --with-gxx-include-dir=${TARGLIB}/include/c++/
+ --program-suffix=${SUFFIX} \
+ --with-as=/usr/bin/as \
+ --with-gmp=${LOCALBASE} \
+ --with-gxx-include-dir=${TARGLIB}/include/c++/ \
+ --with-ld=/usr/bin/ld \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}