aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-27 02:56:29 +0800
committerrm <rm@FreeBSD.org>2012-10-27 02:56:29 +0800
commitf656e9f0ff410d058c8bf2e45ec69e58a4b0582a (patch)
tree7a6213a031e6ab9fc0b11fadf78d224c6e4e2e14
parentc1443a1f0463272d761a5d5be7c962da2c61eda0 (diff)
downloadfreebsd-ports-gnome-f656e9f0ff410d058c8bf2e45ec69e58a4b0582a.tar.gz
freebsd-ports-gnome-f656e9f0ff410d058c8bf2e45ec69e58a4b0582a.tar.zst
freebsd-ports-gnome-f656e9f0ff410d058c8bf2e45ec69e58a4b0582a.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - trim Makefile header - limit python version to 2.x only - move pkg-plist contents into Makefile:PLIST_FILES PR: 173105 Submitted by: rm (myself) Approved by: glarkin (maintainer, by mail) Feature safe: yes
-rw-r--r--www/trac-pagetopdf/Makefile23
-rw-r--r--www/trac-pagetopdf/pkg-plist1
2 files changed, 7 insertions, 17 deletions
diff --git a/www/trac-pagetopdf/Makefile b/www/trac-pagetopdf/Makefile
index a986cde258ef..e9b56c2210b0 100644
--- a/www/trac-pagetopdf/Makefile
+++ b/www/trac-pagetopdf/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: trac-pagetopdf
-# Date created: December 28 2006
-# Whom: Gerrit Beine <gerrit.beine@gmx.de>
-#
+# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-#
PORTNAME= pagetopdf
PORTVERSION= 0.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= www devel python
MASTER_SITES= http://www.gerritbeine.de/download/trac/
PKGNAMEPREFIX= trac-
@@ -18,16 +14,11 @@ COMMENT= Export trac wiki pages as PDFs
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
htmldoc:${PORTSDIR}/textproc/htmldoc
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
-USE_PYTHON= 2.5+
-NO_BUILD= yes
-USE_PYDISTUTILS=yes
-WRKSRC= ${WRKDIR}/${PORTNAME}plugin
-PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
-PYDISTUTILS_NOEGGINFO= yes
-
-do-build:
- @${DO_NADA}
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+PYDISTUTILS_PKGNAME= TracPageToPDF
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
.include <bsd.port.mk>
diff --git a/www/trac-pagetopdf/pkg-plist b/www/trac-pagetopdf/pkg-plist
deleted file mode 100644
index ce32a437fa73..000000000000
--- a/www/trac-pagetopdf/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%PYTHON_SITELIBDIR%%/TracPageToPDF-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg