aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-06 23:59:25 +0800
committerbapt <bapt@FreeBSD.org>2013-06-06 23:59:25 +0800
commitf7ca1ab0dc59d2c9844430bf67fb99caab4a16ae (patch)
treedfc5a0e207572d27fd88dcdd3eb72e40e0beec57
parent020ef88859922b290ce6b39c98822ab82a78f76c (diff)
downloadfreebsd-ports-gnome-f7ca1ab0dc59d2c9844430bf67fb99caab4a16ae.tar.gz
freebsd-ports-gnome-f7ca1ab0dc59d2c9844430bf67fb99caab4a16ae.tar.zst
freebsd-ports-gnome-f7ca1ab0dc59d2c9844430bf67fb99caab4a16ae.zip
Convert to new options framework
-rw-r--r--graphics/evas-loader-generic/Makefile9
-rw-r--r--graphics/vips/Makefile17
2 files changed, 18 insertions, 8 deletions
diff --git a/graphics/evas-loader-generic/Makefile b/graphics/evas-loader-generic/Makefile
index 69944393a6d5..56639151a81e 100644
--- a/graphics/evas-loader-generic/Makefile
+++ b/graphics/evas-loader-generic/Makefile
@@ -16,8 +16,13 @@ LICENSE= BSD
EVAS_GENERIC_LOADERS= gst pdf ps raw svg xcf
+#bmake compatibility
+.MAKE.FreeBSD_UL= yes
+
.for NODE in ${EVAS_GENERIC_LOADERS}
-OPTIONS+= ${NODE:U} "Install ${NODE} evas generic loader" on
+OPTIONS_DEFINE+= ${NODE:U}
+OPTIONS_DEFAULT+= ${NODE:U}
+${NODE:U}_DESC= Install ${NODE} evas generic loader
.endfor
DIST_SUBDIR= e17
@@ -36,7 +41,7 @@ CONFIGURE_ARGS+= --enable-image-loader-generic
.include <bsd.port.options.mk>
.for NODE in ${EVAS_GENERIC_LOADERS}
-. if !defined(WITHOUT_${NODE:U})
+. if ${PORT_OPTIONS:M${NODE:U}}
RUN_DEPENDS+= ${LOCALBASE}/lib/evas/utils/evas_image_loader.${NODE}:${PORTSDIR}/graphics/evas_generic_loaders-${NODE}
. endif
.endfor
diff --git a/graphics/vips/Makefile b/graphics/vips/Makefile
index f04621cfbe65..c496c4867c65 100644
--- a/graphics/vips/Makefile
+++ b/graphics/vips/Makefile
@@ -10,8 +10,10 @@ MASTER_SITES= http://www.vips.ecs.soton.ac.uk/supported/${PORTVERSION:R}/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Free image processing system
-OPTIONS+= LIBOIL "Use liboil for CPU-optimized primitives" on
-OPTIONS+= PYTHON "Create Python bindings" ${PYPRESENT}
+OPTIONS_DEFINE= LIBOIL PYTHON
+OPTIONS_DEFAULT= LIBOIL
+LIBOIL_DESC= Use leiboil for CPU-optimized primitives
+PYTHON_DESC= Create Python bindings
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
@@ -26,6 +28,9 @@ LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
lcms:${PORTSDIR}/graphics/lcms
PYPRESENT!= which python > /dev/null && echo on || echo off
+.if ${PYPRESENT} == on
+OPTIONS_DEFAULT+= PYTHON
+.endif
USE_GMAKE= yes
USES= gettext
USE_PERL5_BUILD=yes
@@ -39,8 +44,9 @@ post-configure:
${REINPLACE_CMD} -Ee 's,^(G?MSGFMT = *)$$,\1${LOCALBASE}/bin/msgfmt,g' \
${WRKSRC}/po/Makefile
+.include <bsd.port.options.mk>
# Don't extract doc/ subdirectory - the simplest way:
-.ifdef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
EXTRACT_AFTER_ARGS= --exclude doc
EXTRA_PATCHES= ${FILESDIR}/nodoc-patch
.endif
@@ -56,8 +62,7 @@ CONFIGURE_ARGS+=--with-$p-libraries=${LOCALBASE}/lib
.include "Makefile.man"
-.include <bsd.port.options.mk>
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
PLIST_SUB+= PY=""
.else
@@ -71,7 +76,7 @@ PLIST_SUB+= PY="@comment "
BROKEN= Does not compile on sparc64-9
.endif
-.if defined(WITH_LIBOIL)
+.if ${PORT_OPTIONS:MLIBOIL}
LIB_DEPENDS+= oil:${PORTSDIR}/devel/liboil
.else
CONFIGURE_ARGS+= --without-liboil