aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2010-07-28 00:43:37 +0800
committernox <nox@FreeBSD.org>2010-07-28 00:43:37 +0800
commitf8342e94ca5c8e963b241ff05480f1567e9a8aa8 (patch)
treed4e8380ead13c2443fa03aa129a472e5d0df9951
parent056af63857f7a8cd8b08d1b9adeea479041b294e (diff)
downloadfreebsd-ports-gnome-f8342e94ca5c8e963b241ff05480f1567e9a8aa8.tar.gz
freebsd-ports-gnome-f8342e94ca5c8e963b241ff05480f1567e9a8aa8.tar.zst
freebsd-ports-gnome-f8342e94ca5c8e963b241ff05480f1567e9a8aa8.zip
(Attempt to) fix build on head.
Submitted by: portsmon
-rw-r--r--emulators/kqemu-kmod-devel/Makefile3
-rw-r--r--emulators/kqemu-kmod-devel/files/patch-common-kqemu_int.h19
-rw-r--r--emulators/kqemu-kmod/Makefile3
-rw-r--r--emulators/kqemu-kmod/files/patch-common-kqemu_int.h19
4 files changed, 42 insertions, 2 deletions
diff --git a/emulators/kqemu-kmod-devel/Makefile b/emulators/kqemu-kmod-devel/Makefile
index 3eb03947eb41..08bd85ce98de 100644
--- a/emulators/kqemu-kmod-devel/Makefile
+++ b/emulators/kqemu-kmod-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kqemu
PORTVERSION= 1.4.0.p1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators kld
MASTER_SITES= http://bellard.org/qemu/ \
http://qemu.org/ \
@@ -88,6 +88,7 @@ post-patch:
.endif
do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} beforedepend && ${LN} -s @/sys sys)
@(cd ${BUILD_WRKSRC}/common; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} Makefile ${MAKE_ARGS} ${ALL_TARGET})
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
diff --git a/emulators/kqemu-kmod-devel/files/patch-common-kqemu_int.h b/emulators/kqemu-kmod-devel/files/patch-common-kqemu_int.h
new file mode 100644
index 000000000000..1d5edf76be9d
--- /dev/null
+++ b/emulators/kqemu-kmod-devel/files/patch-common-kqemu_int.h
@@ -0,0 +1,19 @@
+--- common/kqemu_int.h.orig
++++ common/kqemu_int.h
+@@ -17,8 +17,16 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+ #ifndef __ASSEMBLY__
++#ifdef __FreeBSD__
++#include <sys/stddef.h>
++#include <machine/stdarg.h>
++#include <sys/cdefs.h>
++#include <machine/_types.h>
++typedef __size_t size_t;
++#else
+ #include <stddef.h>
+ #include <stdarg.h>
++#endif
+
+ #ifndef NO_STD_TYPES
+
diff --git a/emulators/kqemu-kmod/Makefile b/emulators/kqemu-kmod/Makefile
index 31c025bfbfed..3f0d8b722a0e 100644
--- a/emulators/kqemu-kmod/Makefile
+++ b/emulators/kqemu-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kqemu
PORTVERSION= 1.3.0.p11
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= emulators kld
MASTER_SITES= http://bellard.org/qemu/ \
http://qemu.org/ \
@@ -76,6 +76,7 @@ post-patch:
.endif
do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} beforedepend && ${LN} -s @/sys sys)
@(cd ${BUILD_WRKSRC}/common; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} Makefile ${MAKE_ARGS} ${ALL_TARGET})
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
diff --git a/emulators/kqemu-kmod/files/patch-common-kqemu_int.h b/emulators/kqemu-kmod/files/patch-common-kqemu_int.h
new file mode 100644
index 000000000000..1d5edf76be9d
--- /dev/null
+++ b/emulators/kqemu-kmod/files/patch-common-kqemu_int.h
@@ -0,0 +1,19 @@
+--- common/kqemu_int.h.orig
++++ common/kqemu_int.h
+@@ -17,8 +17,16 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+ #ifndef __ASSEMBLY__
++#ifdef __FreeBSD__
++#include <sys/stddef.h>
++#include <machine/stdarg.h>
++#include <sys/cdefs.h>
++#include <machine/_types.h>
++typedef __size_t size_t;
++#else
+ #include <stddef.h>
+ #include <stdarg.h>
++#endif
+
+ #ifndef NO_STD_TYPES
+