aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2008-12-27 14:16:36 +0800
committerpgollucci <pgollucci@FreeBSD.org>2008-12-27 14:16:36 +0800
commitf940280853466ce4d3c53b1786ee54a7e1a68825 (patch)
tree40a692ed8f7a0f3e39b26b097e38af4ee4f152d4
parentfbb877cf5de8e94544f16370a4e610298bf32339 (diff)
downloadfreebsd-ports-gnome-f940280853466ce4d3c53b1786ee54a7e1a68825.tar.gz
freebsd-ports-gnome-f940280853466ce4d3c53b1786ee54a7e1a68825.tar.zst
freebsd-ports-gnome-f940280853466ce4d3c53b1786ee54a7e1a68825.zip
- Fix pkg-plist for NOPORTDOCS=yes [1]
- Fix path to README in pkg-message Reported by: QAT [1]
-rw-r--r--www/rt38/Makefile6
-rw-r--r--www/rt38/files/extra-patch-noportdocs-Makefile.in14
-rw-r--r--www/rt38/files/pkg-message.in2
-rw-r--r--www/rt40/Makefile6
-rw-r--r--www/rt40/files/extra-patch-noportdocs-Makefile.in14
-rw-r--r--www/rt40/files/pkg-message.in2
6 files changed, 42 insertions, 2 deletions
diff --git a/www/rt38/Makefile b/www/rt38/Makefile
index fc4b28eb0eb5..20b20bb6d566 100644
--- a/www/rt38/Makefile
+++ b/www/rt38/Makefile
@@ -18,6 +18,7 @@
PORTNAME= rt
PORTVERSION= 3.8.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/ \
ftp://ftp.eu.uu.net/pub/unix/ticketing/rt/release/ \
@@ -27,6 +28,10 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= RT is an industrial-grade ticketing system written in Perl
+.if defined(NOPORTDOCS)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-noportdocs-Makefile.in
+.endif
+
CONFLICTS= rt-2* rt-3.0* rt-3.2* rt-3.4* rt-3.6*
LATEST_LINK= rt38
@@ -143,6 +148,7 @@ IGNORE= options WITH_MODPERL and WITH_MODPERL2 are mutually exclusive
RT_PATH?= ${LOCALBASE}
RT_ETC_PATH?= ${LOCALBASE}/etc/${PORTNAME}38
RT_LAYOUT?= FreeBSD
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}38
DB_DBA_USER?= root
DB_DBA_PASSWORD?=
diff --git a/www/rt38/files/extra-patch-noportdocs-Makefile.in b/www/rt38/files/extra-patch-noportdocs-Makefile.in
new file mode 100644
index 000000000000..8f2e2547e525
--- /dev/null
+++ b/www/rt38/files/extra-patch-noportdocs-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in 2008-12-27 01:07:12.000000000 -0500
++++ /home/pgollucci/Makefile.in 2008-12-27 01:06:35.000000000 -0500
+@@ -419,10 +419,7 @@
+
+ # {{{ doc-install
+ doc-install:
+-@COMMENT_INPLACE_LAYOUT@ # RT 3.0.0 - RT 3.0.2 would accidentally create a file instead of a dir
+-@COMMENT_INPLACE_LAYOUT@ -[ -f $(DESTDIR)$(RT_DOC_PATH) ] && rm $(DESTDIR)$(RT_DOC_PATH)
+-@COMMENT_INPLACE_LAYOUT@ [ -d $(DESTDIR)$(RT_DOC_PATH) ] || $(INSTALL) -m 0755 -d $(DESTDIR)$(RT_DOC_PATH)
+-@COMMENT_INPLACE_LAYOUT@ -$(INSTALL) -m 0644 ./README $(DESTDIR)$(RT_DOC_PATH)/
++@COMMENT_INPLACE_LAYOUT@ /usr/bin/true
+ # }}}
+
+ # {{{ etc-install
diff --git a/www/rt38/files/pkg-message.in b/www/rt38/files/pkg-message.in
index 50ec1b927818..2381be4a10c2 100644
--- a/www/rt38/files/pkg-message.in
+++ b/www/rt38/files/pkg-message.in
@@ -5,7 +5,7 @@ To complete the installation of this port, please follow these steps:
1. Edit %%RT_PATH%%/etc/RT_SiteConfig.pm, by referring to
the default config file (%%RT_PATH%%/etc/RT_Config.pm).
2. Configure the email and web gateways. Please refer to
- 'SETTING UP THE MAIL GATEWAY' in %%RT_PATH%%/README
+ 'SETTING UP THE MAIL GATEWAY' in %%DOCSDIR%%/README
3. Restart Apache.
4. Do remember to *CHANGE* the root's password for the web interface.
The default is "password" (without the quotes.)
diff --git a/www/rt40/Makefile b/www/rt40/Makefile
index fc4b28eb0eb5..20b20bb6d566 100644
--- a/www/rt40/Makefile
+++ b/www/rt40/Makefile
@@ -18,6 +18,7 @@
PORTNAME= rt
PORTVERSION= 3.8.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/ \
ftp://ftp.eu.uu.net/pub/unix/ticketing/rt/release/ \
@@ -27,6 +28,10 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= RT is an industrial-grade ticketing system written in Perl
+.if defined(NOPORTDOCS)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-noportdocs-Makefile.in
+.endif
+
CONFLICTS= rt-2* rt-3.0* rt-3.2* rt-3.4* rt-3.6*
LATEST_LINK= rt38
@@ -143,6 +148,7 @@ IGNORE= options WITH_MODPERL and WITH_MODPERL2 are mutually exclusive
RT_PATH?= ${LOCALBASE}
RT_ETC_PATH?= ${LOCALBASE}/etc/${PORTNAME}38
RT_LAYOUT?= FreeBSD
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}38
DB_DBA_USER?= root
DB_DBA_PASSWORD?=
diff --git a/www/rt40/files/extra-patch-noportdocs-Makefile.in b/www/rt40/files/extra-patch-noportdocs-Makefile.in
new file mode 100644
index 000000000000..8f2e2547e525
--- /dev/null
+++ b/www/rt40/files/extra-patch-noportdocs-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in 2008-12-27 01:07:12.000000000 -0500
++++ /home/pgollucci/Makefile.in 2008-12-27 01:06:35.000000000 -0500
+@@ -419,10 +419,7 @@
+
+ # {{{ doc-install
+ doc-install:
+-@COMMENT_INPLACE_LAYOUT@ # RT 3.0.0 - RT 3.0.2 would accidentally create a file instead of a dir
+-@COMMENT_INPLACE_LAYOUT@ -[ -f $(DESTDIR)$(RT_DOC_PATH) ] && rm $(DESTDIR)$(RT_DOC_PATH)
+-@COMMENT_INPLACE_LAYOUT@ [ -d $(DESTDIR)$(RT_DOC_PATH) ] || $(INSTALL) -m 0755 -d $(DESTDIR)$(RT_DOC_PATH)
+-@COMMENT_INPLACE_LAYOUT@ -$(INSTALL) -m 0644 ./README $(DESTDIR)$(RT_DOC_PATH)/
++@COMMENT_INPLACE_LAYOUT@ /usr/bin/true
+ # }}}
+
+ # {{{ etc-install
diff --git a/www/rt40/files/pkg-message.in b/www/rt40/files/pkg-message.in
index 50ec1b927818..2381be4a10c2 100644
--- a/www/rt40/files/pkg-message.in
+++ b/www/rt40/files/pkg-message.in
@@ -5,7 +5,7 @@ To complete the installation of this port, please follow these steps:
1. Edit %%RT_PATH%%/etc/RT_SiteConfig.pm, by referring to
the default config file (%%RT_PATH%%/etc/RT_Config.pm).
2. Configure the email and web gateways. Please refer to
- 'SETTING UP THE MAIL GATEWAY' in %%RT_PATH%%/README
+ 'SETTING UP THE MAIL GATEWAY' in %%DOCSDIR%%/README
3. Restart Apache.
4. Do remember to *CHANGE* the root's password for the web interface.
The default is "password" (without the quotes.)