aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-03-08 07:39:10 +0800
committeredwin <edwin@FreeBSD.org>2004-03-08 07:39:10 +0800
commitf9b5f3c241e8b12d6915d507e3d7101259e2001c (patch)
tree5125ce1a3e9ae1cbee4ae99adb4a13195aae23d4
parent0deb4a26d0e602a52522cf25e78087d6d2428699 (diff)
downloadfreebsd-ports-gnome-f9b5f3c241e8b12d6915d507e3d7101259e2001c.tar.gz
freebsd-ports-gnome-f9b5f3c241e8b12d6915d507e3d7101259e2001c.tar.zst
freebsd-ports-gnome-f9b5f3c241e8b12d6915d507e3d7101259e2001c.zip
Let ports use the USE_SDL macro
PR: ports/61807 Submitted by: Edwin Groothuis <edwin@mavetju.org> Approved by: maintainer timeout
-rw-r--r--devel/directfb/Makefile7
-rw-r--r--emulators/xmame/Makefile3
-rw-r--r--emulators/yape/Makefile4
-rw-r--r--emulators/zsnes/Makefile7
-rw-r--r--graphics/synaesthesia/Makefile6
-rw-r--r--graphics/xmms-infinity/Makefile8
-rw-r--r--graphics/xmms-jess/Makefile5
-rw-r--r--graphics/xmms-nebulus/Makefile6
-rw-r--r--graphics/xmms-paranormal/Makefile7
-rw-r--r--lang/lush/Makefile4
-rw-r--r--misc/explosions/Makefile6
11 files changed, 16 insertions, 47 deletions
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index 5c445ce24cf0..5b54a9e431a3 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -16,14 +16,11 @@ MAINTAINER= fab@gcu.info
COMMENT= Graphic development lightweight API
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
png.5:${PORTSDIR}/graphics/png
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
-
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- CPPFLAGS="${PTHREAD_CFLAGS}" \
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
LDFLAGS="${PTHREAD_LIBS}"
+USE_SDL= sdl
USE_LIBTOOL= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 081dd2470ddd..ef9457b34543 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -189,8 +189,7 @@ pre-everything::
@${ECHO_MSG} "'make options' for more information."
@exit 1
.endif
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_SDL= sdl
DISPLAY_METHOD= SDL
SDLSOUNDCOMMENT=
.endif
diff --git a/emulators/yape/Makefile b/emulators/yape/Makefile
index ef8e4e125203..83eaee9fffdf 100644
--- a/emulators/yape/Makefile
+++ b/emulators/yape/Makefile
@@ -15,11 +15,9 @@ DISTNAME= yapeSDL-${PORTVERSION}
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Yet Another Commodore +4 Emulator
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
+USE_SDL= sdl
NO_WRKSUBDIR= yes
USE_REINPLACE= yes
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= yes
ALL_TARGET= yape
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index 29ae128ebf52..769b2b8a6c7f 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -19,9 +19,9 @@ COMMENT= Intel x86 only Super Nintendo Entertainment System (SNES) Emulator
# This must be >= 0.98!
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- png.5:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+USE_SDL= sdl
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -31,9 +31,6 @@ PLIST_FILES= bin/zsnes
# non-portable, for a portable version see emulators/snes9x
ONLY_FOR_ARCHS= i386
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
GNU_CONFIGURE= yes
diff --git a/graphics/synaesthesia/Makefile b/graphics/synaesthesia/Makefile
index 92381c9ab7a8..27e832814a89 100644
--- a/graphics/synaesthesia/Makefile
+++ b/graphics/synaesthesia/Makefile
@@ -14,17 +14,13 @@ MASTER_SITES= http://www.logarithmic.net/pfh/Synaesthesia/
MAINTAINER= petef@FreeBSD.org
COMMENT= Graphically represents sound in real time
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
-
+USE_SDL= sdl
USE_GMAKE= Yes
USE_REINPLACE= Yes
USE_X_PREFIX= Yes
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-sdl-prefix=${LOCALBASE}
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
post-patch:
@${REINPLACE_CMD} -e 's,stdint.h,inttypes.h,' `${FIND} ${WRKSRC} -name \*.cc -or -name \*.c`
diff --git a/graphics/xmms-infinity/Makefile b/graphics/xmms-infinity/Makefile
index 3c82e99bfa37..c8e529ecfeba 100644
--- a/graphics/xmms-infinity/Makefile
+++ b/graphics/xmms-infinity/Makefile
@@ -15,16 +15,12 @@ DISTNAME= infinity-${PORTVERSION}
MAINTAINER= dyeske@yahoo.com
COMMENT= A XMMS plug-in which generate full-screen interactive light effects
-LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
- SDL-1.1.5:${PORTSDIR}/devel/sdl12
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
-
PLIST_FILES= lib/xmms/Visualization/libinfinite.so
GNU_CONFIGURE= yes
+USE_SDL= sdl
USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= gtk12
diff --git a/graphics/xmms-jess/Makefile b/graphics/xmms-jess/Makefile
index aa7c5883e1b8..4abc75f587b3 100644
--- a/graphics/xmms-jess/Makefile
+++ b/graphics/xmms-jess/Makefile
@@ -16,12 +16,9 @@ MAINTAINER= dyeske@yahoo.com
COMMENT= A XMMS visualization plugin that uses SDL
BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+USE_SDL= sdl
GNU_CONFIGURE= yes
PLIST_FILES= lib/xmms/Visualization/libjess.so
USE_GNOME= glib12
diff --git a/graphics/xmms-nebulus/Makefile b/graphics/xmms-nebulus/Makefile
index 5da6f20ae89b..a18c49c3a867 100644
--- a/graphics/xmms-nebulus/Makefile
+++ b/graphics/xmms-nebulus/Makefile
@@ -15,10 +15,10 @@ MAINTAINER= dyeske@yahoo.com
COMMENT= A XMMS visualization plugin that uses SDL and OpenGL
BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
PLIST_FILES= lib/xmms/Visualization/libnebulus.so
+USE_SDL= sdl
USE_X_PREFIX= yes
USE_MESA= yes
USE_GNOME= gtk12
@@ -28,10 +28,6 @@ USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include"
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
-MAKE_ENV+= SDL_CONFIG=${SDL_CONFIG}
-
post-patch:
@${REINPLACE_CMD} -E -e \
's|SDL/SDL.h|SDL11/SDL.h|; \
diff --git a/graphics/xmms-paranormal/Makefile b/graphics/xmms-paranormal/Makefile
index 442a5823a8d6..29e68d1cb3a3 100644
--- a/graphics/xmms-paranormal/Makefile
+++ b/graphics/xmms-paranormal/Makefile
@@ -16,15 +16,14 @@ DISTNAME= paranormal-${PORTVERSION:S/.p/pre/}
MAINTAINER= dyeske@yahoo.com
COMMENT= An adaptation of the "OpenGL Spectrum Analyzer" from XMMS
-LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
- SDL-1.1.5:${PORTSDIR}/devel/sdl12
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include/libxml2/libxml" SDL_CONFIG="${SDL_CONFIG}"
+CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include/libxml2/libxml"
GNU_CONFIGURE= yes
+USE_SDL= sdl
INSTALLS_SHLIB= yes
USE_GNOME= gtk12
USE_GMAKE= yes
diff --git a/lang/lush/Makefile b/lang/lush/Makefile
index a003b08975ec..eb7e202b4ee3 100644
--- a/lang/lush/Makefile
+++ b/lang/lush/Makefile
@@ -14,12 +14,10 @@ MASTER_SITE_SUBDIR= lush
MAINTAINER= dyeske@yahoo.com
COMMENT= A high level object-oriented programming language
-LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GL= yes
-USE_SDL= yes
+USE_SDL= sdl image
GNU_CONFIGURE= yes
USE_REINPLACE= yes
diff --git a/misc/explosions/Makefile b/misc/explosions/Makefile
index f9e1d0136219..e48d86576d4f 100644
--- a/misc/explosions/Makefile
+++ b/misc/explosions/Makefile
@@ -15,15 +15,11 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/^0.//}
MAINTAINER= petef@FreeBSD.org
COMMENT= 3D objects flying around resembling explosions with various effects
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
+USE_SDL= sdl image
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_X_PREFIX= yes
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
-
post-patch:
@${PERL} -pi -e 's!CFLAGS=-Wall -O2!CFLAGS+=-Wall!; \
s!sdl-config!${SDL_CONFIG}!' \