aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-04-09 08:51:55 +0800
committerarved <arved@FreeBSD.org>2003-04-09 08:51:55 +0800
commitfa354714ab3a39d3d2a8fcf9d42e4f3de896144e (patch)
tree0939726aae5be834ad4e6c933269c772b83839f7
parentab70e474033366c800f918014b543bcb5245c9c3 (diff)
downloadfreebsd-ports-gnome-fa354714ab3a39d3d2a8fcf9d42e4f3de896144e.tar.gz
freebsd-ports-gnome-fa354714ab3a39d3d2a8fcf9d42e4f3de896144e.tar.zst
freebsd-ports-gnome-fa354714ab3a39d3d2a8fcf9d42e4f3de896144e.zip
Fix build on CURRENT
Reported by: many Tested by: jeff@walters.name (Jeff Walters), seanc
-rw-r--r--archivers/ark/Makefile10
-rw-r--r--comms/kremotecontrol/Makefile10
-rw-r--r--deskutils/kcharselect/Makefile10
-rw-r--r--math/kcalc/Makefile10
-rw-r--r--misc/kdeutils3/Makefile10
-rw-r--r--misc/kdeutils4/Makefile10
-rw-r--r--security/kgpg-kde4/Makefile10
-rw-r--r--security/kwallet/Makefile10
-rw-r--r--sysutils/kdf/Makefile10
-rw-r--r--sysutils/kfloppy/Makefile10
-rw-r--r--sysutils/sweeper/Makefile10
11 files changed, 99 insertions, 11 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/comms/kremotecontrol/Makefile b/comms/kremotecontrol/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/comms/kremotecontrol/Makefile
+++ b/comms/kremotecontrol/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/kcharselect/Makefile b/deskutils/kcharselect/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/deskutils/kcharselect/Makefile
+++ b/deskutils/kcharselect/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/kdeutils3/Makefile b/misc/kdeutils3/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/misc/kdeutils3/Makefile
+++ b/misc/kdeutils3/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/kdeutils4/Makefile b/misc/kdeutils4/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/misc/kdeutils4/Makefile
+++ b/misc/kdeutils4/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/kgpg-kde4/Makefile b/security/kgpg-kde4/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/security/kgpg-kde4/Makefile
+++ b/security/kgpg-kde4/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/kwallet/Makefile b/security/kwallet/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/security/kwallet/Makefile
+++ b/security/kwallet/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/kdf/Makefile b/sysutils/kdf/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/sysutils/kdf/Makefile
+++ b/sysutils/kdf/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/kfloppy/Makefile b/sysutils/kfloppy/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/sysutils/kfloppy/Makefile
+++ b/sysutils/kfloppy/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/sweeper/Makefile b/sysutils/sweeper/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/sysutils/sweeper/Makefile
+++ b/sysutils/sweeper/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>