aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-06-17 08:33:00 +0800
committernaddy <naddy@FreeBSD.org>2003-06-17 08:33:00 +0800
commitfc001e88a475118cb1c556ee58b87aefd818f8d1 (patch)
treee2094c0d1fd2a3dc4983372086bea5402626e610
parentdb0242e24aa53fad719f5f1d4b5400a2bc6054e1 (diff)
downloadfreebsd-ports-gnome-fc001e88a475118cb1c556ee58b87aefd818f8d1.tar.gz
freebsd-ports-gnome-fc001e88a475118cb1c556ee58b87aefd818f8d1.tar.zst
freebsd-ports-gnome-fc001e88a475118cb1c556ee58b87aefd818f8d1.zip
Fix format specifier.
Submitted by: Andrew Williams <andrew.s.williams@adelaide.edu.au>
-rw-r--r--audio/vorbis-tools/Makefile2
-rw-r--r--audio/vorbis-tools/files/patch-ogginfo_ogginfo2.c14
-rw-r--r--audio/vorbis-tools/files/patch-vcut_vcut.c14
3 files changed, 29 insertions, 1 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index ee4138e1a28c..8837718c8f75 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vorbis-tools
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 3
CATEGORIES= audio
MASTER_SITES= http://www.vorbis.com/files/1.0/unix/ \
diff --git a/audio/vorbis-tools/files/patch-ogginfo_ogginfo2.c b/audio/vorbis-tools/files/patch-ogginfo_ogginfo2.c
new file mode 100644
index 000000000000..a425ae9b6471
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-ogginfo_ogginfo2.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ogginfo/ogginfo2.c.orig Tue Jun 17 01:19:29 2003
++++ ogginfo/ogginfo2.c Tue Jun 17 01:20:35 2003
+@@ -27,7 +27,7 @@
+ #ifdef _WIN32
+ #define INT64FORMAT "%I64d"
+ #else
+-#define INT64FORMAT "%Ld"
++#define INT64FORMAT "%lld"
+ #endif
+
+ struct vorbis_release {
diff --git a/audio/vorbis-tools/files/patch-vcut_vcut.c b/audio/vorbis-tools/files/patch-vcut_vcut.c
new file mode 100644
index 000000000000..422ce50ee10a
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-vcut_vcut.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- vcut/vcut.c.orig Tue Jun 17 01:19:13 2003
++++ vcut/vcut.c Tue Jun 17 01:20:27 2003
+@@ -26,7 +26,7 @@
+ #ifdef _WIN32
+ #define FORMAT_INT64 "%I64d"
+ #else
+-#define FORMAT_INT64 "%Ld"
++#define FORMAT_INT64 "%lld"
+ #endif
+
+ static vcut_packet *save_packet(ogg_packet *packet)