aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2017-04-20 03:06:19 +0800
committercpm <cpm@FreeBSD.org>2017-04-20 03:06:19 +0800
commitfc3a8dec4c33ad038615e88f45f11e588f413b75 (patch)
tree46973d1cba44e2a67836b7052b5669eab8a0676e
parent5372f792e7482247ac0595998944b057fbecb39a (diff)
downloadfreebsd-ports-gnome-fc3a8dec4c33ad038615e88f45f11e588f413b75.tar.gz
freebsd-ports-gnome-fc3a8dec4c33ad038615e88f45f11e588f413b75.tar.zst
freebsd-ports-gnome-fc3a8dec4c33ad038615e88f45f11e588f413b75.zip
Add slave port of devel/py-docutils to support Python 3 version
PR: 217469 Submitted by: Danilo G. Baio <dbaio@bsd.com.br> Approved by: miwi (Python@)
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-docutils/Makefile4
-rw-r--r--textproc/py3-docutils/Makefile10
3 files changed, 13 insertions, 2 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b6bcc1dfb5db..a88ed8613e68 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1374,6 +1374,7 @@
SUBDIR += py3-alabaster
SUBDIR += py3-asciinema
SUBDIR += py3-chardet
+ SUBDIR += py3-docutils
SUBDIR += py3-hunspell
SUBDIR += py3-libxml2
SUBDIR += py3-pager
diff --git a/textproc/py-docutils/Makefile b/textproc/py-docutils/Makefile
index a8e20638d59f..f44248c95f05 100644
--- a/textproc/py-docutils/Makefile
+++ b/textproc/py-docutils/Makefile
@@ -15,11 +15,11 @@ LICENSE_COMB= multi
NO_ARCH= yes
USE_PYTHON= autoplist concurrent distutils
-USES= python
+USES?= python
OPTIONS_DEFINE= PYGMENTS
PYGMENTS_DESC= Syntax highlighting
-PYGMENTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments
+PYGMENTS_RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments
SCRIPTS= rst2html rst2latex rst2man rst2odt rst2odt_prepstyles \
rst2pseudoxml rst2s5 rst2xetex rst2xml rstpep2html
diff --git a/textproc/py3-docutils/Makefile b/textproc/py3-docutils/Makefile
new file mode 100644
index 000000000000..6628764cea90
--- /dev/null
+++ b/textproc/py3-docutils/Makefile
@@ -0,0 +1,10 @@
+# Created by: Danilo G. Baio <dbaio@bsd.com.br>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-docutils
+
+USES= python:3.3+
+
+PYGMENTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py3-pygments
+
+.include "${MASTERDIR}/Makefile"