aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-11-12 23:52:20 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-11-12 23:52:20 +0800
commitfcb859477d7bd91a650f0dcb88c3ad3c72a838f2 (patch)
tree410421424cabb77170518566628dc1f1794e4424
parent9b924761aa492d064814d00601439ba7ce409d4b (diff)
downloadfreebsd-ports-gnome-fcb859477d7bd91a650f0dcb88c3ad3c72a838f2.tar.gz
freebsd-ports-gnome-fcb859477d7bd91a650f0dcb88c3ad3c72a838f2.tar.zst
freebsd-ports-gnome-fcb859477d7bd91a650f0dcb88c3ad3c72a838f2.zip
- Support staging
- Make use of compier USES macro to determine compiler type
-rw-r--r--audio/xmms-sapplug/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
index a3192c74e14d..9b5fdd2be3ba 100644
--- a/audio/xmms-sapplug/Makefile
+++ b/audio/xmms-sapplug/Makefile
@@ -16,8 +16,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-USES= gmake
-NO_STAGE= yes
+USES= gmake compiler
USE_GNOME= glib12
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
@@ -28,13 +27,10 @@ PLIST_FILES= lib/xmms/Input/libsap.so
OPTIONS_DEFINE= OPTIMIZED_CFLAGS
-.include <bsd.port.options.mk>
-
-_CLANG!= ${CXX} --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
-ISCLANG= ${_CLANG:M[34][0-9]}
+.include <bsd.port.pre.mk>
# clang can build this without -fno-exceptions
-.if empty(ISCLANG)
+.if ${COMPILER_TYPE} == "gcc"
CXXFLAGS+= -fno-exceptions
.endif
@@ -56,9 +52,8 @@ post-patch:
${WRKSRC}/saplib/Makefile
do-install:
- ${INSTALL_DATA} ${WRKSRC}/libsap.so ${PREFIX}/lib/xmms/Input/libsap.so
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/xmms/Input
+ ${INSTALL_DATA} ${WRKSRC}/libsap.so \
+ ${STAGEDIR}${PREFIX}/lib/xmms/Input/libsap.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>