aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-09-04 21:11:02 +0800
committermat <mat@FreeBSD.org>2013-09-04 21:11:02 +0800
commitfdb0adeca7382387591a74280e52370806cc4b69 (patch)
treecfb0da10519f53012f579aaecf625f1ba7d8711b
parent339f532759c6d5f81e81c422b63c2e84aa62fb4d (diff)
downloadfreebsd-ports-gnome-fdb0adeca7382387591a74280e52370806cc4b69.tar.gz
freebsd-ports-gnome-fdb0adeca7382387591a74280e52370806cc4b69.tar.zst
freebsd-ports-gnome-fdb0adeca7382387591a74280e52370806cc4b69.zip
* Add devel/p5-Module-Build-Tiny support to USE_PERL5 with modbuildtiny.
* Add doc for the configure, modbuild and modbuildtiny options. Reviewed by: az, bapt Approved by: az, bapt
-rw-r--r--Mk/Uses/perl5.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index 7ca63e57fc0b..260cb489f339 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -26,7 +26,10 @@
# SITE_PERL - Directory name where site specific perl packages go.
# This value is added to PLIST_SUB.
# USE_PERL5 - If set, this port uses perl5 in one or more of the extract,
-# patch, build, install or run phases
+# patch, build, install or run phases.
+# It can also have configure, modbuild and modbuildtiny when
+# the port needs to run Makefile.PL, Build.PL and a
+# Module::Build::Tiny flavor of Build.PL.
.if !defined(_INCLUDE_USES_PERL5_MK)
_INCLUDE_USES_PERL5_MK= yes
@@ -147,12 +150,15 @@ _MANPAGES+= ${P5MAN${sect}:S%^%${PREFIX}/lib/perl5/${PERL_VER}/man/man${sect}/%}
.endif
.endfor
-.if ${_USE_PERL5:Mmodbuild}
+.if ${_USE_PERL5:Mmodbuild} || ${_USE_PERL5:Mmodbuildtiny}
_USE_PERL5+= configure
CONFIGURE_SCRIPT?= Build.PL
.if ${PORTNAME} != Module-Build
BUILD_DEPENDS+= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
.endif
+.if ${_USE_PERL5:Mmodbuildtiny}
+BUILD_DEPENDS+= ${SITE_PERL}/Module/Build/Tiny.pm:${PORTSDIR}/devel/p5-Module-Build-Tiny
+.endif
ALL_TARGET?=
PL_BUILD?= Build
CONFIGURE_ARGS+= \