aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-08-07 18:10:06 +0800
committerbsam <bsam@FreeBSD.org>2013-08-07 18:10:06 +0800
commitff8de846665d45ef34248d09ecb80e2d410f616e (patch)
tree744d085a5e34c58ebf9614bd54ee52edbe4e7d6a
parent2c1de282d0d69b816587eb9f72e4b67de21f35a3 (diff)
downloadfreebsd-ports-gnome-ff8de846665d45ef34248d09ecb80e2d410f616e.tar.gz
freebsd-ports-gnome-ff8de846665d45ef34248d09ecb80e2d410f616e.tar.zst
freebsd-ports-gnome-ff8de846665d45ef34248d09ecb80e2d410f616e.zip
. fix package build error when apparently the INDEX is built on [1]
a machine with clang while the package is not; . remove CPP configuration (it's not used with this port); . add "-L${LOCALBASE}/lib -liconv" to LDFLAGS due to the error: ----- [ 86%] Building CXX object src/tests/CMakeFiles/test2-static.dir/test2.cpp.o Linking CXX executable test2-static /usr/bin/ld: ^^^A: invalid DSO for symbol `libiconv_open' definition /usr/local/lib/libiconv.so.3: could not read symbols: Bad value ----- PR: ports/180608 [1] Submitted by: tijl [1]
-rw-r--r--graphics/oyranos/Makefile10
-rw-r--r--graphics/oyranos/pkg-plist5
2 files changed, 9 insertions, 6 deletions
diff --git a/graphics/oyranos/Makefile b/graphics/oyranos/Makefile
index 39cc9641b866..24589df70375 100644
--- a/graphics/oyranos/Makefile
+++ b/graphics/oyranos/Makefile
@@ -32,20 +32,20 @@ USE_GNOME= libxml2
USE_QT4= gui moc_build qmake_build rcc_build uic_build
USE_XORG= xfixes xinerama xrandr xxf86vm
CMAKE_ARGS+= -DXDG_CONFIG_DIR=${PREFIX}/etc/xdg
+LDFLAGS+= -L${LOCALBASE}/lib -liconv
MAN1= oyranos-config-fltk.1 oyranos-monitor-daemon.1 oyranos-monitor.1 \
oyranos-policy.1 oyranos-profile-graph.1 oyranos-profile-install.1 \
oyranos-profile.1 oyranos-profiles.1 oyranos-xforms-modules.1 qcmsevents.1
MAN3= oyranos-config.3 oyranos.3
-.if exists(/usr/bin/clang)
+.include <bsd.port.pre.mk>
+
+.if exists(/usr/bin/clang) && ${OSVERSION} > 901502
CC= /usr/bin/clang
-CPP= /usr/bin/clang-cpp
CXX= /usr/bin/clang++
-CONFIGURE_ENV+= CXXCPP="${CPP}"
.else
USE_GCC= 4.6+
-CONFIGURE_ENV+= CXXCPP="${CPP}"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/oyranos/pkg-plist b/graphics/oyranos/pkg-plist
index 996af05de0ae..f17fad99ec3f 100644
--- a/graphics/oyranos/pkg-plist
+++ b/graphics/oyranos/pkg-plist
@@ -532,12 +532,15 @@ share/pixmaps/qcmsevents.svg
%%DOCSDIR%%/html/unionoyValue__u__coll__graph.png
@dirrm %%DOCSDIR%%/html
@dirrm %%DOCSDIR%%
-@dirrmtry share/color/settings
@dirrmtry share/applications
+@dirrmtry share/color/settings
+@dirrmtry share/color
@dirrmtry lib/pkgconfig
@dirrm lib/oyranos/cmake
@dirrm lib/oyranos
@dirrmtry lib/colour/modules
@dirrmtry lib/colour
+@comment @dirrmtry etc/xdg/autostart
+@comment @dirrmtry etc/xdg
@dirrm include/oyranos/alpha
@dirrm include/oyranos