aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2014-07-03 18:07:29 +0800
committerolivierd <olivierd@FreeBSD.org>2014-07-03 18:07:29 +0800
commit02707cde203392d7908bb5d3965206d7bc8a740e (patch)
tree359743ba7cde2d9534a048028e0b133889be5133
parentac8c99fef0433d5298f38f325718667fa289d555 (diff)
downloadfreebsd-ports-gnome-02707cde203392d7908bb5d3965206d7bc8a740e.tar.gz
freebsd-ports-gnome-02707cde203392d7908bb5d3965206d7bc8a740e.tar.zst
freebsd-ports-gnome-02707cde203392d7908bb5d3965206d7bc8a740e.zip
Library that provides GLib and Gtk implementation of the DBusMenu protocol.
The DBusMenu protocol make it possible for applications to export and import their menus over DBus. WWW: https://launchpad.net/libdbusmenu
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libdbusmenu/Makefile60
-rw-r--r--devel/libdbusmenu/distinfo2
-rw-r--r--devel/libdbusmenu/files/patch-configure22
-rw-r--r--devel/libdbusmenu/files/patch-libdbusmenu-glib__menuitem.c20
-rw-r--r--devel/libdbusmenu/files/patch-libdbusmenu-glib__server.c15
-rw-r--r--devel/libdbusmenu/pkg-descr5
-rw-r--r--devel/libdbusmenu/pkg-plist89
8 files changed, 214 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a344636e6ca2..e0aaf3641f5b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -969,6 +969,7 @@
SUBDIR += libdap
SUBDIR += libdasm
SUBDIR += libdatrie
+ SUBDIR += libdbusmenu
SUBDIR += libdbusmenu-qt
SUBDIR += libdevq
SUBDIR += libdfui
diff --git a/devel/libdbusmenu/Makefile b/devel/libdbusmenu/Makefile
new file mode 100644
index 000000000000..499f34190a69
--- /dev/null
+++ b/devel/libdbusmenu/Makefile
@@ -0,0 +1,60 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= libdbusmenu
+PORTVERSION= 12.10.2
+CATEGORIES= devel
+MASTER_SITES= https://launchpadlibrarian.net/118249592/ \
+ https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}/+download/
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= GLib and Gtk Implementation of the DBusMenu protocol
+
+LICENSE= GPLv3 LGPL21 LGPL3
+LICENSE_COMB= multi
+LICENSE_DISTFILES= ${WRKSRC}/COPYING-GPL3 ${WRKSRC}/COPYING.2.1 \
+ ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen \
+ gtkdoc-check:${PORTSDIR}/textproc/gtk-doc
+LIB_DEPENDS= libjson-glib-1.0.so:${PORTSDIR}/devel/json-glib
+
+GNU_CONFIGURE= yes
+USES= gmake pkgconfig pathfix libtool
+USE_GNOME= glib20 intltool intlhack libxslt introspection:build
+USE_XORG= x11
+USE_LDCONFIG= yes
+
+PLIST_SUB= VERSION="0.4"
+
+OPTIONS_SINGLE= GTK
+OPTIONS_SINGLE_GTK= GTK2 GTK3
+OPTIONS_DEFAULT= GTK3
+
+CONFIGURE_ARGS= --disable-scrollkeeper \
+ --disable-dumper \
+ --disable-tests \
+ --disable-massivedebugging \
+ --enable-introspection=yes \
+ --disable-nls \
+ --enable-vala \
+ --without-omf-dir \
+ --without-help-dir
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGTK2}
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+=--enable-gtk --with-gtk=2
+PLIST_SUB+= GTK2=""
+PLIST_SUB+= GTK3="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MGTK3}
+USE_GNOME+= gtk30
+CONFIGURE_ARGS+=--enable-gtk --with-gtk=3
+PLIST_SUB+= GTK2="@comment "
+PLIST_SUB+= GTK3=""
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libdbusmenu/distinfo b/devel/libdbusmenu/distinfo
new file mode 100644
index 000000000000..cfd575bd8b14
--- /dev/null
+++ b/devel/libdbusmenu/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libdbusmenu-12.10.2.tar.gz) = 9d6ad4a0b918b342ad2ee9230cce8a095eb601cb0cee6ddc1122d0481f9d04c9
+SIZE (libdbusmenu-12.10.2.tar.gz) = 735730
diff --git a/devel/libdbusmenu/files/patch-configure b/devel/libdbusmenu/files/patch-configure
new file mode 100644
index 000000000000..dd0a035b7e45
--- /dev/null
+++ b/devel/libdbusmenu/files/patch-configure
@@ -0,0 +1,22 @@
+--- ./configure.orig 2012-10-03 15:57:06.000000000 +0000
++++ ./configure 2014-02-12 22:43:06.000000000 +0000
+@@ -14615,7 +14615,7 @@
+
+ fi
+ fi
+- USE_NLS=yes
++ #USE_NLS=yes
+
+
+ gt_cv_have_gettext=no
+@@ -15756,10 +15756,6 @@
+ as_fn_error $? "conditional \"WANT_TESTS\" was never defined.
+ Usually this means the macro was only invoked conditionally." "$LINENO" 5
+ fi
+-if test -z "${HAVE_VALGRIND_TRUE}" && test -z "${HAVE_VALGRIND_FALSE}"; then
+- as_fn_error $? "conditional \"HAVE_VALGRIND\" was never defined.
+-Usually this means the macro was only invoked conditionally." "$LINENO" 5
+-fi
+ if test -z "${HAVE_INTROSPECTION_TRUE}" && test -z "${HAVE_INTROSPECTION_FALSE}"; then
+ as_fn_error $? "conditional \"HAVE_INTROSPECTION\" was never defined.
+ Usually this means the macro was only invoked conditionally." "$LINENO" 5
diff --git a/devel/libdbusmenu/files/patch-libdbusmenu-glib__menuitem.c b/devel/libdbusmenu/files/patch-libdbusmenu-glib__menuitem.c
new file mode 100644
index 000000000000..d589fc1e958a
--- /dev/null
+++ b/devel/libdbusmenu/files/patch-libdbusmenu-glib__menuitem.c
@@ -0,0 +1,20 @@
+--- ./libdbusmenu-glib/menuitem.c.orig 2012-10-03 15:54:22.000000000 +0000
++++ ./libdbusmenu-glib/menuitem.c 2014-07-03 11:27:19.000000000 +0000
+@@ -974,7 +974,7 @@
+ }
+ return mi;
+ }
+- find_id_t find_id = {mi: NULL, id: id};
++ find_id_t find_id = {.mi = NULL, .id = id};
+ find_id_helper(mi, &find_id);
+ return find_id.mi;
+ }
+@@ -1712,7 +1712,7 @@
+
+ func(mi, data);
+ GList * children = dbusmenu_menuitem_get_children(mi);
+- foreach_struct_t foreach_data = {func: func, data: data};
++ foreach_struct_t foreach_data = {.func = func, .data = data};
+ g_list_foreach(children, foreach_helper, &foreach_data);
+ return;
+ }
diff --git a/devel/libdbusmenu/files/patch-libdbusmenu-glib__server.c b/devel/libdbusmenu/files/patch-libdbusmenu-glib__server.c
new file mode 100644
index 000000000000..0e01d4f81403
--- /dev/null
+++ b/devel/libdbusmenu/files/patch-libdbusmenu-glib__server.c
@@ -0,0 +1,15 @@
+--- ./libdbusmenu-glib/server.c.orig 2012-10-03 15:54:22.000000000 +0000
++++ ./libdbusmenu-glib/server.c 2014-07-03 11:29:01.000000000 +0000
+@@ -215,9 +215,9 @@
+ static GDBusNodeInfo * dbusmenu_node_info = NULL;
+ static GDBusInterfaceInfo * dbusmenu_interface_info = NULL;
+ static const GDBusInterfaceVTable dbusmenu_interface_table = {
+- method_call: bus_method_call,
+- get_property: bus_get_prop,
+- set_property: NULL /* No properties that can be set */
++ .method_call = bus_method_call,
++ .get_property = bus_get_prop,
++ .set_property = NULL /* No properties that can be set */
+ };
+ static method_table_t dbusmenu_method_table[METHOD_COUNT];
+
diff --git a/devel/libdbusmenu/pkg-descr b/devel/libdbusmenu/pkg-descr
new file mode 100644
index 000000000000..28e48ea8d26e
--- /dev/null
+++ b/devel/libdbusmenu/pkg-descr
@@ -0,0 +1,5 @@
+Library that provides GLib and Gtk implementation of the DBusMenu protocol.
+The DBusMenu protocol make it possible for applications to export and import
+their menus over DBus.
+
+WWW: https://launchpad.net/libdbusmenu
diff --git a/devel/libdbusmenu/pkg-plist b/devel/libdbusmenu/pkg-plist
new file mode 100644
index 000000000000..fd565658be6c
--- /dev/null
+++ b/devel/libdbusmenu/pkg-plist
@@ -0,0 +1,89 @@
+include/libdbusmenu-glib-%%VERSION%%/libdbusmenu-glib/client.h
+include/libdbusmenu-glib-%%VERSION%%/libdbusmenu-glib/dbusmenu-glib.h
+include/libdbusmenu-glib-%%VERSION%%/libdbusmenu-glib/enum-types.h
+include/libdbusmenu-glib-%%VERSION%%/libdbusmenu-glib/menuitem-proxy.h
+include/libdbusmenu-glib-%%VERSION%%/libdbusmenu-glib/menuitem.h
+include/libdbusmenu-glib-%%VERSION%%/libdbusmenu-glib/server.h
+include/libdbusmenu-glib-%%VERSION%%/libdbusmenu-glib/types.h
+%%GTK2%%include/libdbusmenu-gtk-%%VERSION%%/libdbusmenu-gtk/client.h
+%%GTK2%%include/libdbusmenu-gtk-%%VERSION%%/libdbusmenu-gtk/dbusmenu-gtk.h
+%%GTK2%%include/libdbusmenu-gtk-%%VERSION%%/libdbusmenu-gtk/menu.h
+%%GTK2%%include/libdbusmenu-gtk-%%VERSION%%/libdbusmenu-gtk/menuitem.h
+%%GTK2%%include/libdbusmenu-gtk-%%VERSION%%/libdbusmenu-gtk/parser.h
+%%GTK3%%include/libdbusmenu-gtk3-%%VERSION%%/libdbusmenu-gtk/client.h
+%%GTK3%%include/libdbusmenu-gtk3-%%VERSION%%/libdbusmenu-gtk/dbusmenu-gtk.h
+%%GTK3%%include/libdbusmenu-gtk3-%%VERSION%%/libdbusmenu-gtk/menu.h
+%%GTK3%%include/libdbusmenu-gtk3-%%VERSION%%/libdbusmenu-gtk/menuitem.h
+%%GTK3%%include/libdbusmenu-gtk3-%%VERSION%%/libdbusmenu-gtk/parser.h
+lib/girepository-1.0/Dbusmenu-%%VERSION%%.typelib
+%%GTK2%%lib/girepository-1.0/DbusmenuGtk-%%VERSION%%.typelib
+%%GTK3%%lib/girepository-1.0/DbusmenuGtk3-%%VERSION%%.typelib
+lib/libdbusmenu-glib.a
+lib/libdbusmenu-glib.so
+lib/libdbusmenu-glib.so.4
+lib/libdbusmenu-glib.so.4.0.12
+%%GTK2%%lib/libdbusmenu-gtk.a
+%%GTK2%%lib/libdbusmenu-gtk.so
+%%GTK2%%lib/libdbusmenu-gtk.so.4
+%%GTK2%%lib/libdbusmenu-gtk.so.4.0.12
+%%GTK3%%lib/libdbusmenu-gtk3.a
+%%GTK3%%lib/libdbusmenu-gtk3.so
+%%GTK3%%lib/libdbusmenu-gtk3.so.4
+%%GTK3%%lib/libdbusmenu-gtk3.so.4.0.12
+libdata/pkgconfig/dbusmenu-glib-%%VERSION%%.pc
+%%GTK2%%libdata/pkgconfig/dbusmenu-gtk-%%VERSION%%.pc
+%%GTK3%%libdata/pkgconfig/dbusmenu-gtk3-%%VERSION%%.pc
+libexec/dbusmenu-bench
+%%DOCSDIR%%/README.dbusmenu-bench
+share/gir-1.0/Dbusmenu-%%VERSION%%.gir
+%%GTK2%%share/gir-1.0/DbusmenuGtk-%%VERSION%%.gir
+%%GTK3%%share/gir-1.0/DbusmenuGtk3-%%VERSION%%.gir
+share/gtk-doc/html/libdbusmenu-glib/annotation-glossary.html
+share/gtk-doc/html/libdbusmenu-glib/api-index-deprecated.html
+share/gtk-doc/html/libdbusmenu-glib/api-index-full.html
+share/gtk-doc/html/libdbusmenu-glib/ch01.html
+share/gtk-doc/html/libdbusmenu-glib/home.png
+share/gtk-doc/html/libdbusmenu-glib/index.html
+share/gtk-doc/html/libdbusmenu-glib/index.sgml
+share/gtk-doc/html/libdbusmenu-glib/left.png
+share/gtk-doc/html/libdbusmenu-glib/libdbusmenu-glib-DbusmenuClient.html
+share/gtk-doc/html/libdbusmenu-glib/libdbusmenu-glib-DbusmenuMenuitem.html
+share/gtk-doc/html/libdbusmenu-glib/libdbusmenu-glib-DbusmenuMenuitemProxy.html
+share/gtk-doc/html/libdbusmenu-glib/libdbusmenu-glib-DbusmenuServer.html
+share/gtk-doc/html/libdbusmenu-glib/libdbusmenu-glib-Types.html
+share/gtk-doc/html/libdbusmenu-glib/libdbusmenu-glib.devhelp2
+share/gtk-doc/html/libdbusmenu-glib/object-tree.html
+share/gtk-doc/html/libdbusmenu-glib/right.png
+share/gtk-doc/html/libdbusmenu-glib/style.css
+share/gtk-doc/html/libdbusmenu-glib/up.png
+share/gtk-doc/html/libdbusmenu-gtk/annotation-glossary.html
+share/gtk-doc/html/libdbusmenu-gtk/api-index-deprecated.html
+share/gtk-doc/html/libdbusmenu-gtk/api-index-full.html
+share/gtk-doc/html/libdbusmenu-gtk/ch01.html
+share/gtk-doc/html/libdbusmenu-gtk/home.png
+share/gtk-doc/html/libdbusmenu-gtk/index.html
+share/gtk-doc/html/libdbusmenu-gtk/index.sgml
+share/gtk-doc/html/libdbusmenu-gtk/left.png
+share/gtk-doc/html/libdbusmenu-gtk/libdbusmenu-gtk-DbusmenuGtkClient.html
+share/gtk-doc/html/libdbusmenu-gtk/libdbusmenu-gtk-DbusmenuGtkMenu.html
+share/gtk-doc/html/libdbusmenu-gtk/libdbusmenu-gtk-menuitem.html
+share/gtk-doc/html/libdbusmenu-gtk/libdbusmenu-gtk-parser.html
+share/gtk-doc/html/libdbusmenu-gtk/libdbusmenu-gtk.devhelp2
+share/gtk-doc/html/libdbusmenu-gtk/object-tree.html
+share/gtk-doc/html/libdbusmenu-gtk/right.png
+share/gtk-doc/html/libdbusmenu-gtk/style.css
+share/gtk-doc/html/libdbusmenu-gtk/up.png
+share/vala/vapi/Dbusmenu-%%VERSION%%.vapi
+%%GTK2%%share/vala/vapi/DbusmenuGtk-%%VERSION%%.vapi
+%%GTK3%%share/vala/vapi/DbusmenuGtk3-%%VERSION%%.vapi
+@dirrm share/gtk-doc/html/libdbusmenu-gtk
+@dirrm share/gtk-doc/html/libdbusmenu-glib
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc
+@dirrm %%DOCSDIR%%
+%%GTK2%%@dirrm include/libdbusmenu-gtk-%%VERSION%%/libdbusmenu-gtk
+%%GTK2%%@dirrm include/libdbusmenu-gtk-%%VERSION%%
+%%GTK3%%@dirrm include/libdbusmenu-gtk3-%%VERSION%%/libdbusmenu-gtk
+%%GTK3%%@dirrm include/libdbusmenu-gtk3-%%VERSION%%
+@dirrm include/libdbusmenu-glib-%%VERSION%%/libdbusmenu-glib
+@dirrm include/libdbusmenu-glib-%%VERSION%%