aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2009-04-24 10:52:45 +0800
committerglarkin <glarkin@FreeBSD.org>2009-04-24 10:52:45 +0800
commit034f5fd0f4aae475fab260e512b9dcf264f7bc31 (patch)
treeb3af4ab4fb8b120a8adcd5d02b2b6aad20b48c51
parent6efb1872215ead703109e53604a29492554ac402 (diff)
downloadfreebsd-ports-gnome-034f5fd0f4aae475fab260e512b9dcf264f7bc31.tar.gz
freebsd-ports-gnome-034f5fd0f4aae475fab260e512b9dcf264f7bc31.tar.zst
freebsd-ports-gnome-034f5fd0f4aae475fab260e512b9dcf264f7bc31.zip
- Added patch to fix signature in BlockingQueue.h
- Take maintainership - Bump PORTREVISION - Minor Makefile style cleanups - Regenerated patch files with "make makepatch" PR: ports/124841 Submitted by: Michael <freebsdports at bindone dot de>
-rw-r--r--devel/zthread/Makefile10
-rw-r--r--devel/zthread/files/patch-include__zthread__Barrier.h20
-rw-r--r--devel/zthread/files/patch-include__zthread__BlockingQueue.h11
-rw-r--r--devel/zthread/files/patch-include__zthread__Guard.h (renamed from devel/zthread/files/patch-include_zthread_Guard.h)6
-rw-r--r--devel/zthread/files/patch-src__MutexImpl.h (renamed from devel/zthread/files/patch-src_MutexImpl.h)4
5 files changed, 41 insertions, 10 deletions
diff --git a/devel/zthread/Makefile b/devel/zthread/Makefile
index 334447c57c0f..bfd0778b96fb 100644
--- a/devel/zthread/Makefile
+++ b/devel/zthread/Makefile
@@ -7,12 +7,12 @@
PORTNAME= zthread
PORTVERSION= 2.3.2
+PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= ZThread-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= glarkin@FreeBSD.org
COMMENT= A platform-independent object-oriented C++ threading library
USE_AUTOTOOLS= libtool:15
@@ -33,8 +33,8 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/zthread/files/patch-include__zthread__Barrier.h b/devel/zthread/files/patch-include__zthread__Barrier.h
new file mode 100644
index 000000000000..fc575162096b
--- /dev/null
+++ b/devel/zthread/files/patch-include__zthread__Barrier.h
@@ -0,0 +1,20 @@
+--- ./include/zthread/Barrier.h.orig 2005-03-13 00:23:00.000000000 -0500
++++ ./include/zthread/Barrier.h 2009-04-23 15:03:09.000000000 -0400
+@@ -150,7 +150,7 @@
+
+ } else {
+
+- int myGeneration = _generation;
++ unsigned int myGeneration = _generation;
+
+ try {
+
+@@ -251,7 +251,7 @@
+
+ } else {
+
+- int myGeneration = _generation;
++ unsigned int myGeneration = _generation;
+
+ try {
+
diff --git a/devel/zthread/files/patch-include__zthread__BlockingQueue.h b/devel/zthread/files/patch-include__zthread__BlockingQueue.h
new file mode 100644
index 000000000000..39fa120745e1
--- /dev/null
+++ b/devel/zthread/files/patch-include__zthread__BlockingQueue.h
@@ -0,0 +1,11 @@
+--- ./include/zthread/BlockingQueue.h.orig 2005-03-12 21:04:18.000000000 -0500
++++ ./include/zthread/BlockingQueue.h 2009-04-23 15:03:09.000000000 -0400
+@@ -83,7 +83,7 @@
+ /**
+ * @see Queue::add(const T& item, unsigned long timeout)
+ */
+- virtual bool add(T item, unsigned long timeout) {
++ virtual bool add(const T& item, unsigned long timeout) {
+
+ try {
+
diff --git a/devel/zthread/files/patch-include_zthread_Guard.h b/devel/zthread/files/patch-include__zthread__Guard.h
index 6e0c7c933f60..403b09a9751d 100644
--- a/devel/zthread/files/patch-include_zthread_Guard.h
+++ b/devel/zthread/files/patch-include__zthread__Guard.h
@@ -1,6 +1,6 @@
---- include/zthread/Guard.h.orig Wed Jul 30 00:40:13 2003
-+++ include/zthread/Guard.h Fri Dec 24 21:15:17 2004
-@@ -490,7 +490,7 @@
+--- ./include/zthread/Guard.h.orig 2005-03-12 21:10:09.000000000 -0500
++++ ./include/zthread/Guard.h 2009-04-23 15:03:09.000000000 -0400
+@@ -491,7 +491,7 @@
try {
diff --git a/devel/zthread/files/patch-src_MutexImpl.h b/devel/zthread/files/patch-src__MutexImpl.h
index b169fdcc344d..3f4de57d0a62 100644
--- a/devel/zthread/files/patch-src_MutexImpl.h
+++ b/devel/zthread/files/patch-src__MutexImpl.h
@@ -1,5 +1,5 @@
---- src/MutexImpl.h.orig Wed Jul 30 00:40:14 2003
-+++ src/MutexImpl.h Fri Dec 24 21:15:17 2004
+--- ./src/MutexImpl.h.orig 2005-03-12 22:59:15.000000000 -0500
++++ ./src/MutexImpl.h 2009-04-23 15:03:09.000000000 -0400
@@ -153,7 +153,7 @@
_owner = self;