aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2018-10-19 04:23:18 +0800
committertijl <tijl@FreeBSD.org>2018-10-19 04:23:18 +0800
commit0391a6a9054d425428f48e1efb35a2feb191b9c6 (patch)
treef704de126ee859bfab20d0efc577da38c6c273e0
parent495e3f562c450a450e85d741eeec73f68670bffc (diff)
downloadfreebsd-ports-gnome-0391a6a9054d425428f48e1efb35a2feb191b9c6.tar.gz
freebsd-ports-gnome-0391a6a9054d425428f48e1efb35a2feb191b9c6.tar.zst
freebsd-ports-gnome-0391a6a9054d425428f48e1efb35a2feb191b9c6.zip
- Add missing Qt build dependencies.
- Patch CMakeLists.txt so bash isn't needed during build. Submitted by: swills
-rw-r--r--net/linphone/Makefile4
-rw-r--r--net/linphone/files/patch-CMakeLists.txt10
2 files changed, 12 insertions, 2 deletions
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index 2448bcd59b17..8b55cb3baeb7 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -15,8 +15,8 @@ LIB_DEPENDS= libbctoolbox.so:net/bctoolbox \
liblinphone++.so:net/liblinphone
USES= cmake:outsource pkgconfig qt:5
-USE_QT= concurrent core gui linguisttools network qml quick \
- quickcontrols2 speech svg testlib widgets
+USE_QT= buildtools_build concurrent core gui linguisttools network \
+ qmake_build qml quick quickcontrols2 speech svg testlib widgets
post-patch:
@${REINPLACE_CMD} 's/LINPHONE_QT_GIT_VERSION/"${PORTVERSION}"/' \
diff --git a/net/linphone/files/patch-CMakeLists.txt b/net/linphone/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..3e6f2a64b189
--- /dev/null
+++ b/net/linphone/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2017-07-21 13:14:18 UTC
++++ CMakeLists.txt
+@@ -342,7 +342,6 @@ else ()
+ endif ()
+
+ if (NOT WIN32)
+- add_dependencies(update_translations check_qml)
+ endif ()
+ set_target_properties(${TARGET_NAME} PROPERTIES OUTPUT_NAME "${EXECUTABLE_NAME}")
+ set_target_properties(${TESTER_TARGET_NAME} PROPERTIES OUTPUT_NAME "${TESTER_EXECUTABLE_NAME}")