aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2003-09-04 22:51:06 +0800
committerglewis <glewis@FreeBSD.org>2003-09-04 22:51:06 +0800
commit039a551cb0bf69b2bf8522750016d249a295c8cc (patch)
treea1ba92ebb317d32ef361a6e75c30d9771c7eb873
parent0d84a1209bf8765e8712588f8d9806a73147d1b2 (diff)
downloadfreebsd-ports-gnome-039a551cb0bf69b2bf8522750016d249a295c8cc.tar.gz
freebsd-ports-gnome-039a551cb0bf69b2bf8522750016d249a295c8cc.tar.zst
freebsd-ports-gnome-039a551cb0bf69b2bf8522750016d249a295c8cc.zip
. Add a port of XawPlus:
XawPlus is a clone of the original Xaw library, providing a more up to date look and some extensions to the original Athena widget set. This library is as compatible as possible to the original. It should be possible to compile the source code of an Xaw client without any changes (except the include path of the XawPlus header files) to get the new look of XawPlus to this client. XawPlus makes it possible to use XPM pixmaps, tooltips, a truncate mechanism for too long label strings and UTF8 coded UNICODE labels without changing the code of your application. XawPlus comes with a set of adapted applications using also the new features of XawPlus. WWW: http://people.freenet.de/kra/XawPlus PR: 47700 Submitted by: Normal User <freebsd@falx.port5.com>
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/XawPlus/Makefile41
-rw-r--r--x11-toolkits/XawPlus/distinfo1
-rw-r--r--x11-toolkits/XawPlus/files/patch-Makefile60
-rw-r--r--x11-toolkits/XawPlus/files/patch-test::Makefile66
-rw-r--r--x11-toolkits/XawPlus/pkg-descr14
-rw-r--r--x11-toolkits/XawPlus/pkg-message10
-rw-r--r--x11-toolkits/XawPlus/pkg-plist116
8 files changed, 309 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 4504378f5984..f313dcb0ad3c 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -3,6 +3,7 @@
SUBDIR += SoXt
SUBDIR += Xaw3d
+ SUBDIR += XawPlus
SUBDIR += at-spi
SUBDIR += bakery
SUBDIR += blt
diff --git a/x11-toolkits/XawPlus/Makefile b/x11-toolkits/XawPlus/Makefile
new file mode 100644
index 000000000000..0f2df6d50468
--- /dev/null
+++ b/x11-toolkits/XawPlus/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: XawPlus
+# Date created: 30 January 2003
+# Whom: DNPM <freebsd@falx.port5.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XawPlus
+PORTVERSION= 3.1.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://people.freenet.de/kra/XawPlus/
+DISTNAME= ${PORTNAME:L}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A replacement for Xaw with a nicer 3-D look and some extensions
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%X11BASE%%/lib
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @cd ${WRKSRC} && ${FIND} . -name '*.orig' -delete
+
+do-configure:
+ ${REINPLACE_CMD} -e 's:%%X11BASE%%:${X11BASE}:' ${WRKSRC}/test/Makefile
+ -@${RM} -f ${WRKSRC}/test/Makefile.bak
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/test/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/XawPlus/distinfo b/x11-toolkits/XawPlus/distinfo
new file mode 100644
index 000000000000..5a834a147ace
--- /dev/null
+++ b/x11-toolkits/XawPlus/distinfo
@@ -0,0 +1 @@
+MD5 (xawplus-3.1.0.tgz) = 4a2ce98279bb3e2b9879bd04dd1136f9
diff --git a/x11-toolkits/XawPlus/files/patch-Makefile b/x11-toolkits/XawPlus/files/patch-Makefile
new file mode 100644
index 000000000000..0332adb09ffe
--- /dev/null
+++ b/x11-toolkits/XawPlus/files/patch-Makefile
@@ -0,0 +1,60 @@
+$FreeBSD$
+
+--- Makefile.orig Sat Sep 7 12:59:26 2002
++++ Makefile Wed Jan 29 17:09:14 2003
+@@ -22,9 +22,9 @@
+ # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ #
+
+-LIB_PATH = -L/usr/X11/lib # Libraries for X
+-INC_PATH = -I. -I/usr/X11/include # Header files for X
+-INST_LIBS= /usr/X11/lib
++LIB_PATH = -L${X11BASE}/lib # Libraries for X
++INC_PATH = -I. -I${X11BASE}/include # Header files for X
++INST_LIBS= ${PREFIX}/lib
+
+ XAW= ./X11/XawPlus
+
+@@ -39,10 +39,12 @@
+ MenuButton.o Toggle.o Panner.o Command.o Repeater.o \
+ Grip.o Scrollbar.o List.o \
+ Tree.o DrawingArea.o StripChart.o Dialog.o
++all: lib
+
+-all: lib install
+ lib: libXawPlus.a libXawPlus.so.3.1 libXaw.so.6.6 libXaw.so.7.0
+
++.PHONY: clean
++
+ clean:
+ rm -f *.o *.a *.so*
+
+@@ -53,7 +55,7 @@
+
+ libXawPlus.so.3.1: $(OBJS)
+ $(CC) -shared -Wl,-soname,libXawPlus.so.3 \
+- -o libXawPlus.so.3.1 $(OBJS)
++ -o libXawPlus.so.3 $(OBJS)
+
+ libXaw.so.6.6: $(OBJS)
+ $(CC) -shared -Wl,-soname,libXaw.so.6 \
+@@ -66,14 +68,14 @@
+ # --- This only works as superuser root
+
+ install:
+- rm -rf /usr/X11/include/X11/XawPlus
+- mkdir -p /usr/X11/include/X11/XawPlus
+- cp ./X11/XawPlus/*.h /usr/X11/include/X11/XawPlus
++ rm -rf ${PREFIX}/include/X11/XawPlus
++ mkdir -p ${PREFIX}/include/X11/XawPlus
++ ${BSD_INSTALL_DATA} ./X11/XawPlus/*.h ${PREFIX}/include/X11/XawPlus
+ cp libXawPlus.a $(INST_LIBS)
+ rm -f $(INST_LIBS)/libXawPlus.so.3 $(INST_LIBS)/libXawPlus.so
+- cp libXawPlus.so.3.1 $(INST_LIBS)
++ ${BSD_INSTALL_DATA} libXawPlus.so.3 $(INST_LIBS)
+ ldconfig
+- ln -s $(INST_LIBS)/libXawPlus.so.3.1 $(INST_LIBS)/libXawPlus.so
++ ln -s $(INST_LIBS)/libXawPlus.so.3 $(INST_LIBS)/libXawPlus.so
+
+ installxaw:
+ rm -f $(INST_LIBS)/libXaw.so.6 \
diff --git a/x11-toolkits/XawPlus/files/patch-test::Makefile b/x11-toolkits/XawPlus/files/patch-test::Makefile
new file mode 100644
index 000000000000..e0450de740ab
--- /dev/null
+++ b/x11-toolkits/XawPlus/files/patch-test::Makefile
@@ -0,0 +1,66 @@
+$FreeBSD$
+
+--- test/Makefile.orig Sat Aug 10 13:14:54 2002
++++ test/Makefile Wed Jan 29 15:59:24 2003
+@@ -1,13 +1,13 @@
+ #
+-# Makefile fot the test programs
+-# This makefile requires libXawPlus.a in the
+-# parent directory !
++# Makefile for the test programs
+ #
+ # Roland Krause 2000
+ #
+
+-LIB_PATH = -L/usr/X11/lib # Libraries for X
+-INC_PATH = -I/usr/X11/include # Header for X
++PREFIX=%%X11BASE%%
++
++LIB_PATH = -L$(PREFIX)/lib # Libraries for X
++INC_PATH = -I$(PREFIX)/include # Header for X
+ LIBRARIES = -lXmu -lXext -lXt -lXpm -lX11
+
+ CC = gcc
+@@ -19,32 +19,33 @@
+
+ # --- Compile the programs
+
+-test_encoding: test_encoding.o ../libXawPlus.a
+- $(CC) -o test_encoding $(LIB_PATH) test_encoding.o ../libXawPlus.a $(LIBRARIES)
++test_encoding: test_encoding.o $(PREFIX)/lib/libXawPlus.a
++ $(CC) -o test_encoding $(LIB_PATH) test_encoding.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
+
+ test_encoding.o:test_encoding.c
+ $(CC) $(FLAGS) $(INC_PATH) -c test_encoding.c
+
+-test_pixmap: test_pixmap.o ../libXawPlus.a
+- $(CC) -o test_pixmap $(LIB_PATH) test_pixmap.o ../libXawPlus.a $(LIBRARIES)
++test_pixmap: test_pixmap.o $(PREFIX)/lib/libXawPlus.a
++ $(CC) -o test_pixmap $(LIB_PATH) test_pixmap.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
+
+ test_pixmap.o: test_pixmap.c
+ $(CC) $(FLAGS) $(INC_PATH) -c test_pixmap.c
+
+-test_scrbar: test_scrbar.o ../libXawPlus.a
+- $(CC) -o test_scrbar $(LIB_PATH) test_scrbar.o ../libXawPlus.a $(LIBRARIES)
++test_scrbar: test_scrbar.o $(PREFIX)/lib/libXawPlus.a
++ $(CC) -o test_scrbar $(LIB_PATH) test_scrbar.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
+
+ test_scrbar.o: test_scrbar.c
+ $(CC) $(FLAGS) $(INC_PATH) -c test_scrbar.c
+
+-test_menu: test_menu.o ../libXawPlus.a
+- $(CC) -o test_menu $(LIB_PATH) test_menu.o ../libXawPlus.a $(LIBRARIES)
++test_menu: test_menu.o $(PREFIX)/lib/libXawPlus.a
++ $(CC) -o test_menu $(LIB_PATH) test_menu.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
+
+ test_menu.o: test_menu.c
+ $(CC) $(FLAGS) $(INC_PATH) -c test_menu.c
+
+-
+ # --- Clean up
++
++.PHONY: clean
+
+ clean:
+ rm -f *.o $(PROGS)
diff --git a/x11-toolkits/XawPlus/pkg-descr b/x11-toolkits/XawPlus/pkg-descr
new file mode 100644
index 000000000000..ff924ddebda0
--- /dev/null
+++ b/x11-toolkits/XawPlus/pkg-descr
@@ -0,0 +1,14 @@
+XawPlus is a clone of the original Xaw library, providing a more up to date
+look and some extensions to the original Athena widget set. This library is
+as compatible as possible to the original. It should be possible to compile
+the source code of an Xaw client without any changes (except the include path
+of the XawPlus header files) to get the new look of XawPlus to this client.
+
+XawPlus makes it possible to use XPM pixmaps, tooltips, a truncate mechanism
+for too long label strings and UTF8 coded UNICODE labels without changing the
+code of your application.
+
+XawPlus comes with a set of adapted applications using also the new
+features of XawPlus.
+
+WWW: http://people.freenet.de/kra/XawPlus
diff --git a/x11-toolkits/XawPlus/pkg-message b/x11-toolkits/XawPlus/pkg-message
new file mode 100644
index 000000000000..1dd5d3934f52
--- /dev/null
+++ b/x11-toolkits/XawPlus/pkg-message
@@ -0,0 +1,10 @@
+*******************************************************************
+If you want XawPlus to replace the default Athena Widget Set
+so most X applications will get a 3-D look, do this (as root):
+
+cd ${PREFIX}/lib
+mv libXaw.so.7 libXaw2d.so.7
+rm libXaw.so
+ln -s libXawPlus.so.3 libXaw.so.7
+ln -s libXawPlus.so.3 libXaw.so
+*******************************************************************
diff --git a/x11-toolkits/XawPlus/pkg-plist b/x11-toolkits/XawPlus/pkg-plist
new file mode 100644
index 000000000000..2544709aabb2
--- /dev/null
+++ b/x11-toolkits/XawPlus/pkg-plist
@@ -0,0 +1,116 @@
+lib/libXawPlus.a
+lib/libXawPlus.so
+lib/libXawPlus.so.3
+include/X11/XawPlus/AsciiSink.h
+include/X11/XawPlus/AsciiSinkP.h
+include/X11/XawPlus/AsciiSrc.h
+include/X11/XawPlus/AsciiSrcP.h
+include/X11/XawPlus/AsciiText.h
+include/X11/XawPlus/AsciiTextP.h
+include/X11/XawPlus/Box.h
+include/X11/XawPlus/BoxP.h
+include/X11/XawPlus/Cardinals.h
+include/X11/XawPlus/Command.h
+include/X11/XawPlus/CommandP.h
+include/X11/XawPlus/Dialog.h
+include/X11/XawPlus/DialogP.h
+include/X11/XawPlus/DrawingArea.h
+include/X11/XawPlus/DrawingAreaP.h
+include/X11/XawPlus/Form.h
+include/X11/XawPlus/FormP.h
+include/X11/XawPlus/Grip.h
+include/X11/XawPlus/GripP.h
+include/X11/XawPlus/IconList.h
+include/X11/XawPlus/Label.h
+include/X11/XawPlus/LabelP.h
+include/X11/XawPlus/List.h
+include/X11/XawPlus/ListP.h
+include/X11/XawPlus/MenuButtoP.h
+include/X11/XawPlus/MenuButton.h
+include/X11/XawPlus/MultiSink.h
+include/X11/XawPlus/MultiSinkP.h
+include/X11/XawPlus/MultiSrc.h
+include/X11/XawPlus/MultiSrcP.h
+include/X11/XawPlus/Paned.h
+include/X11/XawPlus/PanedP.h
+include/X11/XawPlus/Panner.h
+include/X11/XawPlus/PannerP.h
+include/X11/XawPlus/Porthole.h
+include/X11/XawPlus/PortholeP.h
+include/X11/XawPlus/Repeater.h
+include/X11/XawPlus/RepeaterP.h
+include/X11/XawPlus/Reports.h
+include/X11/XawPlus/Scrollbar.h
+include/X11/XawPlus/ScrollbarP.h
+include/X11/XawPlus/Simple.h
+include/X11/XawPlus/SimpleMenP.h
+include/X11/XawPlus/SimpleMenu.h
+include/X11/XawPlus/SimpleP.h
+include/X11/XawPlus/Sme.h
+include/X11/XawPlus/SmeBSB.h
+include/X11/XawPlus/SmeBSBP.h
+include/X11/XawPlus/SmeLine.h
+include/X11/XawPlus/SmeLineP.h
+include/X11/XawPlus/SmeP.h
+include/X11/XawPlus/StrToPmap.h
+include/X11/XawPlus/StripCharP.h
+include/X11/XawPlus/StripChart.h
+include/X11/XawPlus/Text.h
+include/X11/XawPlus/TextP.h
+include/X11/XawPlus/TextSink.h
+include/X11/XawPlus/TextSinkP.h
+include/X11/XawPlus/TextSrc.h
+include/X11/XawPlus/TextSrcP.h
+include/X11/XawPlus/Toggle.h
+include/X11/XawPlus/ToggleP.h
+include/X11/XawPlus/Tree.h
+include/X11/XawPlus/TreeP.h
+include/X11/XawPlus/VendorEP.h
+include/X11/XawPlus/Viewport.h
+include/X11/XawPlus/ViewportP.h
+include/X11/XawPlus/XawImP.h
+include/X11/XawPlus/XawInit.h
+@dirrm include/X11/XawPlus
+%%PORTDOCS%%%%DOCSDIR%%/AsciiSink.html
+%%PORTDOCS%%%%DOCSDIR%%/AsciiSource.html
+%%PORTDOCS%%%%DOCSDIR%%/AsciiText.html
+%%PORTDOCS%%%%DOCSDIR%%/Box.html
+%%PORTDOCS%%%%DOCSDIR%%/Command.html
+%%PORTDOCS%%%%DOCSDIR%%/Dialog.html
+%%PORTDOCS%%%%DOCSDIR%%/DrawingArea.html
+%%PORTDOCS%%%%DOCSDIR%%/Form.html
+%%PORTDOCS%%%%DOCSDIR%%/Grip.html
+%%PORTDOCS%%%%DOCSDIR%%/IconList.html
+%%PORTDOCS%%%%DOCSDIR%%/Label.html
+%%PORTDOCS%%%%DOCSDIR%%/List.html
+%%PORTDOCS%%%%DOCSDIR%%/MenuButton.html
+%%PORTDOCS%%%%DOCSDIR%%/Paned.html
+%%PORTDOCS%%%%DOCSDIR%%/Panner.html
+%%PORTDOCS%%%%DOCSDIR%%/Porthole.html
+%%PORTDOCS%%%%DOCSDIR%%/Repeater.html
+%%PORTDOCS%%%%DOCSDIR%%/Scrollbar.html
+%%PORTDOCS%%%%DOCSDIR%%/Simple.html
+%%PORTDOCS%%%%DOCSDIR%%/SimpleMenu.html
+%%PORTDOCS%%%%DOCSDIR%%/Sme.html
+%%PORTDOCS%%%%DOCSDIR%%/SmeBSB.html
+%%PORTDOCS%%%%DOCSDIR%%/SmeLine.html
+%%PORTDOCS%%%%DOCSDIR%%/StripChart.html
+%%PORTDOCS%%%%DOCSDIR%%/Text.html
+%%PORTDOCS%%%%DOCSDIR%%/TextActions.html
+%%PORTDOCS%%%%DOCSDIR%%/TextFuncs.html
+%%PORTDOCS%%%%DOCSDIR%%/TextSink.html
+%%PORTDOCS%%%%DOCSDIR%%/TextSource.html
+%%PORTDOCS%%%%DOCSDIR%%/Toggle.html
+%%PORTDOCS%%%%DOCSDIR%%/Tree.html
+%%PORTDOCS%%%%DOCSDIR%%/Viewport.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/exit.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/mini-question.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/test_encoding.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/test_menu.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/test_pixmap.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/test_scrbar.c
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%