aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-12-08 16:59:28 +0800
committerpav <pav@FreeBSD.org>2009-12-08 16:59:28 +0800
commit039ed560744cf053a3249bb8a51f21c53c4510d8 (patch)
tree3c2047f4349caae94c73ccbd4d1ae651786a2bf0
parentaf159121148caea633da7590cabefc0ae730239a (diff)
downloadfreebsd-ports-gnome-039ed560744cf053a3249bb8a51f21c53c4510d8.tar.gz
freebsd-ports-gnome-039ed560744cf053a3249bb8a51f21c53c4510d8.tar.zst
freebsd-ports-gnome-039ed560744cf053a3249bb8a51f21c53c4510d8.zip
- Remove support for ucd-snmp4 in ports, that also support net-snmp5.
(ucd-snmp4 port is past expiration date)
-rw-r--r--lang/php4/Makefile.ext11
-rw-r--r--lang/php5/Makefile.ext15
-rw-r--r--lang/php53/Makefile.ext15
-rw-r--r--mail/cyrus-imapd22/Makefile12
-rw-r--r--mail/cyrus-imapd23/Makefile12
-rw-r--r--mail/cyrus-imapd24/Makefile12
-rw-r--r--net-mgmt/mbrowse/Makefile16
-rw-r--r--net-mgmt/p5-SNMP-Util/Makefile10
-rw-r--r--net-mgmt/p5-SNMP-Util/pkg-descr4
-rw-r--r--sysutils/jailadmin/Makefile4
10 files changed, 20 insertions, 91 deletions
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index 02c1a6ded751..623534cc38e0 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -293,10 +293,9 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
+LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
-
-OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
.endif
.if ${PHP_MODNAME} == "sockets"
@@ -466,14 +465,6 @@ post-patch:
@${REINPLACE_CMD} "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/pfpro.c
.endif
-.if ${PHP_MODNAME} == "snmp"
-. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
-LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-. else
-LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-. endif
-.endif
-
.if ${PHP_MODNAME} == "zlib"
post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 05dbbe16da11..caab1b6c1e03 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -378,10 +378,9 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
-USE_OPENSSL= yes
-
-OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
+LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
+USE_OPENSSL= yes
.endif
.if ${PHP_MODNAME} == "soap"
@@ -601,14 +600,6 @@ LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
.endif
.endif
-.if ${PHP_MODNAME} == "snmp"
-. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
-LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-. else
-LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-. endif
-.endif
-
.if ${PHP_MODNAME} == "sqlite"
. if defined(WITH_UTF8)
CONFIGURE_ARGS+=--enable-sqlite-utf8
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 05dbbe16da11..caab1b6c1e03 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -378,10 +378,9 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
-USE_OPENSSL= yes
-
-OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
+LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
+USE_OPENSSL= yes
.endif
.if ${PHP_MODNAME} == "soap"
@@ -601,14 +600,6 @@ LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
.endif
.endif
-.if ${PHP_MODNAME} == "snmp"
-. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
-LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-. else
-LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-. endif
-.endif
-
.if ${PHP_MODNAME} == "sqlite"
. if defined(WITH_UTF8)
CONFIGURE_ARGS+=--enable-sqlite-utf8
diff --git a/mail/cyrus-imapd22/Makefile b/mail/cyrus-imapd22/Makefile
index 96a9d70cd574..adb1bded1f94 100644
--- a/mail/cyrus-imapd22/Makefile
+++ b/mail/cyrus-imapd22/Makefile
@@ -48,8 +48,7 @@ OPTIONS= DRAC "Enable DRAC support" off \
MURDER "Enable IMAP Murder support" off \
NETSCAPEHACK "Enable X-NETSCAPE extensions" off \
NNTP "Enable NNTP support" off \
- SNMP_4 "Enable SNMP support using net-snmp v4" off \
- SNMP_5 "Enable SNMP support using net-snmp v5" off \
+ SNMP_5 "Enable SNMP support" off \
PASS8BITHACK "Add pass8bit option (not recommended)" off
.include <bsd.port.pre.mk>
@@ -105,15 +104,8 @@ CONFIGURE_ARGS+=--with-drac=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
-.if defined(WITH_SNMP_4) && defined(WITH_SNMP_5)
-BROKEN= Multiple net-snmp versions selected. Run 'make config' again!
-.endif
-.if defined(WITH_SNMP_4)
-LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-.elif defined(WITH_SNMP_5)
+.if defined(WITH_SNMP_5)
LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-.endif
-.if defined(WITH_SNMP_4) || defined(WITH_SNMP_5)
CONFIGURE_ARGS+=--with-snmp=${LOCALBASE}
.else
CONFIGURE_ARGS+=--with-snmp=no
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index 61f89a743589..c33cb3f1bb3b 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -50,8 +50,7 @@ OPTIONS= BDB "Use Berkeley DB" on \
PGSQL "Use PostgreSQL (experimental)" off \
REPLICATION "Enable replication" off \
SQLITE "Use SQLite (experimental)" off \
- SNMP_4 "Enable SNMP support using net-snmp v4" off \
- SNMP_5 "Enable SNMP support using net-snmp v5" off
+ SNMP_5 "Enable SNMP support" off
.include <bsd.port.pre.mk>
@@ -126,15 +125,8 @@ CONFIGURE_ARGS+=--with-drac=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
-.if defined(WITH_SNMP_4) && defined(WITH_SNMP_5)
-BROKEN= Multiple net-snmp versions selected. Run 'make config' again!
-.endif
-.if defined(WITH_SNMP_4)
-LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-.elif defined(WITH_SNMP_5)
+.if defined(WITH_SNMP_5)
LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-.endif
-.if defined(WITH_SNMP_4) || defined(WITH_SNMP_5)
CONFIGURE_ARGS+=--with-snmp=${LOCALBASE}
.else
CONFIGURE_ARGS+=--with-snmp=no
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index 61f89a743589..c33cb3f1bb3b 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -50,8 +50,7 @@ OPTIONS= BDB "Use Berkeley DB" on \
PGSQL "Use PostgreSQL (experimental)" off \
REPLICATION "Enable replication" off \
SQLITE "Use SQLite (experimental)" off \
- SNMP_4 "Enable SNMP support using net-snmp v4" off \
- SNMP_5 "Enable SNMP support using net-snmp v5" off
+ SNMP_5 "Enable SNMP support" off
.include <bsd.port.pre.mk>
@@ -126,15 +125,8 @@ CONFIGURE_ARGS+=--with-drac=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
-.if defined(WITH_SNMP_4) && defined(WITH_SNMP_5)
-BROKEN= Multiple net-snmp versions selected. Run 'make config' again!
-.endif
-.if defined(WITH_SNMP_4)
-LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-.elif defined(WITH_SNMP_5)
+.if defined(WITH_SNMP_5)
LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-.endif
-.if defined(WITH_SNMP_4) || defined(WITH_SNMP_5)
CONFIGURE_ARGS+=--with-snmp=${LOCALBASE}
.else
CONFIGURE_ARGS+=--with-snmp=no
diff --git a/net-mgmt/mbrowse/Makefile b/net-mgmt/mbrowse/Makefile
index 7f2c1b507ae0..cb1863b1ef09 100644
--- a/net-mgmt/mbrowse/Makefile
+++ b/net-mgmt/mbrowse/Makefile
@@ -14,23 +14,13 @@ MASTER_SITES= http://www.kill-9.org/mbrowse/
MAINTAINER= ports@FreeBSD.org
COMMENT= An SNMP MIB Browser for X
-.if defined(WITH_NET_SNMP4)
-LIB_DEPENDS= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-.else
LIB_DEPENDS= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-.endif
GNU_CONFIGURE= yes
PLIST_FILES= bin/mbrowse
USE_GNOME= gtk12 gnometarget
-CONFIGURE_ARGS+= --with-snmp-prefix=${PREFIX}
-
-.if defined(WITH_NET_SNMP4)
-CONFIGURE_ARGS+= --with-snmp-type=ucd
-.else
-CONFIGURE_ENV+= LDFLAGS="`net-snmp-config --libs`" \
- CPPFLAGS="`net-snmp-config --cflags`"
-CONFIGURE_ARGS+= --with-snmp-type=net
-.endif
+CONFIGURE_ARGS= --with-snmp-prefix=${PREFIX} --with-snmp-type=net
+CONFIGURE_ENV= LDFLAGS="`net-snmp-config --libs`" \
+ CPPFLAGS="`net-snmp-config --cflags`"
.include <bsd.port.mk>
diff --git a/net-mgmt/p5-SNMP-Util/Makefile b/net-mgmt/p5-SNMP-Util/Makefile
index a45237ca4097..d6c7f9409a67 100644
--- a/net-mgmt/p5-SNMP-Util/Makefile
+++ b/net-mgmt/p5-SNMP-Util/Makefile
@@ -15,15 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl modules to perform SNMP set,get,walk,next,walk_hash etc
-#
-# Define WITH_NETSNMP4 to use net-mgmt/net-snmp4 instead of net-mgmt/net-snmp.
-#
-.if !defined(WITH_NETSNMP4)
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SNMP.pm:${PORTSDIR}/net-mgmt/net-snmp
-EXTRA_PATCHES+= ${PATCHDIR}/extra-net-snmp-patch-Makefile.PL
-.else
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SNMP.pm:${PORTSDIR}/net-mgmt/p5-SNMP
-.endif
+
+EXTRA_PATCHES= ${PATCHDIR}/extra-net-snmp-patch-Makefile.PL
PERL_CONFIGURE= yes
diff --git a/net-mgmt/p5-SNMP-Util/pkg-descr b/net-mgmt/p5-SNMP-Util/pkg-descr
index 0e94a34f7fc0..2fe36208ce19 100644
--- a/net-mgmt/p5-SNMP-Util/pkg-descr
+++ b/net-mgmt/p5-SNMP-Util/pkg-descr
@@ -1,3 +1,3 @@
This Perl library is a set of utilities for configuring and monitoring
-SNMP based devices. This library requires the UCD port of SNMP and the
-SNMP.pm module written by Joe Marzot.
+SNMP based devices. This library requires the Net-SNMP implementation of SNMP
+and the SNMP.pm module written by Joe Marzot.
diff --git a/sysutils/jailadmin/Makefile b/sysutils/jailadmin/Makefile
index 07654a018f62..71024041a6cb 100644
--- a/sysutils/jailadmin/Makefile
+++ b/sysutils/jailadmin/Makefile
@@ -22,11 +22,7 @@ PORTDOCS= INSTALL README
.include <bsd.port.pre.mk>
.if defined(WITH_SNMP)
-.if exists(${LOCALBASE}/lib/libsnmp.so.4) || defined(WITH_SNMP4)
-LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-.else
LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
-.endif
PLIST_SUB+= SNMP=""
.else
INSTALL_TARGET= installbase