aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-07-12 17:06:38 +0800
committermaho <maho@FreeBSD.org>2007-07-12 17:06:38 +0800
commit05da0b8323dda837ce781bc0a6f86de1022b9391 (patch)
tree14d1e819c0618db7995cfc5936b463f06de2b2f5
parent0ff0469ef4be243e8ab75e79a75478d37bff0e37 (diff)
downloadfreebsd-ports-gnome-05da0b8323dda837ce781bc0a6f86de1022b9391.tar.gz
freebsd-ports-gnome-05da0b8323dda837ce781bc0a6f86de1022b9391.tar.zst
freebsd-ports-gnome-05da0b8323dda837ce781bc0a6f86de1022b9391.zip
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
-rw-r--r--math/lapack95/Makefile5
-rw-r--r--math/linpack/Makefile5
2 files changed, 2 insertions, 8 deletions
diff --git a/math/lapack95/Makefile b/math/lapack95/Makefile
index baed389a761c..af38e8fc799e 100644
--- a/math/lapack95/Makefile
+++ b/math/lapack95/Makefile
@@ -38,10 +38,7 @@ BLAS= -lblas
LAPACK= -llapack
.endif
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
WRKSRC= ${WRKDIR}/LAPACK95
FORTRAN_FIXED=
FORTRAN_FREE=# -free
diff --git a/math/linpack/Makefile b/math/linpack/Makefile
index b26b28c5cf9b..612d07cf922c 100644
--- a/math/linpack/Makefile
+++ b/math/linpack/Makefile
@@ -20,10 +20,7 @@ LIB_DEPENDS= blas.2:${PORTSDIR}/math/blas
.include <bsd.port.pre.mk>
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
USE_LDCONFIG= yes
DIST_SUBDIR= ${PORTNAME}