aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-02-17 08:20:41 +0800
committerkris <kris@FreeBSD.org>2004-02-17 08:20:41 +0800
commit0783500376930eb242169bed0d355c25535a05b6 (patch)
tree4eb660caba0304ef684400c54068f497ceef48bc
parent67ea34782aaeb83ec9249462b2b2173d4075f098 (diff)
downloadfreebsd-ports-gnome-0783500376930eb242169bed0d355c25535a05b6.tar.gz
freebsd-ports-gnome-0783500376930eb242169bed0d355c25535a05b6.tar.zst
freebsd-ports-gnome-0783500376930eb242169bed0d355c25535a05b6.zip
FORBIDDEN on 502102: does not respect PTHREAD_{CFLAGS,LIBS}
-rw-r--r--lang/qscheme/Makefile4
-rw-r--r--net-im/licq/Makefile5
-rw-r--r--net/licq/Makefile5
-rw-r--r--textproc/xerces-c2-devel/Makefile4
-rw-r--r--textproc/xerces-c2/Makefile4
-rw-r--r--textproc/xerces-c27/Makefile4
6 files changed, 26 insertions, 0 deletions
diff --git a/lang/qscheme/Makefile b/lang/qscheme/Makefile
index d83c1fc86f7f..d7ceedf8aad9 100644
--- a/lang/qscheme/Makefile
+++ b/lang/qscheme/Makefile
@@ -46,4 +46,8 @@ CONFIGURE_ARGS+= --with-gmp-lib=${LOCALBASE}/lib \
--with-gmp-inc=${LOCALBASE}/include
.endif
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
+.endif
+
.include <bsd.port.post.mk>
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 879ace422690..2eaf32525253 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -53,5 +53,10 @@ post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
+.endif
+
.include "${LICQ_PORT}/Makefile.inc"
.include <bsd.port.post.mk>
diff --git a/net/licq/Makefile b/net/licq/Makefile
index 879ace422690..2eaf32525253 100644
--- a/net/licq/Makefile
+++ b/net/licq/Makefile
@@ -53,5 +53,10 @@ post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
+.endif
+
.include "${LICQ_PORT}/Makefile.inc"
.include <bsd.port.post.mk>
diff --git a/textproc/xerces-c2-devel/Makefile b/textproc/xerces-c2-devel/Makefile
index e7695973a859..dac732421f48 100644
--- a/textproc/xerces-c2-devel/Makefile
+++ b/textproc/xerces-c2-devel/Makefile
@@ -63,6 +63,10 @@ CONFIGURE_ARGS+= -t ${TRANSCODER}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
+.endif
+
.if defined(DEBUG)
PKGNAMESUFFIX+= -debug
CONFIGURE_ARGS+= -d
diff --git a/textproc/xerces-c2/Makefile b/textproc/xerces-c2/Makefile
index e7695973a859..dac732421f48 100644
--- a/textproc/xerces-c2/Makefile
+++ b/textproc/xerces-c2/Makefile
@@ -63,6 +63,10 @@ CONFIGURE_ARGS+= -t ${TRANSCODER}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
+.endif
+
.if defined(DEBUG)
PKGNAMESUFFIX+= -debug
CONFIGURE_ARGS+= -d
diff --git a/textproc/xerces-c27/Makefile b/textproc/xerces-c27/Makefile
index e7695973a859..dac732421f48 100644
--- a/textproc/xerces-c27/Makefile
+++ b/textproc/xerces-c27/Makefile
@@ -63,6 +63,10 @@ CONFIGURE_ARGS+= -t ${TRANSCODER}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
+.endif
+
.if defined(DEBUG)
PKGNAMESUFFIX+= -debug
CONFIGURE_ARGS+= -d