aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1998-02-23 07:06:17 +0800
committerandreas <andreas@FreeBSD.org>1998-02-23 07:06:17 +0800
commit09b7d877cef951ca82e47d6d7e76627c6f272c1a (patch)
tree43d391281fdf2b61126c14aab15ca206a4a607b9
parenta32c291716e2b80a464e54c1faf10e76a6981512 (diff)
downloadfreebsd-ports-gnome-09b7d877cef951ca82e47d6d7e76627c6f272c1a.tar.gz
freebsd-ports-gnome-09b7d877cef951ca82e47d6d7e76627c6f272c1a.tar.zst
freebsd-ports-gnome-09b7d877cef951ca82e47d6d7e76627c6f272c1a.zip
If BATCH is defined, then build apache-php with mysql support.
Reasons: - mysql is free software and very popular. - msql is only free for private use - msql isn't as fast and reliable (from hearsay)
-rw-r--r--www/mod_php3/Makefile6
-rw-r--r--www/mod_php4/Makefile6
-rw-r--r--www/mod_php5/Makefile6
3 files changed, 18 insertions, 0 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index 25f96fef3ec5..f174f6dade6b 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -21,7 +21,13 @@ NO_PACKAGE= "Too many questions"
#
# Currently we support two db's: msql and mysql
+# When running in batch mode default to mysql support, because it's
+# a free and very popular database !
#
+.if defined(BATCH)
+PHP_DBTYPE=mysql
+.endif
+
.if !defined(PHP_DBTYPE)
pre-fetch:
@ ${ECHO}
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index 25f96fef3ec5..f174f6dade6b 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -21,7 +21,13 @@ NO_PACKAGE= "Too many questions"
#
# Currently we support two db's: msql and mysql
+# When running in batch mode default to mysql support, because it's
+# a free and very popular database !
#
+.if defined(BATCH)
+PHP_DBTYPE=mysql
+.endif
+
.if !defined(PHP_DBTYPE)
pre-fetch:
@ ${ECHO}
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 25f96fef3ec5..f174f6dade6b 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -21,7 +21,13 @@ NO_PACKAGE= "Too many questions"
#
# Currently we support two db's: msql and mysql
+# When running in batch mode default to mysql support, because it's
+# a free and very popular database !
#
+.if defined(BATCH)
+PHP_DBTYPE=mysql
+.endif
+
.if !defined(PHP_DBTYPE)
pre-fetch:
@ ${ECHO}