aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2014-09-05 19:20:42 +0800
committererwin <erwin@FreeBSD.org>2014-09-05 19:20:42 +0800
commit0a1690016e3f6c689ffc3f1330002d91192d4d2a (patch)
treecebd6f4d8eca7c7f6ff422b5d794fd6e527d835a
parent0170a37c6b90c452418b05ce22bfe55751908c44 (diff)
downloadfreebsd-ports-gnome-0a1690016e3f6c689ffc3f1330002d91192d4d2a.tar.gz
freebsd-ports-gnome-0a1690016e3f6c689ffc3f1330002d91192d4d2a.tar.zst
freebsd-ports-gnome-0a1690016e3f6c689ffc3f1330002d91192d4d2a.zip
- Update to 4.1.0
- Use nsd instead of bind user This release has new features and bugfixes. In nsd.conf you can configure database: "" this makes NSD not use the large mmapped nsd.db file, but instead read and write the zonefiles in text format, which saves about 50% of the memory usage. Also zonefile reading and writing has been optimised to be faster, as well as processing time for zone transfers. NSD writes the (changed) zonefiles every hour. The new nsd-checkzone tool reports if a zonefile parses so you can check it before reading it into the daemon. A bug is fixed where NSD 4 causes rising load average and memory consumption on Linux systems, which is caused by a bug in Linux that slowly deteriorates system performance by repeated recursive forks. Full release notes: http://open.nlnetlabs.nl/pipermail/nsd-users/2014-September/002007.html PR: 193332 Submitted by: Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer) Sponsored by: DK Hostmaster A/S
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--dns/nsd/Makefile26
-rw-r--r--dns/nsd/distinfo4
-rw-r--r--dns/nsd/pkg-plist2
5 files changed, 18 insertions, 16 deletions
diff --git a/GIDs b/GIDs
index 6ddbfad8893d..d3f695e5d0a4 100644
--- a/GIDs
+++ b/GIDs
@@ -124,6 +124,7 @@ git:*:211:
hg:*:212:
drizzle:*:213:
opendnssec:*:215:
+nsd:*:216:
bs:*:220:
rtpproxy:*:222:
postgrey:*:225:
diff --git a/UIDs b/UIDs
index fa807bde4cb8..c47dc1ae86bc 100644
--- a/UIDs
+++ b/UIDs
@@ -128,6 +128,7 @@ git:*:211:211::0:0:gitosis user:/usr/local/git:/bin/sh
hg:*:212:212::0:0:mercurial-server user:/usr/local/hg:/bin/sh
drizzle:*:213:213::0:0:Drizzle daemon:/var/db/drizzle:/usr/sbin/nologin
opendnssec:*:215:215::0:0:Opendnssec Pseudo User:/nonexistent:/usr/sbin/nologin
+nsd:*:216:216::0:0:Opendnssec Pseudo User:/nonexistent:/usr/sbin/nologin
bs:*:220:220::0:0:Big Sister:/usr/local/bigsister:/bin/sh
rtpproxy:*:222:222::0:0:& user:/nonexistent:/sbin/nologin
postgrey:*:225:225::0:0:Postgrey Owner:/nonexistent:/usr/sbin/nologin
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index d60c62566795..83ce2d1db4b5 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nsd
-PORTVERSION= 4.0.3
-PORTREVISION= 1
+PORTVERSION= 4.1.0
CATEGORIES= dns ipv6
MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/ \
ftp://ftp.rhnet.is/pub/nsd/
@@ -17,8 +16,8 @@ CONFLICTS= nsd-[0-3]* nsd3-[0-9]*
USE_RC_SUBR= nsd
-NSDUSER?= bind
-NSDGROUP?= bind
+NSDUSER?= nsd
+NSDGROUP?= nsd
NSDLSDIR= /var
NSDDBDIR= /var/db/nsd
NSDRUNDIR= /var/run/nsd
@@ -37,6 +36,9 @@ PLIST_SUB= NSDUSER=${NSDUSER} \
NSDDBDIR=${NSDDBDIR} \
NSDRUNDIR=${NSDRUNDIR}
+USERS= ${NSDUSER}
+GROUPS= ${NSDGROUP}
+
USE_OPENSSL= yes
PORTDOCS= CREDITS ChangeLog LICENSE NSD-DATABASE NSD-DIFFFILE \
@@ -45,23 +47,18 @@ PORTDOCS= CREDITS ChangeLog LICENSE NSD-DATABASE NSD-DIFFFILE \
differences.tex
OPTIONS_DEFINE= ROOT_SERVER LARGEFILE IPV6 BIND8_STATS CHECKING \
- MINRESPSIZE NSEC3 NSEC3PREHASH MMAP MAXIPS DOCS RRL EUI_RRTYPES \
- RECVMMSG
-OPTIONS_DEFAULT= LARGEFILE IPV6 NSEC3 NSEC3PREHASH MINRESPSIZE RRL \
- EUI_RRTYPES
+ MINRESPSIZE NSEC3 MMAP MAXIPS DOCS RRL
+OPTIONS_DEFAULT= LARGEFILE IPV6 NSEC3 MINRESPSIZE RRL
ROOT_SERVER_DESC= Configure as a root server
LARGEFILE_DESC= Largefile support
BIND8_STATS_DESC= BIND8-like NSTATS & XSTATS
CHECKING_DESC= Internal run-time checks
NSEC3_DESC= NSEC3 support
-NSEC3PREHASH_DESC= Full NSEC3 pre-hashing
MINRESPSIZE_DESC= Minimial response sizing
MMAP_DESC= Use mmap instead of malloc (experimental)
MAXIPS_DESC= Raise max-ips from 8 to ${NSDMAX_IPS}
RRL_DESC= Response Rate Limiting
-EUI_RRTYPES_DESC= EUI48 and EUI64 RRtypes support
-RECVMMSG_DESC= Enable use of recvmmsg and sendmmsg
LIB_DEPENDS+= libevent.so:${PORTSDIR}/devel/libevent2
@@ -72,17 +69,18 @@ BIND8_STATS_CONFIGURE_ENABLE= bind8-stats
CHECKING_CONFIGURE_ENABLE= checking
NSEC3_CONFIGURE_ENABLE= nsec3
MINRESPSIZE_CONFIGURE_ENABLE= minimal-responses
-NSEC3PREHASH_CONFIGURE_ENABLE= full-prehash
MMAP_CONFIGURE_ENABLE= mmap
MAXIPS_CONFIGURE_ON= --with-max-ips=${NSDMAX_IPS}
RRL_CONFIGURE_ENABLE= ratelimit
-EUI_RRTYPES_CONFIGURE_ENABLE= draft-rrtypes
-RECVMMSG_CONFIGURE_ENABLE= enable-recvmmsg
post-install:
${INSTALL_DATA} ${WRKSRC}/nsd.conf.sample \
${STAGEDIR}${PREFIX}/etc/nsd/nsd.conf.sample
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/nsd \
+ ${STAGEDIR}${PREFIX}/sbin/nsd-checkconf \
+ ${STAGEDIR}${PREFIX}/sbin/nsd-checkzone \
+ ${STAGEDIR}${PREFIX}/sbin/nsd-control
.include <bsd.port.mk>
diff --git a/dns/nsd/distinfo b/dns/nsd/distinfo
index df5d4852941a..5ed3d96a19d7 100644
--- a/dns/nsd/distinfo
+++ b/dns/nsd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nsd-4.0.3.tar.gz) = 4bf05f2234e1b41899198aa1070f409201fc3c4980feef6567cd92c7074c4a8b
-SIZE (nsd-4.0.3.tar.gz) = 1043993
+SHA256 (nsd-4.1.0.tar.gz) = ec3f6902f6f26a6b9248dcd7e9f42472fa52755740b4ba6b9d3bd08910b39b62
+SIZE (nsd-4.1.0.tar.gz) = 1056649
diff --git a/dns/nsd/pkg-plist b/dns/nsd/pkg-plist
index 9cc66ee667da..8999349750de 100644
--- a/dns/nsd/pkg-plist
+++ b/dns/nsd/pkg-plist
@@ -1,10 +1,12 @@
%%ETCDIR%%/nsd.conf.sample
man/man5/nsd.conf.5.gz
man/man8/nsd-checkconf.8.gz
+man/man8/nsd-checkzone.8.gz
man/man8/nsd-control.8.gz
man/man8/nsd.8.gz
sbin/nsd
sbin/nsd-checkconf
+sbin/nsd-checkzone
sbin/nsd-control
sbin/nsd-control-setup
@exec install -o %%NSDUSER%% -g %%NSDGROUP%% -m 0755 -d %%NSDRUNDIR%%