aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-09-07 15:22:13 +0800
committervanilla <vanilla@FreeBSD.org>2015-09-07 15:22:13 +0800
commit0a3fea52c0ac9617c99561a37e2a24dbd2748eca (patch)
tree304ec8969738f1509a1d7b8e61317505ead81836
parent3daaeea88fc7d205e73c2528eaac758a34ddc9f1 (diff)
downloadfreebsd-ports-gnome-0a3fea52c0ac9617c99561a37e2a24dbd2748eca.tar.gz
freebsd-ports-gnome-0a3fea52c0ac9617c99561a37e2a24dbd2748eca.tar.zst
freebsd-ports-gnome-0a3fea52c0ac9617c99561a37e2a24dbd2748eca.zip
Add php-uprofiler 0.11.0.20150219, lightweight profiler for PHP.
PR: 202829 Submitted by: Gasol Wu <gasol.wu@gmail.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/php-uprofiler/Makefile24
-rw-r--r--devel/php-uprofiler/distinfo2
-rw-r--r--devel/php-uprofiler/pkg-descr5
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3bceb3718bc7..8704d2413169 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3688,6 +3688,7 @@
SUBDIR += php-libawl
SUBDIR += php-memoize
SUBDIR += php-scalar_objects
+ SUBDIR += php-uprofiler
SUBDIR += php-xdebug
SUBDIR += php5-blitz
SUBDIR += php5-blitz-devel
diff --git a/devel/php-uprofiler/Makefile b/devel/php-uprofiler/Makefile
new file mode 100644
index 000000000000..2fa86a0c96ec
--- /dev/null
+++ b/devel/php-uprofiler/Makefile
@@ -0,0 +1,24 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= uprofiler
+PORTVERSION= 0.11.0.20150219
+CATEGORIES= devel
+PKGNAMEPREFIX= php-
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= Lightweight profiler for PHP
+
+LICENSE= APACHE20
+
+USE_GITHUB= yes
+GH_ACCOUNT= FriendsOfPHP
+GH_TAGNAME= 483c1e5
+
+WRKSRC= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME_EXTRACT}/extension
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+USES= tar:tgz
+
+.include <bsd.port.mk>
diff --git a/devel/php-uprofiler/distinfo b/devel/php-uprofiler/distinfo
new file mode 100644
index 000000000000..9f2ccfc2e697
--- /dev/null
+++ b/devel/php-uprofiler/distinfo
@@ -0,0 +1,2 @@
+SHA256 (FriendsOfPHP-uprofiler-0.11.0.20150219-483c1e5_GH0.tgz) = 3694aae89c1244dda11edb38d8bb96d11c798ecef5c3e8641504a9052837e431
+SIZE (FriendsOfPHP-uprofiler-0.11.0.20150219-483c1e5_GH0.tgz) = 103031
diff --git a/devel/php-uprofiler/pkg-descr b/devel/php-uprofiler/pkg-descr
new file mode 100644
index 000000000000..f17175c443d6
--- /dev/null
+++ b/devel/php-uprofiler/pkg-descr
@@ -0,0 +1,5 @@
+uprofiler is a hierarchical profiler for PHP. It reports function-level call
+counts and inclusive and exclusive metrics such as wall (elapsed) time, CPU time
+and memory usage. A function's profile can be broken down by callers or callees.
+
+WWW: https://github.com/FriendsOfPHP/uprofiler