aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2015-08-14 05:23:21 +0800
committerrm <rm@FreeBSD.org>2015-08-14 05:23:21 +0800
commit0a48d8af7ef7bbbe28de5db53619c65bca7199b5 (patch)
treeef5d479a62ec4fb9a9f7509c08e8696c187b126b
parent05621091e226ec75d26aa7104df5f85a3a5f253d (diff)
downloadfreebsd-ports-gnome-0a48d8af7ef7bbbe28de5db53619c65bca7199b5.tar.gz
freebsd-ports-gnome-0a48d8af7ef7bbbe28de5db53619c65bca7199b5.tar.zst
freebsd-ports-gnome-0a48d8af7ef7bbbe28de5db53619c65bca7199b5.zip
Weblib provides tools to solve typical tasks in web scraping:
* processing HTML * handling text encodings * controling repeating and parallel tasks * parsing RSS/ATOM feeds * preparing data for HTTP requests * working with DOM tree * working with text and numeral data * list of common user agents * cross-platform file locking * operations with files and directories WWW: https://pypi.python.org/pypi/weblib
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-weblib/Makefile25
-rw-r--r--devel/py-weblib/distinfo2
-rw-r--r--devel/py-weblib/pkg-descr14
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8e66bd317eb1..b83f5e875b38 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4272,6 +4272,7 @@
SUBDIR += py-virtualenvwrapper
SUBDIR += py-watchdog
SUBDIR += py-wcwidth
+ SUBDIR += py-weblib
SUBDIR += py-wheel
SUBDIR += py-wsgi_xmlrpc
SUBDIR += py-wsgitools
diff --git a/devel/py-weblib/Makefile b/devel/py-weblib/Makefile
new file mode 100644
index 000000000000..a5f51735457d
--- /dev/null
+++ b/devel/py-weblib/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= weblib
+PORTVERSION= 0.1.14
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Set of tools for web scraping projects
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytils>0:${PORTSDIR}/russian/py-pytils \
+ ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-extract:
+ ${RM} -rf ${WRKSRC}/test
+
+.include <bsd.port.mk>
diff --git a/devel/py-weblib/distinfo b/devel/py-weblib/distinfo
new file mode 100644
index 000000000000..4840ff416ead
--- /dev/null
+++ b/devel/py-weblib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (weblib-0.1.14.tar.gz) = f9602ce66a6c5e010509d515a57b55d8c9d1eda8c4cbf5544a9ae11382618d8a
+SIZE (weblib-0.1.14.tar.gz) = 36292
diff --git a/devel/py-weblib/pkg-descr b/devel/py-weblib/pkg-descr
new file mode 100644
index 000000000000..74d209dc1eb5
--- /dev/null
+++ b/devel/py-weblib/pkg-descr
@@ -0,0 +1,14 @@
+Weblib provides tools to solve typical tasks in web scraping:
+
+ * processing HTML
+ * handling text encodings
+ * controling repeating and parallel tasks
+ * parsing RSS/ATOM feeds
+ * preparing data for HTTP requests
+ * working with DOM tree
+ * working with text and numeral data
+ * list of common user agents
+ * cross-platform file locking
+ * operations with files and directories
+
+WWW: https://pypi.python.org/pypi/weblib