aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-12-28 01:41:21 +0800
committertobez <tobez@FreeBSD.org>2005-12-28 01:41:21 +0800
commit0a6ce2d62d0494f0b6a31fa39c338be567d02458 (patch)
treec9328847388958c6a04ba9e05dfc116d2af75e8b
parent7da06609ee5aec403bc428d6527626b6027f36e0 (diff)
downloadfreebsd-ports-gnome-0a6ce2d62d0494f0b6a31fa39c338be567d02458.tar.gz
freebsd-ports-gnome-0a6ce2d62d0494f0b6a31fa39c338be567d02458.tar.zst
freebsd-ports-gnome-0a6ce2d62d0494f0b6a31fa39c338be567d02458.zip
Add devel/p5-Test-Strict 0.07, a Perl module to test and report on the
coverage of the strict/warnings pragmas. PR: 90981 Submitted by: Zach Thompson <hideo@lastamericanempire.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Strict/Makefile31
-rw-r--r--devel/p5-Test-Strict/distinfo3
-rw-r--r--devel/p5-Test-Strict/pkg-descr3
-rw-r--r--devel/p5-Test-Strict/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e88eeb513f62..fb6ff022eaa8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1179,6 +1179,7 @@
SUBDIR += p5-Test-Pod-Coverage
SUBDIR += p5-Test-Reporter
SUBDIR += p5-Test-Simple
+ SUBDIR += p5-Test-Strict
SUBDIR += p5-Test-SubCalls
SUBDIR += p5-Test-Tester
SUBDIR += p5-Test-Unit
diff --git a/devel/p5-Test-Strict/Makefile b/devel/p5-Test-Strict/Makefile
new file mode 100644
index 000000000000..f3fc8fe0a652
--- /dev/null
+++ b/devel/p5-Test-Strict/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Test-Strict
+# Date Created: 27 Dec 2005
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Strict
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Test and report on use strict/warnings coverage
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Devel/Cover.pm:${PORTSDIR}/devel/p5-Devel-Cover
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Strict.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.1 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Strict/distinfo b/devel/p5-Test-Strict/distinfo
new file mode 100644
index 000000000000..7940e90795d1
--- /dev/null
+++ b/devel/p5-Test-Strict/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Strict-0.07.tar.gz) = 22022dd7f79f6a23679be06104a704d8
+SHA256 (Test-Strict-0.07.tar.gz) = 93623f4797ad33075a41a0e81869d607f9e6cd7b88992ddaffd6a3ad0aaf9caf
+SIZE (Test-Strict-0.07.tar.gz) = 6556
diff --git a/devel/p5-Test-Strict/pkg-descr b/devel/p5-Test-Strict/pkg-descr
new file mode 100644
index 000000000000..4218f51385a1
--- /dev/null
+++ b/devel/p5-Test-Strict/pkg-descr
@@ -0,0 +1,3 @@
+Test and report on the coverage of the strict/warnings pragmas.
+
+WWW: http://search.cpan.org/dist/Test-Strict/
diff --git a/devel/p5-Test-Strict/pkg-plist b/devel/p5-Test-Strict/pkg-plist
new file mode 100644
index 000000000000..dcdcd4265d17
--- /dev/null
+++ b/devel/p5-Test-Strict/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/Strict.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Strict/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Strict
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true