aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-09-16 18:00:59 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-09-16 18:00:59 +0800
commit0abd279573c02a73a23e70f26cfb58a2cc7355b6 (patch)
treefb2bcc71a3236ec1b6150af749245bd1426b1c3a
parent96f94beb1eff9097e4c23f4d5274a856a781b47c (diff)
downloadfreebsd-ports-gnome-0abd279573c02a73a23e70f26cfb58a2cc7355b6.tar.gz
freebsd-ports-gnome-0abd279573c02a73a23e70f26cfb58a2cc7355b6.tar.zst
freebsd-ports-gnome-0abd279573c02a73a23e70f26cfb58a2cc7355b6.zip
Add untahris, play several classic fun, simple arcade games in
multiplayer mode. PR: 103012 Submitted by: Dmitry Marakasov <amdmi3 at mail.ru>
-rw-r--r--games/Makefile1
-rw-r--r--games/untahris/Makefile48
-rw-r--r--games/untahris/distinfo3
-rw-r--r--games/untahris/files/patch-intface.cpp11
-rw-r--r--games/untahris/files/patch-untahris.cpp19
-rw-r--r--games/untahris/pkg-descr14
6 files changed, 96 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 34052b22e62e..61a5d9d99dea 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -714,6 +714,7 @@
SUBDIR += tyrquake
SUBDIR += uhexen
SUBDIR += umark
+ SUBDIR += untahris
SUBDIR += uox3
SUBDIR += uqm
SUBDIR += urban
diff --git a/games/untahris/Makefile b/games/untahris/Makefile
new file mode 100644
index 000000000000..e4ec3df7246a
--- /dev/null
+++ b/games/untahris/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: untahris
+# Date created: 08 Sep 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= untahris
+DISTVERSION= 1.0beta
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Play several classic fun, simple arcade games in multiplayer mode
+
+USE_SDL= sdl net ttf
+USE_GCC= 3.4+
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/untahris %%DATADIR%%/VeraBd.ttf %%DATADIR%%/graph16.unt
+PLIST_DIRS= %%DATADIR%%
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|verabd.ttf|${DATADIR}/VeraBd.ttf|; \
+ s|graph%d|${DATADIR}/graph%d|' ${WRKSRC}/intface.cpp
+ @${REINPLACE_CMD} -e 's|SDL/||' ${WRKSRC}/net.cpp ${WRKSRC}/untahris.h
+
+do-build:
+ cd ${WRKSRC} && ${CXX} ${CXXFLAGS} `${SDL_CONFIG} --libs --cflags` \
+ -lSDL_net -lSDL_ttf untahris.cpp -o untahris
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/untahris ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/VeraBd.ttf ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/graph16.unt ${DATADIR}
+
+.include <bsd.port.post.mk>
diff --git a/games/untahris/distinfo b/games/untahris/distinfo
new file mode 100644
index 000000000000..0f1ad1087988
--- /dev/null
+++ b/games/untahris/distinfo
@@ -0,0 +1,3 @@
+MD5 (untahris-1.0beta-src.tgz) = 567f6b203dc8b7efb26ec7f9eae08fe0
+SHA256 (untahris-1.0beta-src.tgz) = 9c1067c9edb64fce5e23c11de34fe20ed6591e3048388fec89e921f9e350d0a5
+SIZE (untahris-1.0beta-src.tgz) = 70050
diff --git a/games/untahris/files/patch-intface.cpp b/games/untahris/files/patch-intface.cpp
new file mode 100644
index 000000000000..e6dab8a29897
--- /dev/null
+++ b/games/untahris/files/patch-intface.cpp
@@ -0,0 +1,11 @@
+--- intface.cpp.orig Mon Sep 4 19:16:15 2006
++++ intface.cpp Fri Sep 8 06:57:45 2006
+@@ -517,7 +517,7 @@
+ thruster.pixel[y][x] = 'P';
+ }
+
+- char buf[64];
++ char buf[1024];
+ sprintf(buf, "graph%d.unt", d.Res);
+ FILE *f = fopen(buf, "rt");
+ if(f) {
diff --git a/games/untahris/files/patch-untahris.cpp b/games/untahris/files/patch-untahris.cpp
new file mode 100644
index 000000000000..01b2da071e96
--- /dev/null
+++ b/games/untahris/files/patch-untahris.cpp
@@ -0,0 +1,19 @@
+--- untahris.cpp.orig Tue Sep 5 16:50:04 2006
++++ untahris.cpp Fri Sep 8 06:54:50 2006
+@@ -6,7 +6,7 @@
+
+ #include "untahris.h"
+
+-char *configfile = "config.unt";
++char *configfile = ".untahris.config";
+
+ #include "tools.cpp"
+ #include "intface.cpp"
+@@ -117,6 +117,7 @@
+ }
+
+ int main(int argc, char **argv) {
++ chdir(getenv("HOME"));
+ g.sizeX = 0;
+ g.sizeY = 0;
+ d.ofsX = 0;
diff --git a/games/untahris/pkg-descr b/games/untahris/pkg-descr
new file mode 100644
index 000000000000..caad4cc29775
--- /dev/null
+++ b/games/untahris/pkg-descr
@@ -0,0 +1,14 @@
+In the Untahris Common Playground, you can play several classic fun, simple
+arcade games. But playing alone is not fun, and you can play them in multiplayer
+mode (on one computer, local network, or maybe Internet).
+
+Now, Untahris has an original experimental feature, which makes it more than
+just a bundle of these games! In multiplayer mode each player can play a
+different game --- however, they play all on the same board. This may lead to
+funny interactions, battles or alliances between them.
+
+The games in Untahris have been modified to make them better interact with each
+other. Thus, in each game you are allowed to shoot and collect bonuses, even if
+it was not a part of the original game.
+
+WWW: http://untahris.sourceforge.net