aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2008-08-11 20:27:52 +0800
committerkuriyama <kuriyama@FreeBSD.org>2008-08-11 20:27:52 +0800
commit0b28a964f0c4e448a7bd61277db98e4f6a0033a1 (patch)
tree3b695a30d0d9f3abb7935f3c8751594a4eff4a98
parent2490e03b43a49b1c3307bd1c118a744224cf2755 (diff)
downloadfreebsd-ports-gnome-0b28a964f0c4e448a7bd61277db98e4f6a0033a1.tar.gz
freebsd-ports-gnome-0b28a964f0c4e448a7bd61277db98e4f6a0033a1.tar.zst
freebsd-ports-gnome-0b28a964f0c4e448a7bd61277db98e4f6a0033a1.zip
Fix plist with NOPORTDOCS.
Reported by: QA Tindy (itetcu)
-rw-r--r--security/gnupg1/files/patch-doc:Makefile.in41
-rw-r--r--security/gnupg1/files/patch-g10:Makefile.in41
2 files changed, 70 insertions, 12 deletions
diff --git a/security/gnupg1/files/patch-doc:Makefile.in b/security/gnupg1/files/patch-doc:Makefile.in
index 31695a542984..c2091b30024c 100644
--- a/security/gnupg1/files/patch-doc:Makefile.in
+++ b/security/gnupg1/files/patch-doc:Makefile.in
@@ -1,11 +1,40 @@
---- doc/Makefile.in.orig Tue Aug 1 19:41:48 2006
-+++ doc/Makefile.in Mon Dec 4 09:34:23 2006
-@@ -35,7 +35,7 @@
- srcdir = @srcdir@
- top_srcdir = @top_srcdir@
+--- doc/Makefile.in.orig 2008-03-27 02:30:46.000000000 +0900
++++ doc/Makefile.in 2008-08-11 11:30:00.000000000 +0900
+@@ -32,7 +32,7 @@
+ # along with this program; if not, see <http://www.gnu.org/licenses/>.
+
VPATH = @srcdir@
-pkgdatadir = $(datadir)/@PACKAGE@
+pkgdatadir = $(datadir)/doc/gnupg1
pkglibdir = $(libdir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ..
+ am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
+@@ -296,7 +296,11 @@
+
+ # Need this to avoid building of dvis with automake 1.4
+ DVIS =
++ifdef NOPORTDOCS
++pkgdata_DATA =
++else
+ pkgdata_DATA = FAQ faq.html
++endif
+ BUILT_SOURCES = FAQ faq.html
+ # we can't add gpg.texi gpgv.texi here because automake does not like them to
+ # be built files.
+@@ -589,6 +593,8 @@
+ rm -f "$(DESTDIR)$(man7dir)/$$inst"; \
+ done
+ install-pkgdataDATA: $(pkgdata_DATA)
++ifdef NOPORTDOCS
++else
+ @$(NORMAL_INSTALL)
+ test -z "$(pkgdatadir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
+ @list='$(pkgdata_DATA)'; for p in $$list; do \
+@@ -597,6 +603,7 @@
+ echo " $(pkgdataDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgdatadir)/$$f'"; \
+ $(pkgdataDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgdatadir)/$$f"; \
+ done
++endif
+
+ uninstall-pkgdataDATA:
+ @$(NORMAL_UNINSTALL)
diff --git a/security/gnupg1/files/patch-g10:Makefile.in b/security/gnupg1/files/patch-g10:Makefile.in
index a5f512103295..56df6cf92d06 100644
--- a/security/gnupg1/files/patch-g10:Makefile.in
+++ b/security/gnupg1/files/patch-g10:Makefile.in
@@ -1,11 +1,40 @@
---- g10/Makefile.in.orig Mon Dec 4 09:50:35 2006
-+++ g10/Makefile.in Mon Dec 4 09:50:46 2006
-@@ -36,7 +36,7 @@
- srcdir = @srcdir@
- top_srcdir = @top_srcdir@
+--- g10/Makefile.in.orig 2008-03-27 02:30:47.000000000 +0900
++++ g10/Makefile.in 2008-08-11 11:39:26.000000000 +0900
+@@ -34,7 +34,7 @@
+
+
VPATH = @srcdir@
-pkgdatadir = $(datadir)/@PACKAGE@
+pkgdatadir = $(datadir)/doc/gnupg1
pkglibdir = $(libdir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ..
+ am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
+@@ -346,7 +346,11 @@
+ @LIBUSB_CPPFLAGS@ $(am__append_1)
+ needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
+ other_libs = $(LIBICONV) $(DNSLIBS) $(LIBINTL) $(CAPLIBS)
++ifdef NOPORTDOCS
++dist_pkgdata_DATA =
++else
+ dist_pkgdata_DATA = options.skel
++endif
+ @ENABLE_BZIP2_SUPPORT_FALSE@bzip2_source =
+ @ENABLE_BZIP2_SUPPORT_TRUE@bzip2_source = compress-bz2.c
+ common_source = \
+@@ -590,6 +594,8 @@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+ @am__fastdepCC_FALSE@ $(COMPILE) -c `$(CYGPATH_W) '$<'`
+ install-dist_pkgdataDATA: $(dist_pkgdata_DATA)
++ifdef NOPORTDOCS
++else
+ @$(NORMAL_INSTALL)
+ test -z "$(pkgdatadir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
+ @list='$(dist_pkgdata_DATA)'; for p in $$list; do \
+@@ -598,6 +604,7 @@
+ echo " $(dist_pkgdataDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgdatadir)/$$f'"; \
+ $(dist_pkgdataDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgdatadir)/$$f"; \
+ done
++endif
+
+ uninstall-dist_pkgdataDATA:
+ @$(NORMAL_UNINSTALL)