aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-12-20 14:18:56 +0800
committerlinimon <linimon@FreeBSD.org>2018-12-20 14:18:56 +0800
commit0bb494790668138bb3fc7d7d659e5dd1e8111418 (patch)
tree8a4f7ade160d606b9cffa0e02eb29ec4aae892fa
parent6b868a284cd2356f360db89a27cb082e9dca2e17 (diff)
downloadfreebsd-ports-gnome-0bb494790668138bb3fc7d7d659e5dd1e8111418.tar.gz
freebsd-ports-gnome-0bb494790668138bb3fc7d7d659e5dd1e8111418.tar.zst
freebsd-ports-gnome-0bb494790668138bb3fc7d7d659e5dd1e8111418.zip
USES=compiler:c11 is necessary to build on GCC-based architectures.
While here, add ldflags to simplify Makefile. PR: 233928 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
-rw-r--r--devel/ptlib/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/ptlib/Makefile b/devel/ptlib/Makefile
index a44aa3b92cd1..f9a086e4b98b 100644
--- a/devel/ptlib/Makefile
+++ b/devel/ptlib/Makefile
@@ -16,11 +16,12 @@ LIB_DEPENDS= libexpat.so:textproc/expat2
CONFLICTS= pwlib-1.*
-USES= autoreconf:build bison gmake pathfix pkgconfig ssl tar:xz
+USES= autoreconf:build bison compiler:c11 gmake localbase:ldflags \
+ pathfix pkgconfig ssl tar:xz
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CPPFLAGS+= -I${OPENSSLINC} -I${LOCALBASE}/include
-LDFLAGS+= -L${OPENSSLLIB} -L${LOCALBASE}/lib
+CPPFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
CONFIGURE_ARGS+=--enable-audio \
--enable-ipv6 \