aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2013-08-20 14:49:44 +0800
committerwen <wen@FreeBSD.org>2013-08-20 14:49:44 +0800
commit0c4b85531e4a753815d3cb555a5d3f05203f0f1e (patch)
tree1200c8072a6e9b1a63b27c83e478931a01b211df
parent580c5fab17b402c94877a3287396df526dbce588 (diff)
downloadfreebsd-ports-gnome-0c4b85531e4a753815d3cb555a5d3f05203f0f1e.tar.gz
freebsd-ports-gnome-0c4b85531e4a753815d3cb555a5d3f05203f0f1e.tar.zst
freebsd-ports-gnome-0c4b85531e4a753815d3cb555a5d3f05203f0f1e.zip
- Update to 3.0.0
-rw-r--r--devel/py-tables/Makefile13
-rw-r--r--devel/py-tables/distinfo8
-rw-r--r--devel/py-tables/files/patch-setup.py18
3 files changed, 19 insertions, 20 deletions
diff --git a/devel/py-tables/Makefile b/devel/py-tables/Makefile
index 2b326d9ba420..066df2a81b45 100644
--- a/devel/py-tables/Makefile
+++ b/devel/py-tables/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tables
-PORTVERSION= 2.4.0
+PORTVERSION= 3.0.0
CATEGORIES= devel python
MASTER_SITES= SF/py${PORTNAME:L}/py${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,15 +15,15 @@ COMMENT= Hierarchical database for Python
BUILD_DEPENDS= ${PYNUMPY} \
${LOCALBASE}/bin/cython:${PORTSDIR}/lang/cython \
${PYTHON_PKGNAMEPREFIX}numexpr>=1.4.1:${PORTSDIR}/math/py-numexpr
-LIB_DEPENDS= hdf5.7:${PORTSDIR}/science/hdf5-18 \
- lzo2.2:${PORTSDIR}/archivers/lzo2 \
- ucl.1:${PORTSDIR}/archivers/ucl
+LIB_DEPENDS= hdf5:${PORTSDIR}/science/hdf5-18 \
+ lzo2:${PORTSDIR}/archivers/lzo2 \
+ ucl:${PORTSDIR}/archivers/ucl
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-PLIST_FILES= bin/nctoh5 bin/ptdump bin/ptrepack
+PLIST_FILES= bin/pt2to3 bin/ptdump bin/ptrepack
OPTIONS_DEFINE= PYREX
PYREX_DESC= Use code generated by Pyrex to build
@@ -31,7 +31,6 @@ PYREX_DESC= Use code generated by Pyrex to build
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MPYREX}
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/Pyrex/__init__.py:${PORTSDIR}/devel/pyrex
@@ -64,4 +63,4 @@ post-install:
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-tables/distinfo b/devel/py-tables/distinfo
index cf40998b9afe..dc72973589d7 100644
--- a/devel/py-tables/distinfo
+++ b/devel/py-tables/distinfo
@@ -1,4 +1,4 @@
-SHA256 (tables-2.4.0.tar.gz) = 6a2ab6037ccde0636ce47e4475e671c45505029ebded333d403d7252cde18d57
-SIZE (tables-2.4.0.tar.gz) = 8947724
-SHA256 (pytablesmanual-2.4.0.pdf) = 49bf7261250e0e7efe0d561da7c9fd94eeec0dee346c6b47c6b886a9ea4765de
-SIZE (pytablesmanual-2.4.0.pdf) = 3084689
+SHA256 (tables-3.0.0.tar.gz) = 53532a59c8f03c3c5ef3c73c04f5bfd8384d6a3d508683cb87fc17af4c71dfe1
+SIZE (tables-3.0.0.tar.gz) = 6191726
+SHA256 (pytablesmanual-3.0.0.pdf) = 623cf4d64884c0c34996ac8d4208dd899450a96ddd64d1267c733da0a59a6ed6
+SIZE (pytablesmanual-3.0.0.pdf) = 2515096
diff --git a/devel/py-tables/files/patch-setup.py b/devel/py-tables/files/patch-setup.py
index f0a7d6aa21ba..c7c43f77884f 100644
--- a/devel/py-tables/files/patch-setup.py
+++ b/devel/py-tables/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2012-03-25 19:20:35.000000000 +0900
-+++ setup.py 2012-03-25 19:22:53.000000000 +0900
-@@ -96,8 +96,8 @@
+--- setup.py.orig 2013-08-20 10:38:37.000000000 +0800
++++ setup.py 2013-08-20 10:40:44.000000000 +0800
+@@ -133,8 +133,8 @@
debug = '--debug' in sys.argv
# Global variables
@@ -11,19 +11,19 @@
optional_libs = []
data_files = [] # list of data files to add to packages (mainly for DLL's)
-@@ -121,13 +121,12 @@
+@@ -160,13 +160,13 @@
add_from_path("CPATH", default_header_dirs)
add_from_path("C_INCLUDE_PATH", default_header_dirs)
add_from_flags("CPPFLAGS", "-I", default_header_dirs)
- default_header_dirs.extend(['/usr/include', '/usr/local/include'])
--
-+ default_header_dirs = ['/usr/include', '/usr/local/include','%%LOCALBASE%%/include']
++ default_header_dirs.extend(['/usr/include', '/usr/local/include','%%LOCALBASE%%/include'])
+
default_library_dirs = []
add_from_flags("LDFLAGS", "-L", default_library_dirs)
default_library_dirs.extend(
os.path.join(_tree, _arch)
-- for _tree in ('/', '/usr', '/usr/local')
-+ for _tree in ('/', '/usr', '/usr/local','%%LOCALBASE%%')
- for _arch in ('lib64', 'lib') )
+- for _tree in ('/usr/local', '/sw', '/opt', '/opt/local', '/usr', '/')
++ for _tree in ('/usr/local', '/sw', '/opt', '/opt/local', '/usr', '/','%%LOCALBASE%%')
+ for _arch in ('lib64', 'lib'))
default_runtime_dirs = default_library_dirs