aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordvl <dvl@FreeBSD.org>2018-01-18 00:33:27 +0800
committerdvl <dvl@FreeBSD.org>2018-01-18 00:33:27 +0800
commit0ca1cf19c899a921bc3d4367d39e9812b5449132 (patch)
tree75ddbbf4722c0594c858af6e659165d84ab4fa5b
parent01c755f517177fad1b84d6c0fca61b0a86683e85 (diff)
downloadfreebsd-ports-gnome-0ca1cf19c899a921bc3d4367d39e9812b5449132.tar.gz
freebsd-ports-gnome-0ca1cf19c899a921bc3d4367d39e9812b5449132.tar.zst
freebsd-ports-gnome-0ca1cf19c899a921bc3d4367d39e9812b5449132.zip
Fix build
was failing with: Error: '/bin/bash' is an invalid shebang you need USES=shebangfix for 'lib/ruby/gems/2.4/gems/passenger-5.1.12/dev/ci/tests/debian/run' Error: '/bin/bash' is an invalid shebang you need USES=shebangfix for 'lib/ruby/gems/2.4/gems/passenger-5.1.12/dev/ci/tests/rpm/run' Error: '/usr/local/bin/python2' is an invalid shebang you need USES=shebangfix for 'lib/ruby/gems/2.4/gems/passenger-5.1.12/src/cxx_supportlib/vendor-copy/libuv/gyp_uv.py' Approved by: portmgr@ (blanket approval)
-rw-r--r--www/rubygem-passenger/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/www/rubygem-passenger/Makefile b/www/rubygem-passenger/Makefile
index bb870b76fae1..fc01e054f6b5 100644
--- a/www/rubygem-passenger/Makefile
+++ b/www/rubygem-passenger/Makefile
@@ -3,6 +3,7 @@
PORTNAME= passenger
PORTVERSION= 5.1.12
+PORTREVISION= 1
CATEGORIES= www rubygems
MASTER_SITES= RG
PKGNAMEPREFIX= rubygem-
@@ -28,12 +29,14 @@ OPTIONS_DEFAULT= APACHE22
USE_RUBY= yes
RAKE_BIN= ${LOCALBASE}/bin/rake
-USES= cpe gem libtool shebangfix ssl
+USES= cpe gem libtool python:env shebangfix ssl
SHEBANG_FILES= \
src/cxx_supportlib/vendor-copy/libuv/gyp_uv.py \
dev/vagrant/nginx_start \
dev/vagrant/provision.sh \
dev/ci/run-tests-with-docker \
+ dev/ci/tests/debian/run \
+ dev/ci/tests/rpm/run \
dev/ci/scripts/setup-host-natively.sh \
dev/ci/scripts/docker-entrypoint-stage2.sh \
dev/ci/scripts/inituidgid \