aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-20 03:21:24 +0800
committererwin <erwin@FreeBSD.org>2005-12-20 03:21:24 +0800
commit0cf7118ea39603ff44daa037649549bd2dcacd1a (patch)
tree62245fcbedc50fa9b62ca8b291efb1f82a1acdea
parentbd57a966a3b697e08c0a91c10cab1d47cd250c7e (diff)
downloadfreebsd-ports-gnome-0cf7118ea39603ff44daa037649549bd2dcacd1a.tar.gz
freebsd-ports-gnome-0cf7118ea39603ff44daa037649549bd2dcacd1a.tar.zst
freebsd-ports-gnome-0cf7118ea39603ff44daa037649549bd2dcacd1a.zip
Extends base class with a "mmap" cache.
WWW: http://search.cpan.org/dist/Catalyst-Plugin-Cache-FastMmap/ PR: ports/90660 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FastMmap/Makefile30
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FastMmap/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-descr3
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-plist4
5 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d2f8054d31c5..71baebb65bc8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -498,6 +498,7 @@
SUBDIR += p5-Catalyst-Plugin-Authentication-Store-Htpasswd
SUBDIR += p5-Catalyst-Plugin-Authorization-ACL
SUBDIR += p5-Catalyst-Plugin-Authorization-Roles
+ SUBDIR += p5-Catalyst-Plugin-Cache-FastMmap
SUBDIR += p5-Catalyst-Plugin-DefaultEnd
SUBDIR += p5-Catalyst-Plugin-FillInForm
SUBDIR += p5-Catalyst-Plugin-FormValidator
diff --git a/www/p5-Catalyst-Plugin-Cache-FastMmap/Makefile b/www/p5-Catalyst-Plugin-Cache-FastMmap/Makefile
new file mode 100644
index 000000000000..685490de7590
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FastMmap/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Cache-FastMmap
+# Date created: Dec 19, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Cache-FastMmap
+PORTVERSION= 0.5
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Mmap cache for Catalyst
+
+BUILD_DEPENDS= p5-Catalyst>=0:${PORTSDIR}/www/p5-Catalyst \
+ p5-Cache-FastMmap>=0:${PORTSDIR}/devel/p5-Cache-FastMmap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Cache::FastMmap.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Cache-FastMmap/distinfo b/www/p5-Catalyst-Plugin-Cache-FastMmap/distinfo
new file mode 100644
index 000000000000..2bc532a0c15c
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FastMmap/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Cache-FastMmap-0.5.tar.gz) = 915bad156d581bfcf19b4c2a277e2bf7
+SHA256 (Catalyst-Plugin-Cache-FastMmap-0.5.tar.gz) = e06586e877e4186b9169e685870c0c588ab93bca298da56ae258045118b4b0d2
+SIZE (Catalyst-Plugin-Cache-FastMmap-0.5.tar.gz) = 2334
diff --git a/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-descr b/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-descr
new file mode 100644
index 000000000000..e5d9f44fabbc
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-descr
@@ -0,0 +1,3 @@
+Extends base class with a "mmap" cache.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Cache-FastMmap/
diff --git a/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-plist b/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-plist
new file mode 100644
index 000000000000..c08631eee016
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Catalyst/Plugin/Cache/FastMmap.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Cache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true