aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-03-08 15:17:24 +0800
committerahze <ahze@FreeBSD.org>2005-03-08 15:17:24 +0800
commit0d3cc004ec0bd8ec5872529dba293ce6225c2d6a (patch)
treeb32ebf03555ba012b359bcc9e95a13bafa1c209a
parent47ce894151025567811e06f9acd767e90305f97f (diff)
downloadfreebsd-ports-gnome-0d3cc004ec0bd8ec5872529dba293ce6225c2d6a.tar.gz
freebsd-ports-gnome-0d3cc004ec0bd8ec5872529dba293ce6225c2d6a.tar.zst
freebsd-ports-gnome-0d3cc004ec0bd8ec5872529dba293ce6225c2d6a.zip
- Add graphics/gstreamer-plugins-cairo
-rw-r--r--Mk/bsd.gstreamer.mk21
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gstreamer-plugins-cairo/Makefile14
-rw-r--r--graphics/gstreamer-plugins-cairo80/Makefile14
4 files changed, 41 insertions, 9 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 50e3d96f181a..348bf78dc3e3 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -52,13 +52,14 @@ GST_SHLIB_VERSION= 1
#
# These are the current supported gstreamer-plugins modules
#
-_USE_GSTREAMER_ALL= a52dec aalib artsd audiofile cdaudio cdparanoia dirac \
- dts dv dvd esound faac faad ffmpeg flac gdkpixbuf \
- gnomevfs gsm hermes ivorbis jack jpeg jpeg-mmx ladspa \
- lame libcaca libfame libmng libpng libvisual mad mikmod \
- mpeg2dec mpeg2enc mplex musepack musicbrainz nas sdl \
- shout sidplay smoothwave sndfile speex theora ogg pango \
- polypaudio swfdec vorbis xine xvid
+_USE_GSTREAMER_ALL= a52dec aalib artsd audiofile cairo cdaudio cdparanoia \
+ dirac dts dv dvd esound faac faad ffmpeg flac \
+ gdkpixbuf gnomevfs gsm hermes ivorbis jack jpeg \
+ jpeg-mmx ladspa lame libcaca libfame libmng libpng \
+ libvisual mad mikmod mpeg2dec mpeg2enc mplex musepack \
+ musicbrainz nas sdl shout sidplay smoothwave sndfile \
+ speex theora ogg pango polypaudio swfdec vorbis xine \
+ xvid
# other plugins
OTHER_GSTREAMER_PLUGINS+= core yes
@@ -143,6 +144,8 @@ sdl_PLIST= libgstsdlvideosink
aalib_DEPENDS= graphics/gstreamer-plugins-aalib
aalib_PLIST= libgstaasink
+cairo_DEPENDS= graphics/gstreamer-plugins-cairo
+
gdkpixbuf_DEPENDS= graphics/gstreamer-plugins-gdkpixbuf
hermes_DEPENDS= graphics/gstreamer-plugins-hermes
@@ -166,8 +169,6 @@ libvisual_DEPNDS= graphics/gstreamer-plugins-libvisual
swfdec_DEPENDS= graphics/gstreamer-plugins-swfdec
-theora_DEPENDS= multimedia/gstreamer-plugins-theora
-
# Multimedia Plugins Section
dirac_DEPENDS= multimedia/gstreamer-plugins-dirac
@@ -192,6 +193,8 @@ mpeg2enc_DEPENDS= multimedia/gstreamer-plugins-mpeg2enc
mplex_DEPENDS= multimedia/gstreamer-plugins-mplex
+theora_DEPENDS= multimedia/gstreamer-plugins-theora
+
xine_DEPENDS= multimedia/gstreamer-plugins-xine
xvid_DEPENDS= multimedia/gstreamer-plugins-xvid
diff --git a/graphics/Makefile b/graphics/Makefile
index 3b6e1df5d31e..53545d52f454 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -162,6 +162,7 @@
SUBDIR += gridpix
SUBDIR += gsculpt
SUBDIR += gstreamer-plugins-aalib
+ SUBDIR += gstreamer-plugins-cairo
SUBDIR += gstreamer-plugins-gdkpixbuf
SUBDIR += gstreamer-plugins-hermes
SUBDIR += gstreamer-plugins-jpeg
diff --git a/graphics/gstreamer-plugins-cairo/Makefile b/graphics/gstreamer-plugins-cairo/Makefile
new file mode 100644
index 000000000000..63570dc7fd38
--- /dev/null
+++ b/graphics/gstreamer-plugins-cairo/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: gstreamer-plugins-cairo
+# Date created: Mar 8 2005
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= graphics
+
+GST_PLUGIN= cairo
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer-plugins-cairo80/Makefile b/graphics/gstreamer-plugins-cairo80/Makefile
new file mode 100644
index 000000000000..63570dc7fd38
--- /dev/null
+++ b/graphics/gstreamer-plugins-cairo80/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: gstreamer-plugins-cairo
+# Date created: Mar 8 2005
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= graphics
+
+GST_PLUGIN= cairo
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"