aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2004-03-13 18:33:18 +0800
committernetchild <netchild@FreeBSD.org>2004-03-13 18:33:18 +0800
commit0d4342c909c7dc99f61d3638d3bab3d7e088da31 (patch)
tree088908af41470bc42108d408501ad5ea584d8a28
parent0920536511e0c309d6d8ed5af6b23f633cc0d0f5 (diff)
downloadfreebsd-ports-gnome-0d4342c909c7dc99f61d3638d3bab3d7e088da31.tar.gz
freebsd-ports-gnome-0d4342c909c7dc99f61d3638d3bab3d7e088da31.tar.zst
freebsd-ports-gnome-0d4342c909c7dc99f61d3638d3bab3d7e088da31.zip
- some base system headers know about icc now, don't override them
where appropriate [1] - make portlint happy [1] - sync icc7 and icc [1] - add linux_base as a patch depends for icc v8 Submitted by: Marius Strobl <marius@alchemy.franken.de> [1] Requested by: maintainer [1]
-rw-r--r--lang/icc/Makefile17
-rw-r--r--lang/icc/pkg-plist6
-rw-r--r--lang/icc7/Makefile20
-rw-r--r--lang/icc7/files/stdarg.h4
-rw-r--r--lang/icc7/pkg-plist8
5 files changed, 41 insertions, 14 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 0995a1f64a73..d88cd3ae9515 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icc
PORTVERSION= 8.0.058.p060
+PORTREVISION= 1
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_pc_${PORTVERSION:C/\.p.+$//}
@@ -21,6 +22,7 @@ DISTFILES+= ${DISTNAME}_${PATCHLEVEL}${EXTRACT_SUFX}
.endif
EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
+PATCH_DEPENDS= ${LINUXBASE}/etc/redhat-release:${PORTSDIR}/emulators/linux_base
RESTRICTED= Intel forbids any redistribution
NO_PACKAGE= ${RESTRICTED}
@@ -53,6 +55,12 @@ EXTRACT_AFTER_ARGS= | tar -xf - \
ICCCFGVAL!= ${UNAME} -r | ${SED} -e 's/\..*//'
+.if ( ${OSVERSION} < 502108 )
+PLIST_SUB+= STDARG_H="" SYS_CDEFS_H=""
+.else
+PLIST_SUB+= STDARG_H="@comment " SYS_CDEFS_H="@comment "
+.endif
+
.for file in ${DISTFILES}
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${file})
IGNORE= "Go to Intel Premier Support, https://premier.intel.com, to obtain ${DISTFILES}. Product updates such as this compiler are posted regularly on Premier Support. You must have a license to obtain access to Premier Support. If you do not already have a license go to ${ICC_SITE} to review licensing options \(evaluation, commercial, and free non-commercial\) and obtain a license. Put ${DISTFILES} into ${DISTDIR} and run make again"
@@ -119,9 +127,12 @@ post-patch:
# Provide a more FreeBSD'ish compile environment
.for i in icc.cfg icpc.cfg
@${ECHO_CMD} -e "-no-gcc\n-Qlocation,ld,${PREFIX}/${COMPILERDIR}/bin/ldwrapper\n\n-wr1125\n-we140\n\n-Ulinux\n-U__linux__\n-U__linux\n-U__gnu_linux__\n\n-D__FreeBSD__=${ICCCFGVAL}\n\n" >>${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
-.if ${OSVERSION} >= 500039
+.if ( ${OSVERSION} >= 500039 )
@${ECHO_CMD} -e "-D__wchar_t=__ct_rune_t\n" >>${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
.endif
+.if ( ${OSVERSION} >= 502108 )
+ @${ECHO_CMD} -e "-restrict\n" >>${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
+.endif
@${CHMOD} a-x,g-w ${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
.endfor
# C++ hack for icpc
@@ -130,9 +141,11 @@ post-patch:
@cd ${WRKSRC}/opt/${COMPILERDIR}/bin/ && ${LN} -s icc.cfg iccbin.cfg \
&& ${LN} -s icpc.cfg icpcbin.cfg
# Hack while there's no support for icc in the stdarg.h and sys/cdefs.h.
+.if ( ${OSVERSION} < 502108 )
@${CP} ${FILESDIR}/stdarg.h ${WRKSRC}/opt/${COMPILERDIR}/include
@${MKDIR} ${WRKSRC}/opt/${COMPILERDIR}/include/sys
@${CP} ${FILESDIR}/cdefs.h ${WRKSRC}/opt/${COMPILERDIR}/include/sys
+.endif
.if ( ${OSVERSION} >= 470101 && ${OSVERSION} < 500000 ) || \
( ${OSVERSION} >= 500042 )
@@ -142,7 +155,7 @@ OBJCOPY_OPS= --redefine-sym stdin=__stdinp \
.endif
do-build:
-# Use the Linux ABI for the binaries
+# Use the Linux ABI for the binaries
.for i in codecov iccbin iccfilt icpcbin icpi mcpcom profmerge proforder tselect xiar xild
@${BRANDELF} -t Linux ${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
.endfor
diff --git a/lang/icc/pkg-plist b/lang/icc/pkg-plist
index 0d6f25b3a3d3..5be7f0dcc782 100644
--- a/lang/icc/pkg-plist
+++ b/lang/icc/pkg-plist
@@ -1445,9 +1445,9 @@
%%COMPILERDIR%%/include/pmmintrin.h
%%COMPILERDIR%%/include/proto.h
%%COMPILERDIR%%/include/sse2mmx.h
-%%COMPILERDIR%%/include/stdarg.h
-%%COMPILERDIR%%/include/sys/cdefs.h
-@dirrm %%COMPILERDIR%%/include/sys
+%%STDARG_H%%%%COMPILERDIR%%/include/stdarg.h
+%%SYS_CDEFS_H%%%%COMPILERDIR%%/include/sys/cdefs.h
+%%SYS_CDEFS_H%%@dirrm %%COMPILERDIR%%/include/sys
%%COMPILERDIR%%/include/xmm_func.h
%%COMPILERDIR%%/include/xmm_utils.h
%%COMPILERDIR%%/include/xmmintrin.h
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index 824856ecae56..248a0542e248 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -7,7 +7,7 @@
PORTNAME= icc7
PORTVERSION= 7.1.035
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_pc_${PORTVERSION}
@@ -27,7 +27,6 @@ CONFLICTS= linux_devtools* ifc*
USE_LINUX= yes
USE_REINPLACE= yes
-USE_SIZE= yes
NO_WRKSUBDIR= yes
NO_FILTER_SHLIBS= yes
@@ -50,7 +49,11 @@ EXTRACT_AFTER_ARGS= | tar -xf - \
ICCCFGVAL!= ${UNAME} -r | ${SED} -e 's/\..*//'
-OBJCOPY?= /usr/bin/objcopy
+.if ( ${OSVERSION} < 502108 )
+PLIST_SUB+= STDARG_H="" SYS_CDEFS_H=""
+.else
+PLIST_SUB+= STDARG_H="@comment " SYS_CDEFS_H="@comment "
+.endif
.for file in ${DISTNAME}
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${file}${EXTRACT_SUFX})
@@ -90,7 +93,7 @@ pre-patch:
@${CHMOD} a-x ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/Errormatch.txt
# Use the Linux ABI for the binaries
.for i in iccbin iccfilt icid icpcbin icpi mcpcom profmerge proforder xiar xild
- @brandelf -t Linux ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
+ @${BRANDELF} -t Linux ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
.endfor
post-patch:
@@ -112,16 +115,23 @@ post-patch:
@${REINPLACE_CMD} -i "" -e 's:-Xlinker -rpath -Xlinker <INSTALLDIR>/${COMPILERDIR}/ia32/lib::g' \
${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
@${ECHO_CMD} -e "-Qlocation,ld,${PREFIX}/intel/${COMPILERDIR}/ia32/bin/ldwrapper\n\n-wr1125\n-we140\n\n-Ulinux\n-U__linux__\n-U__linux\n-U__gnu_linux__\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
-.if ${OSVERSION} >= 500039
+.if ( ${OSVERSION} >= 500039 )
@${ECHO_CMD} -e "-D__wchar_t=__ct_rune_t\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
.endif
+.if ( ${OSVERSION} >= 502108 )
+ @${ECHO_CMD} -e "-restrict\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
+.endif
@${CHMOD} a-x,g-w ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
.endfor
# C++ hack for icpc
@${ECHO_CMD} -e "\n-I${PREFIX}/include/stlport\n-Qoption,ld,-CPLUSPLUS\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/icpc.cfg
@cd ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ && ${LN} -s icc.cfg iccbin.cfg && ${LN} -s icpc.cfg icpcbin.cfg
# Hack while there's no support for icc in the stdarg.h of FreeBSD.
+.if ( ${OSVERSION} < 502108 )
@${CP} ${FILESDIR}/stdarg.h ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/include
+.else
+ @${RM} -rf ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/include/sys
+.endif
.if ( ${OSVERSION} >= 470101 && ${OSVERSION} < 500000 ) || \
( ${OSVERSION} >= 500042 )
diff --git a/lang/icc7/files/stdarg.h b/lang/icc7/files/stdarg.h
index c1d8b38de58c..e2f40091f821 100644
--- a/lang/icc7/files/stdarg.h
+++ b/lang/icc7/files/stdarg.h
@@ -1,3 +1,5 @@
+#ifndef __INTEL_COMPILER_STDARG_H_
+#define __INTEL_COMPILER_STDARG_H_
#include_next <stdarg.h>
@@ -7,3 +9,5 @@
#define va_copy(dest, src) ((dest) = (src))
#endif
#endif
+
+#endif /* !__INTEL_COMPILER_STDARG_H_ */
diff --git a/lang/icc7/pkg-plist b/lang/icc7/pkg-plist
index 67426a5a00ab..4965911ad588 100644
--- a/lang/icc7/pkg-plist
+++ b/lang/icc7/pkg-plist
@@ -1124,9 +1124,9 @@ intel/%%COMPILERDIR%%/ia32/include/pgouser.h
intel/%%COMPILERDIR%%/ia32/include/pmmintrin.h
intel/%%COMPILERDIR%%/ia32/include/proto.h
intel/%%COMPILERDIR%%/ia32/include/sse2mmx.h
-intel/%%COMPILERDIR%%/ia32/include/stdarg.h
-intel/%%COMPILERDIR%%/ia32/include/sys/cdefs.h
-@dirrm intel/%%COMPILERDIR%%/ia32/include/sys
+%%STDARG_H%%intel/%%COMPILERDIR%%/ia32/include/stdarg.h
+%%SYS_CDEFS_H%%intel/%%COMPILERDIR%%/ia32/include/sys/cdefs.h
+%%SYS_CDEFS_H%%@dirrm intel/%%COMPILERDIR%%/ia32/include/sys
intel/%%COMPILERDIR%%/ia32/include/typeinfo
intel/%%COMPILERDIR%%/ia32/include/xmmintrin.h
intel/%%COMPILERDIR%%/ia32/include/xmtx.h
@@ -1354,5 +1354,5 @@ intel/%%COMPILERDIR%%/ia32/lib/libunwind.a
%%PORTDOCS%%@dirrm intel/%%COMPILERDIR%%/training/templ_im
%%PORTDOCS%%@dirrm intel/%%COMPILERDIR%%/training
@dirrm intel/%%COMPILERDIR%%
-@unexec rmdir %D/intel/licenses >/dev/null 2>&1 || echo '*** license directory (%D/intel/licenses/) not removed, it may contain a license'
+@unexec rmdir %D/intel/licenses >/dev/null 2>&1 || echo '*** License directory (%D/intel/licenses/) not removed, it may contain a license.'
@unexec rmdir %D/intel >/dev/null 2>&1 || true